Solved

Can't get Video Calling to work as it should.


1.  Both phones are listed as fully supported for video calling.  LG G4, S7.

  2.  Works perfectly if both phones are set for, and calls routed, via cell.  Video quality is almost like HD - even when cast to big screen via Chromecast.

3.  However - When I set my phone for wifi calling, the video call drops after 20-30 seconds.  Get an error message.  (Can't recall exact wording.)  Can make voice calls over wifi w. no problem.  Wifi connection is 90+Mbps UP and Down.  

      I had assumed that all video calls  (since they are data) would use wifi automatically no matter how you set the preferred routing for voice calls.  That is not the case. 

icon

Best answer by tmo_chris 27 April 2017, 17:11

Oh no! It sounds like this issue is more intermittent while on WiFi and works over the cell network just fine right? If this is the case, the issue is not going to be with the phones or the T-Mobile network leaving the WiFi as the only variable. I know your speeds are fast enough to maintain a call but there may be something else causing the quality of your WiFi to dip while on a video call causing it to drop. I would recommended reaching out to your ISP and seeing if they can run some tests on your connection while you place a video call to see if they can find any abnormalities.

View original

13 replies

Hey, @miket!

I'm sorry it took us a lil' bit to get back to you. Hmm, that's pretty odd that if you're connected to WiFi that the video call drops. That error message would be super helpful to see. Are you able to capture a screenshot of it when it happens again? From the sounds of it, a ticket may need to be filed so our Engineers can figure out where the disconnect is while connected to WiFi. I don't suspect that it's your WiFi connection but just to be on the safe side, have you tried another WiFi network?

OK.  Seemed to work on a one  test I did on a Comcast wifi connection which is much slower.  I'll do a thorough test at the end of this next week when wife gets back w. her S7.

  Also worked once or twice on fast home wifi.  

Awesome! I'm glad there have been a few successful tests. 😊 Yes, keep me updated on how things go later on this week.

Userlevel 6

Hey @miket‌!  I just wanted to check in here and see how things are going with your video calls!  Has the improvement you noticed held steady?

- Marissa

Just checking in here to see how things are going. Let us know!

Using wifi does NOT work.  Tidbits posted a new thread a couple days ago on this same subject  Doesn't work on wifi for him either.

Oh no! It sounds like this issue is more intermittent while on WiFi and works over the cell network just fine right? If this is the case, the issue is not going to be with the phones or the T-Mobile network leaving the WiFi as the only variable. I know your speeds are fast enough to maintain a call but there may be something else causing the quality of your WiFi to dip while on a video call causing it to drop. I would recommended reaching out to your ISP and seeing if they can run some tests on your connection while you place a video call to see if they can find any abnormalities.

Our wifi is over 90Mbps UP and DOWN.  (From a subsidiary of Google at $25/mo.!! - because all 50 units in bldg subscribe.)   An active user, here, (#Tidbits), posted the same problem in the past week.  I haven't had a chance to try a real test from another ISP.  

  Am also starting to try Google's video app called "Google Duo".  Works to/from any phone  any carrier.  

If i had to take a guess it may be a port issue on the router. I wanted to ask though when you place the video call are you connected to wifi when you do it or do you start out on LTE and then turn wifi? I know thats odd but I want to be clear.

I set the phone for wifi calling ONLY.    (Like I do when overseas when calling U.S. numbers.)   I can make regular phone calls over wifi.  Can NOT make video calls using the TM video calling.

      I can make video calls when connected to cellular.

Userlevel 6

TL;DR

Get the T-Mobile Cellspt Router for either $0 or $25 deposit. Guaranteed to work.

Userlevel 7
Badge +12

tmo_chris wrote:

Oh no! It sounds like this issue is more intermittent while on WiFi and works over the cell network just fine right? If this is the case, the issue is not going to be with the phones or the T-Mobile network leaving the WiFi as the only variable. I know your speeds are fast enough to maintain a call but there may be something else causing the quality of your WiFi to dip while on a video call causing it to drop. I would recommended reaching out to your ISP and seeing if they can run some tests on your connection while you place a video call to see if they can find any abnormalities.

The S8 and seems like newer devices no longer goes over WiFi at all.

The S8 shows the icon and says LTE while on the call.  If you kill your LTE and make a call it'll give you an error message when trying to place a call.

Userlevel 7
Badge +12

Here's some screenshots

My data speeds are 500d/50u

Everything on Going through LTE.

Yes I am balding 😜

Here is with LTE off

Reply