Solved

Can't sign in to my t-mobile ID account after upgrading to post-paid sim card

  • 19 April 2019
  • 6 replies
  • 16 views

Hello everyone, i am having trouble with my account.

I used to have a prepaid SIM card and made an iD t-mobile account and everything worked fine. Then I decided i wanted a Post paid SIM card with the same number as the old one.    Later I tried to sign in to my ID account that i have and now i can't sign in to view my account or do anything.

Does the website thinks I still have a prepaid sim card?

I have the same phone number as before, i am using the same email address as always but the same error comes up.

Service Unavailable.

Uh-oh, it looks like we have our wires crossed. Please try again later.

I can't make another ID account with another email using the same phone number because it says it's already taken. Changing the password does nothing (already tried).

Speaking to someone using the 611 number does absolutely nothing, they only say to try again later, but that doesn't solve the problem.

Using the 611 number i spoke to 3 different people, in english and spanish. I even got a a trouble Ticket number (whatever does that means).

I'm not even sure how i got to sign in here to this website to be honest.

Please help, don't know what else to do to solve this.

icon

Best answer by tmo_mike_c 22 April 2019, 20:20

Ah that's no good the site's giving you fits. You should be able to Community-2153​ had get this fixed with a Help Desk

View original

6 replies

Userlevel 5
Badge +12

This happened to me as well.  Baaed on my understanding of what I was told back in November of last year.  Porting a number from prepaid to postpaid still closes the prepaid account, which terminates the online account.  Postpaid and prepaid accounts have different account numbers.

I understand they are different accounts, i'm not trying to sign in to the old one, i'm trying to sign in to my new one. 😥

Did you ever solved your problem with the account or you still can't sign in?

Userlevel 5
Badge +12

I had a new account login created, which worked. 

ok. Did you had to use another email account?

Userlevel 5
Badge +12

Unfortunately, yeah.  I was told it was easier doing so because even closed accounts remain in the system for a while before being archived. 

Userlevel 6
Badge +13

Ah that's no good the site's giving you fits. You should be able to Community-2153​ had get this fixed with a Help Desk

Reply