Cant Sign into My T-Mobile

  • 10 August 2018
  • 3 replies

Ever since I started my service with T-Mobile (2months ago) I have not been able to sign into my My T-Mobile, on the app it says it is not ready for me yet and on the web says I am unauthorized and to contact customer support. I have called them multiple times and they tell me "we will start a ticket for this issue and within 24-72 hours it should allow you to log in" and the last time I called the gentleman said "we will delete your account completely and within a week you can go in and create a new one" I still can not log into my account. This really puts a dilemma on things for me. Please help.


Best answer by magentatechie 10 August 2018, 01:04

View original

3 replies

Userlevel 4
Badge +10

Hey there, I'm sorry to hear the website has been giving you such a hard time. 😥 Do you still have the ticket number? The mods here can check the status of a trouble ticket but don't have any direct access to your account.  Since 611 wasn't very helpful for you, I do recommend reaching out to T-Force via Facebook or Twitter for further assistance.

Userlevel 4

Just checking in here to see how things are going. Please let us know if you still need help.

Chris,maybe you can be helpful because tech support at T-mobile is an exercise in frustration, as is t-mobile website.  I am close to switching to Verizon which offers excellent tech support and also ahs a website that actually works.  Here's my problem.  I can sign into t-mobile but when I click on my voicemail, it makes me sign in to Digits.  When I answer the security questions correctly and attempt to register, I get the error message that says "there was an error contacting the server.  Try again later.  Well I have tried again yesterday and today and same error message.  I even downloaded the Digits app to my desktop even though I have no use for it and I am also using Chrome browser on Windows 10.  So that's the first problem.  The second issue is that I want to shut off my voicemail and one wold think that that this simple task wold be explained under voicemail instructions but it is not and when I called tech support, they told me to turn it on an doff is done by pressing the pound key then 796 and the pound key again. This is incorrect.