Solved

Email to SMS (tmomail.net) is blocking our domain for spam.


I work for a local fire department, which uses the phonenumber@tmomail.net gateway to alert members of the fire department with (T-Mobile service) of emergencies/disasters. We use similar gateways from other carriers for those respective members, and they are without issue at this time. This system from T-Mobile has worked flawlessly for the last 2 years, until recently, which we are now getting bounced by the server and getting the mail messages kicked back with the following error (X's represent the member's phone number):

mx197.us-east-2b.ess.aws.cudaops.com gave this error:
permanent failure for one or more recipients (XXXXXXXXXX@tmomail.net:blocked)

i've tried sending messages individually, and even sending out messages as MMS, and I'm still getting bounce backs.

I see "srickar" on this site answering questions, as the spam admin for tmomail.net, and I was wondering if they'd be able to point me in the right direction.

Not only am I the one handling this issue... I'm also a T-Mobile user, and am one of the end users effected by it.

Thanks for any input.

icon

Best answer by srickar 29 April 2021, 15:50

View original

This topic has been closed for comments

153 replies

Hi @srickar - We are having the same problem receiving a 550 permanent error blocking email messages at mx-inbound46-105.us-east-2c.ess.aws.cudaops.com to 10digitnumber@tmomail.net. Our whole IT team receives server alerts and is having the same issue. Any help will be greatly appreciated. Thank you.

Hello, Is this thread still active?

Or is there another source to get this particular issue resolved?

 

Thanks,

AR

 

Hello,

I just tried the support phone number again in hopes to get this issue resolved through that route. After being on hold for an hour we opened a ticket number #51769606 on this same issue if you want to reference.

 

They said engineering would get back to us in 72 hours or something.

This looks to be a known issue. Could somebody please unblock us like has been done for all the other users in this thread?

 

Need to be able to send alerts to our phones without being blocked..

 

Thanks again,

AR

I am having the same issue. I was on the phone for 45 minutes to no avail. The tech support said they’d call me back within 24 hours. Never heard back from them and I am still haveing the same issue. 

 

This is the message I get back every time:  

Delivery to the following recipients failed permanently:

 

   * 785979XXX@tmomail.net

 

Reason: Delivery to 209.222.82.255 failed. Return Code: 550; Return Message: 550 permanent failure for one or more recipients (785979XXXX@tmomail.net:blocked)

 

Hey! I have a raspberry PI at home that has been sending out emails/(SMS Messages) to my Tmobile phone for years and all of a sudden about a week or so ago it no longer works.  My PI still sends emails to my other email addresses, just not the phone.  I am sending it using postfix and relaying through my personal domain email account. Is Tmobile blocking certain domains now?  I can send an email directly from my email client, just not through the relay. Does Tmobile need to whitelist my home IP address?  I contacted support but they had no idea what I was talking about.  Thanks in advance. 

Any updated on this? This suddenly stopped working for me last week

Hello @srickar  We use email to text for monitoring alerting and other notifications.  This has been working for years.  Suddenly, earlier this month, in one of three datacenters email to text stopped working.   The postfix mail server has the following error message:

Mar 18 19:04:07 xxxxxxx-xxxxxxx postfix/smtp[85822]: 60E961A002B: to=<xxxxxxxxxx@tmomail.net>, relay=d79033b.ess.barracudanetworks.com[209.222.82.253]:25, delay=5.7, delays=0/0/1.6/4.1, dsn=5.0.0, status=bounced (host d79033b.ess.barracudanetworks.com[209.222.82.253] said: 550 permanent failure for one or more recipients (xxxxxxxxxx@tmomail.net:blocked) (in reply to end of DATA command))


We have a QA data center using .net domain, US data center using .com domain, and an EU data center using an .eu domain.   I am able to send an email to text and receive the text from the QA and US data center. I am not able to receive any text messages from the EU data center.  As mentioned, this was working correctly and suddenly started failing.

Userlevel 3
Badge +4

Hello @srickar  We use email to text for monitoring alerting and other notifications.  This has been working for years.  Suddenly, earlier this month, in one of three datacenters email to text stopped working.   The postfix mail server has the following error message:

Mar 18 19:04:07 xxxxxxx-xxxxxxx postfix/smtp[85822]: 60E961A002B: to=<xxxxxxxxxx@tmomail.net>, relay=d79033b.ess.barracudanetworks.com[209.222.82.253]:25, delay=5.7, delays=0/0/1.6/4.1, dsn=5.0.0, status=bounced (host d79033b.ess.barracudanetworks.com[209.222.82.253] said: 550 permanent failure for one or more recipients (xxxxxxxxxx@tmomail.net:blocked) (in reply to end of DATA command))


We have a QA data center using .net domain, US data center using .com domain, and an EU data center using an .eu domain.   I am able to send an email to text and receive the text from the QA and US data center. I am not able to receive any text messages from the EU data center.  As mentioned, this was working correctly and suddenly started failing.

================

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Userlevel 3
Badge +4

Any updated on this? This suddenly stopped working for me last week

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Userlevel 3
Badge +4

Hey! I have a raspberry PI at home that has been sending out emails/(SMS Messages) to my Tmobile phone for years and all of a sudden about a week or so ago it no longer works.  My PI still sends emails to my other email addresses, just not the phone.  I am sending it using postfix and relaying through my personal domain email account. Is Tmobile blocking certain domains now?  I can send an email directly from my email client, just not through the relay. Does Tmobile need to whitelist my home IP address?  I contacted support but they had no idea what I was talking about.  Thanks in advance. 

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Userlevel 3
Badge +4

I am having the same issue. I was on the phone for 45 minutes to no avail. The tech support said they’d call me back within 24 hours. Never heard back from them and I am still haveing the same issue. 

 

This is the message I get back every time:  

Delivery to the following recipients failed permanently:

 

   * 785979XXX@tmomail.net

 

Reason: Delivery to 209.222.82.255 failed. Return Code: 550; Return Message: 550 permanent failure for one or more recipients (785979XXXX@tmomail.net:blocked)

 

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Userlevel 3
Badge +4

Hello, Is this thread still active?

Or is there another source to get this particular issue resolved?

 

Thanks,

AR

 

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Userlevel 3
Badge +4

Hi @srickar - We are having the same problem receiving a 550 permanent error blocking email messages at mx-inbound46-105.us-east-2c.ess.aws.cudaops.com to 10digitnumber@tmomail.net. Our whole IT team receives server alerts and is having the same issue. Any help will be greatly appreciated. Thank you.

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Not sure if this could help anyone, but it has worked for my company. When adding the group of contact numbers to the email to send through the sms gateway- the sender placed the contacts under the “BCC” section of the email. This then sent the message to each person in the group individually and the messages are now being received by T-Mobile users. We have roughly 100 people in our contact groups- and the sender doing this has finally seemed to fix our issue.

I have this problem too.  System failures are sent from our domain hosted at Office 365 and are always blocked.  I have another domain where sometimes they get through and sometimes blocked.  Need some way to whitelist domains so they are never blocked.  I called TMobile service and they said the only thing they could do was remove SCAM ID, but that hasn't seemed to help.  I think that is for calls, not messages.

Hello,

I’m having this same issue. I’m sending individual text messages from my personal gmail account and it works great for all other Mobile Providers, but it’s getting blocked for Tmobile. Can someone help with diagnosing the issue?

@srickar Would love your assistance with this issue as well. I use xxxxxxxxxx@tmomail.net to forward emails from specific senders to my phone (so I am aware of them immediately.) It’s crucial that I receive these in a timely fashion, but am now not receiving them at all. Any help would be appreciated, any further info you’d need from me? Thanks!

Having same exact issues to my number from home automation system. Really relay on this. 

Badge

Our service is also experiencing the same issues. We used to have the 554; banned content every now and then but recently the entire domain has been blocked, even for new accounts verification.

srickar,

Can you help us with some messages that were blocked? We tried to sent an email to text notification regarding an outage to our employees and all of the tmomail.net messages were blocked as spam.

The message was “ProgramName1 and ProgramName2 currently down. Will update as more information is available.” with a subject “Some Services Down” from an actual users email rather than a generic “info” or “support”.

Thanks,

J

Hello @srickar,

I am experiencing the same issue with sending emails to mytmobilenumber@tmomail.net.

The sending email address is Microsoft Azure <azure-noreply@microsoft.com>.

Is there a way to whitelist the Microsoft domain?

Or can the email address be whitelisted?

We use alerts from Azure to send to our cell phone for after hours on-call situations.

I have also been in contact with Microsoft and currently they are not able to change the email address.

Appreciate any help or insight you can provide.

Thanks!

Userlevel 3
Badge +4

Hello @srickar,

I am experiencing the same issue with sending emails to mytmobilenumber@tmomail.net.

The sending email address is Microsoft Azure <azure-noreply@microsoft.com>.

Is there a way to whitelist the Microsoft domain?

Or can the email address be whitelisted?

We use alerts from Azure to send to our cell phone for after hours on-call situations.

I have also been in contact with Microsoft and currently they are not able to change the email address.

Appreciate any help or insight you can provide.

Thanks!

Hi @darockk 

Sorry we cannot whitelist external domains. Please send me a PM and I can investigate further. Envelopes like azure-noreply@microsoft.com are widely configured and the sender envelope is cosmetic purposes only.

I’m having this problem and would love to get some help @srickar srickar on how to fix this!  Thanks. 

Userlevel 3
Badge +4

Hello @srickar,

I am experiencing the same issue with sending emails to mytmobilenumber@tmomail.net.

The sending email address is Microsoft Azure <azure-noreply@microsoft.com>.

Is there a way to whitelist the Microsoft domain?

Or can the email address be whitelisted?

We use alerts from Azure to send to our cell phone for after hours on-call situations.

I have also been in contact with Microsoft and currently they are not able to change the email address.

Appreciate any help or insight you can provide.

Thanks!

I responded to your PM and to remind myself here that we have an ongoing conversation. Due to the configuration, it will require either change in the envelope to accommodate Microsoft restriction on DKIM/SPF/DMARC.

 

Thanks.

Userlevel 3
Badge +4

I’m having this problem and would love to get some help @srickar srickar on how to fix this!  Thanks. 

Hi @stacyb 

Please send me a PM and I can investigate the block reason. Thanks.