Solved

Email to SMS (tmomail.net) is blocking our domain for spam.


I work for a local fire department, which uses the phonenumber@tmomail.net gateway to alert members of the fire department with (T-Mobile service) of emergencies/disasters. We use similar gateways from other carriers for those respective members, and they are without issue at this time. This system from T-Mobile has worked flawlessly for the last 2 years, until recently, which we are now getting bounced by the server and getting the mail messages kicked back with the following error (X's represent the member's phone number):

mx197.us-east-2b.ess.aws.cudaops.com gave this error:
permanent failure for one or more recipients (XXXXXXXXXX@tmomail.net:blocked)

i've tried sending messages individually, and even sending out messages as MMS, and I'm still getting bounce backs.

I see "srickar" on this site answering questions, as the spam admin for tmomail.net, and I was wondering if they'd be able to point me in the right direction.

Not only am I the one handling this issue... I'm also a T-Mobile user, and am one of the end users effected by it.

Thanks for any input.

icon

Best answer by srickar 29 April 2021, 15:50

View original

This topic has been closed for comments

153 replies

I work for a CRM company using email to send SMS alert to our users, and tomomail has started blocking us.  @srickar please help!  I've talked to 8 different people over chat/phone over the last two days trying to get resolution for what sounds like an issue you're very familiar with.  I followed you yesterday, but not sure what to do next.  Your Support team tells me they have discontinued support for @tmomail.net altogether so there is nothing they ca do?  HELP!!  My case # is 40179836

I am having the same issue - what can I do to get assistance? t mobile is blocking our emails from our domain bestcattlesales.com @srickar​ can you please help me - I even messaged this on another thread. I have had no helps to date.

I am having the same issue. I was on the phone for 45 minutes to no avail. The tech support said they’d call me back within 24 hours. Never heard back from them and I am still haveing the same issue. 

 

This is the message I get back every time:  

Delivery to the following recipients failed permanently:

 

   * 785979XXX@tmomail.net

 

Reason: Delivery to 209.222.82.255 failed. Return Code: 550; Return Message: 550 permanent failure for one or more recipients (785979XXXX@tmomail.net:blocked)

 

Hey! I have a raspberry PI at home that has been sending out emails/(SMS Messages) to my Tmobile phone for years and all of a sudden about a week or so ago it no longer works.  My PI still sends emails to my other email addresses, just not the phone.  I am sending it using postfix and relaying through my personal domain email account. Is Tmobile blocking certain domains now?  I can send an email directly from my email client, just not through the relay. Does Tmobile need to whitelist my home IP address?  I contacted support but they had no idea what I was talking about.  Thanks in advance. 

Hello @srickar 

I have had this problem for months now.  I have had two support tickets submitted which did not resolve the problem.  The first ticket response simply said that there was not a problem and that the text messages were being sent through.  This of course was not the case so I again called customer support who submitted another ticket.  The response to this ticket was that GoDaddy had to update its system.  I asked what specifically needed to be changed and the rep did not have that info.  I called go daddy and asked if their email servers were up to date and of course they said yes and that they could not help me resolve issues with third party’s (T-Mobile)  blocking my emails.  Believing the issue lied with GoDaddy I moved my email hosting to Dream Host.  After moving my email hosting I tried to send an email to my own text number and it was blocked just as it had been before with GoDaddy.  I did more research and found something about the internal document DOC-414999.  This prompted another call to T-Mobile customer support.  I mentioned the internal document and was told that my emails were being blocked because my email address started with info@ followed by my company domain.   I was told that If I wanted to fix the problem I would need to change my email address to one that did not start with any number of generic things like info, contactus, etc.  This is the same email address I have had since 2011 which is on all of my printed marketing materials and has worked with text messages until just a few months ago. I would also add that the email to Verizon text works just fine. I also made sure that the blocks were not related to the content of the emails by sending various messages, all with the same results.

Is there any way to get this problem solved without having to change my email address?

Hello @srickar,

I am experiencing the same issue with sending emails to mytmobilenumber@tmomail.net.

The sending email address is Microsoft Azure <azure-noreply@microsoft.com>.

Is there a way to whitelist the Microsoft domain?

Or can the email address be whitelisted?

We use alerts from Azure to send to our cell phone for after hours on-call situations.

I have also been in contact with Microsoft and currently they are not able to change the email address.

Appreciate any help or insight you can provide.

Thanks!

Userlevel 6
Badge +14

I saw this issue before for emails with over 55 characters in the email contents and subject line, but this appears to be resolved. You'll want to Community-2153​ and have a Trouble Ticket filed to get this fixed.

@srickar​  please let me know how to  DM you or feel free to reach me on any of the contact info in my ticket.  Thank you!

Userlevel 3
Badge +4

Glad I could resolve your issue. Thanks!

Hello srickar

I am in a similar boat to others in this thread, with alert messages from a single source to the SMS gateway being blocked from reaching T-Mobile and some Sprint users.  Coincidentally, this has been by the Barracuda appliance/service and since 22 January.

How shall I submit further problem description and headers for resolution?

I've been watching the traffic in other threads but not seen much method or hope for a fix until just now.

Hoping you can help.

Thanks

Having same exact issues to my number from home automation system. Really relay on this. 

Userlevel 3
Badge +4

Hi. I cannot message you yet. Can you please send me a follow through inbox?

Apologies.  Still figuring out the protocols here.

(I think) I just sent follow request

Hello @srickar  We use email to text for monitoring alerting and other notifications.  This has been working for years.  Suddenly, earlier this month, in one of three datacenters email to text stopped working.   The postfix mail server has the following error message:

Mar 18 19:04:07 xxxxxxx-xxxxxxx postfix/smtp[85822]: 60E961A002B: to=<xxxxxxxxxx@tmomail.net>, relay=d79033b.ess.barracudanetworks.com[209.222.82.253]:25, delay=5.7, delays=0/0/1.6/4.1, dsn=5.0.0, status=bounced (host d79033b.ess.barracudanetworks.com[209.222.82.253] said: 550 permanent failure for one or more recipients (xxxxxxxxxx@tmomail.net:blocked) (in reply to end of DATA command))


We have a QA data center using .net domain, US data center using .com domain, and an EU data center using an .eu domain.   I am able to send an email to text and receive the text from the QA and US data center. I am not able to receive any text messages from the EU data center.  As mentioned, this was working correctly and suddenly started failing.

Userlevel 3
Badge +4

Thanks. I sent you a D.M.

Userlevel 3
Badge +4

Hello @srickar  We use email to text for monitoring alerting and other notifications.  This has been working for years.  Suddenly, earlier this month, in one of three datacenters email to text stopped working.   The postfix mail server has the following error message:

Mar 18 19:04:07 xxxxxxx-xxxxxxx postfix/smtp[85822]: 60E961A002B: to=<xxxxxxxxxx@tmomail.net>, relay=d79033b.ess.barracudanetworks.com[209.222.82.253]:25, delay=5.7, delays=0/0/1.6/4.1, dsn=5.0.0, status=bounced (host d79033b.ess.barracudanetworks.com[209.222.82.253] said: 550 permanent failure for one or more recipients (xxxxxxxxxx@tmomail.net:blocked) (in reply to end of DATA command))


We have a QA data center using .net domain, US data center using .com domain, and an EU data center using an .eu domain.   I am able to send an email to text and receive the text from the QA and US data center. I am not able to receive any text messages from the EU data center.  As mentioned, this was working correctly and suddenly started failing.

================

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Hi! I also have the same problem with this. Would you be able to help me out? I will send you a personal message right now. Thank you!

Userlevel 3
Badge +4

Any updated on this? This suddenly stopped working for me last week

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

I too am being blocked as spam when I send an email to tmophonenumber@tmomail.net.  This has worked for me for years.  Would someone please post the solution or instructions how to send a dm to get it resolved?  Thank you.

@tmo_mike_c; @srickar@tmobile-admin

Userlevel 3
Badge +4

Hey! I have a raspberry PI at home that has been sending out emails/(SMS Messages) to my Tmobile phone for years and all of a sudden about a week or so ago it no longer works.  My PI still sends emails to my other email addresses, just not the phone.  I am sending it using postfix and relaying through my personal domain email account. Is Tmobile blocking certain domains now?  I can send an email directly from my email client, just not through the relay. Does Tmobile need to whitelist my home IP address?  I contacted support but they had no idea what I was talking about.  Thanks in advance. 

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Userlevel 3
Badge +4

I sent you a follow request. Please accept and send me a DM please.

Userlevel 3
Badge +4

I am having the same issue. I was on the phone for 45 minutes to no avail. The tech support said they’d call me back within 24 hours. Never heard back from them and I am still haveing the same issue. 

 

This is the message I get back every time:  

Delivery to the following recipients failed permanently:

 

   * 785979XXX@tmomail.net

 

Reason: Delivery to 209.222.82.255 failed. Return Code: 550; Return Message: 550 permanent failure for one or more recipients (785979XXXX@tmomail.net:blocked)

 

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

@srickar​ - I accepted follow request and sent dm with particulars.

Userlevel 3
Badge +4

Hello, Is this thread still active?

Or is there another source to get this particular issue resolved?

 

Thanks,

AR

 

I have been placed back into this support role due to overwhelming demand. Please send me a PM with these details not redacted, and I will look into this. 

Hi, I have a raspberry PI at home that has been sending out emails/(SMS Messages) to my Tmobile phone for years and all of a sudden about a week or so ago it no longer works.  My PI still sends emails to my other email addresses, just not the phone.  I am sending it using postfix and relaying through my personal domain email account.  Is Tmobile blocking certain domains now?  I can send an email directly from my email client, just not through the relay.  Does Tmobile need to whitelist my home IP address?  I contacted support but they had no idea what I was talking about.  Thanks in advance.