Question

how to make digits website work

  • 25 August 2019
  • 16 replies
  • 199 views

i am trying to use digits through the website. after signing in, i go to register my phone but its always gives the error:

Please ensure your browser location is shared and refresh the page to register again.

 

the problem is, i have enabled location sharing for this website. and refreshed, even completely rebooting my desktop doesnt fix this.

what am i doing wrong here? how to i get this website to work?

the digits website is one the few reasons i switched to T-mobile, and i will be switching back if the feature doesnt work.


16 replies

are you using VPN?

The VPN questions is a good one. If no VPN, can you try using another browser?

Userlevel 6
Badge +13

That's a great question. Are you connected to VPN? Please let us know if the suggestions above helped.

i am not using a VPN. i am using Chromium as my web browser. i have also tried Firefox ESR, LYNX, and Konqueror. the digits website doesnt work on any of them with their default settings.

Are you able to try regular Chrome?

Userlevel 4
Badge +6

Are you running Chromium on Linux and, if so, which version? Have you updated today?

yes i am running on linux.

my chromium version is Version 76.0.3809.100

my linux version is 4.19.37

regular google chrome is not officially supported by my OS, Debian 10. it is not in any of the official software repositories.

Userlevel 4
Badge +6

Yes, have you tried FireFox? Chromium, though the base of Chrome, lacks some user friendly code (that will never be approved by the open source community) so I keep both browsers on my machine. 😉

Just checking to see if you were able to give regular FireFox a go?

Are you on a Mac with Catalina (OS 10.15) by any chance? It appears to be completely broken now because of Apple's new security protections in this release. The (Mac) Digits program no longer works as it doesn't correctly ask for location permission and fails. Also Chrome and Firefox have similar issues with security certificates under Catalina. Not sure T-Mobile cares enough about Digits at this point to fix any of this. 😥

Correct. Digits needs to ask for permission to use location and microphone. There is no way to manually add Digits app to the Privacy preferences panel.

Thank you for this! Its unacceptable that that should happen but as of Mar 2020, I still have this inexplicable issue. I had been warned of the incredible uselessness of the digits app/chip, and have been carrying them nevertheless for upwards of 2 yrs (for an additional business line)

@norna

I had this same problem on my MacBook running Catalina 10.15.3 when I installed the T-Mobile Digits app when I tried to register it my new virtual Digits line that I'm using while working from home thanks to the Covid-19 outbreak. :-P

I got the same "Please ensure your browser location is shared and refresh the page to register again" but couldn't add it to my Location Services as everyone else has described. After reading through this thread and seeing that a solution hadn't been provided by T-Mobile (shame!) I decided to poke around a bit and I was able to get it to work.

This is what I did, after receiving the browser location message when I clicked Register, I went to the T-Mobile DIGITS app's menu bar, under "Media" I set it to use my headset for my speakers and microphone first, that didn't help but a step I would have needed to do anyways. 🙂 Next I went to the "Help" menu and clicked on "Check for Updates", nothing seemed to happen. Finally, on the main T-Mobile DIGITS menu I click on "Reload" after which it actually loaded the app as if the registration had completed... which I'm assuming it did in the background and the reload just cleared the stupid Location error.

I did a test text to my virtual Digits line from my mobile line, I received it as expected but only after a short delay (~30 seconds), I then typed a reply text but the app on my MacBook hung so I clicked "Reload" again, then I was able to send a text from my Digits line to my mobile. I then made a call to my mobile from the Digits app, when I answered it on my mobile it gave my my Digit line's voice mail so I cancelled the call. I tried to call my Digits line from my mobile line and it worked fine. I then tried to call my mobile line from my Digits line again and this time it worked fine.

In any case, I got it working and I thought I would share this with you and the others on this thread in the hopes that it may work for you too.

Cheers

Note: Just after copying the screenshot above the Digits application logged me out and I had to go through this again, it didn't work as expected... this time the reload didn't seem to do the trick but leaving it at the registration page while I pondered my next step is all of a sudden loaded the app with my Digits line registered. So... flaky but it works sometimes? ;-)

Good lucks!

I think they released an update to address this, not sure when...  I too had this problem on Catalina.  If I clicked check for updates, nothing ever updated.  I was on version 1.59b something or other.  I went to the download page on the digits web app here: https://wrc.t-mobile.com/wrcpro/customer/downloadHome.html and downloaded version 1.6.  I can now log in without the error message…  Hope this helps!!!

 

Thank you babraham76.  A lifesaver as I wait for T-Mobile to replace my corrupted SIM card.

Reply