Question

I can't access My T-Mobile account in any browser


Userlevel 1
Badge

Hi,

I can't access my T-Mobile account in the web. I can access no problem in the app. I tried Chrome and Microsoft Edge.  I cleared history, cache, cookies with the same result. After I login, the page only display the footer…

This has been happening for months. I was able to see the account a couple of weeks ago when I clear the cache. I tried the next day and even though I deleted everything (cache, cookies), I couldn't access it.

This is a business account.

 

Please help


35 replies

Userlevel 7
Badge +14

That’s strange that you can sign into the forums but not the account page since Tmobile linked the two after the recent forum update.

I usually use Firefox with no issue.

Userlevel 1
Badge

I can successfully log in to my account but I can't see any information. The forum is obviously a different part of the website. 

 

Just tried in Firefox in another computer with the same issue.

Userlevel 7
Badge +13

you are the primary account holder (PAH) for the business account correct? if im thinking correctly usually the business accounts have a rep they go to for issues etc..might be what you will need to do here.

Userlevel 7
Badge +14

I can successfully log in to my account but I can't see any information. The forum is obviously a different part of the website. 

 

Just tried in Firefox in another computer with the same issue.

This site uses the same Tmobile ID as the forum. I go from being logged into my Tmobile account to logging into this account without needing my password. Tmobile changed the forum so they know who the customer is by their username. Pretty slick now it’s not anonymous.

Userlevel 1
Badge

Yes, I am the primary account holder (PAH).

As I said, I am able to log in, but the only information display is the footnote of the page (see attachment above) and nothing about my account. It is really annoying to need to go to the app and send the information through my email to be able to see it in the desktop.

Userlevel 7
Badge +14

You may want to use messenger on one of Tmobile’s social media accounts since this is a user to user forum with some Tmobile moderation. There’s a higher tier of support on those accounts.

I have been having the exact same problem for months.  I have tried different browsers and different computers.  Only thing I see when I log in is the footer for the webpage.  Also, the app is not current when I log in that way.  I only see our original numbers, not the ones I have added over the past year or two.

 

 

I have also been having the same problem for months. I am also the primary user on a business account. With autopay and paperless billing, I need to access the account each month to download our bill for accounting. But every month I run into this problem. 

It’s getting incredibly old. I have driven to local T-Mobile stores to address it, but of course they do not experience the same problem and really have nothing to do with the website design, so they print my bill for me and that’s that. 

Has anyone had any luck with logging into their account? This is crazy and I have been trying for three weeks now. 

Badge

Log in issues are recuring and have been going on for about 5 weeks, TO MANY hours and several calls on the phone with T-mobile Tec and my ISP, T-mobile places the issue on my ISP, my ISP places the issue on T-mobile. Have used multiple browsers, same issue.

9-11 attempts to log in each time the page finally loads… same experience with each link on the T-mobile site after that.

PERHAPS ONE NEEDS TO GET THE MEDIA ON THIS?

Badge

BUSINESS AS USUAL; The proverbial promise of a "call back" within 72 hrs, I said to Tyler, the Boise based tech, "That would be a first, I would be totally surprised"....... Sure enough and business as usual, call back occurred 8 days later after several more hour and a half long tech calls to T-mobile with no resolve.

I called T-mobile months ago, they put in a ticket and said they’d “look into it” just as I’m sure they told everyone else they would. This “Looks like we got our wires crossed” error garbage has been going on since before even Covid, The only way I can even pay my bill is to call their telephone number unless I use their app and I don’t want to use their app. It’s like the whole point of destroying this part of the website is to force the app on people. Honestly, I’m starting to wonder if they even want my business.

Omgosh apparently we have an issue they can’t fix.  I feel like I want to file a complaint to the FCC. Im Sure our no access to our account and data is not legal.  It’s been over a month for me.  Just spins when I login. No acct options on the app. Tried different PCs and devices.  Even had my friend login and he lives on the east coast.  Nothing.  

Badge

Oh my goodness  same!!! I  have been going to Google Chrome and  logging that way, CS said Uninstall and reinstall,  but that didn't work !!! Looks like we are heading back to Verizon!!! Good luck!!

December 27 2 hours new customer home internet and I get wires crossed. I had an email with them years ago and they want me to make a new email. This is the same problem I had before could not login to account  .   The home inter works great.   But I can't even log into the gateway yet alone my account.  What a joke.  They even admitted well your internet is working, so you good and you account is paid.  No shi&&.  Un real what a way to start off 

I have had this happen to me for months. Just hangs and says still working on it forever. yet i just got logged into this community … any recent updates from tmobile? I cannot even get a rep on chat via the mobile app anymore

 

I had a business account and just recently added 2 lines with numbers from consumer cellular,at the time I told the salesperson I Wanted to change everything  to a personal account as I'am retired and it has been unpleasant since,can't logged in to any accounts and it appears everything is still in a business account costing us a lot more money.right now I wish we had stayed with consumer cellular and it looks like I'll have to send a letter to T-moble customer via regular mail as phone calls returns to the store are not working.

Amazingly, I have the exact same problem, and have the exact same ability to set up a tmobile forum account… seems this part works… but can’t actually access my account to pay a bill.

If sprint hadn’t died, would’ve stayed with them.

After I told a coworker I’d gone to tmobile, he said “they’re the worst”, I didn’t realize it until now.

Makes me miss the big gaps in service from sprint that while I might not have calls, at least I could call their customer service, get on their website, and pay the damn bill.

Had same issues.  Tried multiple different browsers, turned off my firewall, checked proxy settings, ...etc.  Eventually found a different entry point through t-mobile pages I could reach.  Found this link worked.  I bookmarked once it worked and now able to reach it every time via navigation or bookmark.  Currently using Edge browser.  No other modifications to Edge settings needed.

https://account.t-mobile.com/signin/v2/

***UPDATE*** - Solution was short lived.  Once I closed all browser tabs and tried bookmark again it stopped working.  Still checking...

I just started to have the same problem. I can connect through my VPN no problem. The most common reason you can't browse the internet if connected to the VPN is an issue with DNS. If your DNS settings are faulty, however, you may not be able to connect to the Internet once you have a VPN on. Your DNS settings need to be manually changed in order to fix this problem.

I cannot log in to the website from Google, Firefox, Edge or Chrome.  Sheesh!

 

Same issue. Can see community on computer, but not the parent T-Mobile.com site. Really odd error. Have to use a phone browser or app to access the site.

Same issue, I see the header but nothing else 

 

I cannot access the website from my computer. I did all the troubleshooting mentioned by the others. I can access it from my phone and tablet and my husband's laptop and desktop. Spent hours on the phone with tech support. No luck. They say it's my computer, but I can access any other website I want. Why just T Mobile? This doesn't make sense to me.  I think my IP address is blocked, but they say not. Very disappointed. 😞. I'm using my tablet to write this. I can read the comments on my computer, but can't log in to write a comment.

Badge

I got online to see if the problem I have been having for over a year was the same as everyone else. You cannot log on from the browser. It says that the website is not available. Or it is blocked. I can get on to pay my bill through my phone but not on my laptop. It is beyond infuriating looking at the amount of issues people on here have had and have called in, emailed in, written letters about, called about, etc. Why doesn’t this company care about it’s customers. If they did they would fix it so they can’t tell me they do. This is such bad business on T-Mobile’s part. If they didn’t spend so much money putting out commercials that they paid big bucks to produce and for stars to be in, maybe they would have money left to take care of their network/system so that it would work correctly for the customers who have purchased their product and put their trust in them. I have been a T-Mobile customer for 7 years and I admit I have hung on longer than I should. If things don’t change soon, I will have to look into a company that cares for their customers.

Reply