Question

I can't access My T-Mobile account in any browser


Userlevel 1
Badge

Hi,

I can't access my T-Mobile account in the web. I can access no problem in the app. I tried Chrome and Microsoft Edge.  I cleared history, cache, cookies with the same result. After I login, the page only display the footer…

This has been happening for months. I was able to see the account a couple of weeks ago when I clear the cache. I tried the next day and even though I deleted everything (cache, cookies), I couldn't access it.

This is a business account.

 

Please help


35 replies

It can't be an isolated problem if so many other customers are having this issue. I prefer to use my computer to access the site and should have that ability. T-Mobile needs to fix this ASAP !

 

For those of you still having this issue, I was having the same issue until I realized that my Windows 11 machine has the Firewall rule set to public on the WiFI adaptor. You need toi change the Wifi adaptor setting from public to Private. This will allow the Windows Firewall to allow the cookies and scripts that T-mobile uses on their site to load, otherwise they get blocked and then you see error message that the site could not load or cannot be reached. 

Change network profile type for Wi-Fi connection (Windows 11) a similar set of steps can be used for Windows 10 machines. 

  1. Open Settings.
  2. Click on Network & internet.
  3. Click the Wi-Fi page on the right side.
  4. Click the Manage known networks setting.
  5. Click the active wireless connection.
  6. Under the “Network profile type” section, select the profile type, including Public or Private.

 

My win.10 computer is set on private network. I don't  see any of the options you mention.

Userlevel 2
Badge +4

Wowza! Sorry to be so late to the party here but this seems to be an ongoing issue still. I would love to have my team take a deeper look at what is going on so we can find a full fix. I greatly appreciate that you all have mentioned what browser you are using and some of the troubleshooting that has been done. 

I have a few questions. Is this still going on for anyone? Is the T-Mobile ID being used to log in the same email that you are using for our Community space? Please don’t put your T-Mobile ID here because it is a public space, but it would be good for me to go to our Business partners with examples of who is having issues. 

 

Same issue as everybody else here. 

After TMobile tech told me it was somebody else's fault, I went first to my Dell support tech (my issue is with my XPS 15 laptop) and spent a lot of time with them. After they spent a lot of time troubleshooting, I ended up at their recommendation doing a clean reinstall of my windows 11 operating system. Of course that meant I had to spend a couple of days loading everything back in and getting all my settings set again. When that didn't fix the problem they suggested I go to my internet provider.

That call didn't take long, once we were able to open the site fine (using a different device, my Android phone) from the same network using the same browser (none of my three browsers will open the T-Mobile site on the computer) and was able to log in just fine. So that means the network isn't blocking me.

I even spent some time with Microsoft tech, since I have an account and had another issue to discuss related to the clean install. Once again, the issue comes down to T-Mobile.

So I returned to Tmobile, & insisted on the discussion with the T-Mobile webtech today. After walking through all of this and identifying the three separate error messages I get, she was baffled.

Apparently the f451 error message I get when I try to log in from the site (when I do get the site up, usually by doing a Google search) indicates some legal conflict, as if I was some government oversight agency or something ridiculous like that. So she actually created a support ticket and promised me a 48 hour turnaround from the engineers.

I will update this thread when I either get a resolution or they take it to the next step.

Clearly, I don't have anything better to do...

For those of you still having this issue, I was having the same issue until I realized that my Windows 11 machine has the Firewall rule set to public on the WiFI adaptor. You need toi change the Wifi adaptor setting from public to Private. This will allow the Windows Firewall to allow the cookies and scripts that T-mobile uses on their site to load, otherwise they get blocked and then you see error message that the site could not load or cannot be reached. 

Change network profile type for Wi-Fi connection (Windows 11) a similar set of steps can be used for Windows 10 machines. 

  1. Open Settings.
  2. Click on Network & internet.
  3. Click the Wi-Fi page on the right side.
  4. Click the Manage known networks setting.
  5. Click the active wireless connection.
  6. Under the “Network profile type” section, select the profile type, including Public or Private.

 

I followed this step by step, to no avail

Had the same problem signing in to T-mobile windows 11 

I enable my VPN  and problem fixed. Go figure!

 

Whoa, an actual solution!

SoU heard back from the T-mobile 'engineers' re: my trouble ticket. They basically said 'you accessed the site (from my phone, not laptop) so you don't have a problem.'

Uh, thanks you jerks. You haven't fixed anything.

I may have to try the VPN idea.

So, I installed a VPN and it works just fine. I wonder if I can get T mobile to cover the cost of the VPN? Maybe they should include a VPN subscription with every account?

Reply