Question

I can't access My T-Mobile account in any browser


Userlevel 1
Badge

Hi,

I can't access my T-Mobile account in the web. I can access no problem in the app. I tried Chrome and Microsoft Edge.  I cleared history, cache, cookies with the same result. After I login, the page only display the footer…

This has been happening for months. I was able to see the account a couple of weeks ago when I clear the cache. I tried the next day and even though I deleted everything (cache, cookies), I couldn't access it.

This is a business account.

 

Please help


35 replies

Userlevel 1
Badge

I can successfully log in to my account but I can't see any information. The forum is obviously a different part of the website. 

 

Just tried in Firefox in another computer with the same issue.

I have been having the exact same problem for months.  I have tried different browsers and different computers.  Only thing I see when I log in is the footer for the webpage.  Also, the app is not current when I log in that way.  I only see our original numbers, not the ones I have added over the past year or two.

 

 

Omgosh apparently we have an issue they can’t fix.  I feel like I want to file a complaint to the FCC. Im Sure our no access to our account and data is not legal.  It’s been over a month for me.  Just spins when I login. No acct options on the app. Tried different PCs and devices.  Even had my friend login and he lives on the east coast.  Nothing.  

Badge

Log in issues are recuring and have been going on for about 5 weeks, TO MANY hours and several calls on the phone with T-mobile Tec and my ISP, T-mobile places the issue on my ISP, my ISP places the issue on T-mobile. Have used multiple browsers, same issue.

9-11 attempts to log in each time the page finally loads… same experience with each link on the T-mobile site after that.

PERHAPS ONE NEEDS TO GET THE MEDIA ON THIS?

Badge

Oh my goodness  same!!! I  have been going to Google Chrome and  logging that way, CS said Uninstall and reinstall,  but that didn't work !!! Looks like we are heading back to Verizon!!! Good luck!!

Has anyone had any luck with logging into their account? This is crazy and I have been trying for three weeks now. 

December 27 2 hours new customer home internet and I get wires crossed. I had an email with them years ago and they want me to make a new email. This is the same problem I had before could not login to account  .   The home inter works great.   But I can't even log into the gateway yet alone my account.  What a joke.  They even admitted well your internet is working, so you good and you account is paid.  No shi&&.  Un real what a way to start off 

I have also been having the same problem for months. I am also the primary user on a business account. With autopay and paperless billing, I need to access the account each month to download our bill for accounting. But every month I run into this problem. 

It’s getting incredibly old. I have driven to local T-Mobile stores to address it, but of course they do not experience the same problem and really have nothing to do with the website design, so they print my bill for me and that’s that. 

So, I installed a VPN and it works just fine. I wonder if I can get T mobile to cover the cost of the VPN? Maybe they should include a VPN subscription with every account?

Badge

I got online to see if the problem I have been having for over a year was the same as everyone else. You cannot log on from the browser. It says that the website is not available. Or it is blocked. I can get on to pay my bill through my phone but not on my laptop. It is beyond infuriating looking at the amount of issues people on here have had and have called in, emailed in, written letters about, called about, etc. Why doesn’t this company care about it’s customers. If they did they would fix it so they can’t tell me they do. This is such bad business on T-Mobile’s part. If they didn’t spend so much money putting out commercials that they paid big bucks to produce and for stars to be in, maybe they would have money left to take care of their network/system so that it would work correctly for the customers who have purchased their product and put their trust in them. I have been a T-Mobile customer for 7 years and I admit I have hung on longer than I should. If things don’t change soon, I will have to look into a company that cares for their customers.

Userlevel 1
Badge

Yes, I am the primary account holder (PAH).

As I said, I am able to log in, but the only information display is the footnote of the page (see attachment above) and nothing about my account. It is really annoying to need to go to the app and send the information through my email to be able to see it in the desktop.

Badge

BUSINESS AS USUAL; The proverbial promise of a "call back" within 72 hrs, I said to Tyler, the Boise based tech, "That would be a first, I would be totally surprised"....... Sure enough and business as usual, call back occurred 8 days later after several more hour and a half long tech calls to T-mobile with no resolve.

Same issue. Can see community on computer, but not the parent T-Mobile.com site. Really odd error. Have to use a phone browser or app to access the site.

I cannot access the website from my computer. I did all the troubleshooting mentioned by the others. I can access it from my phone and tablet and my husband's laptop and desktop. Spent hours on the phone with tech support. No luck. They say it's my computer, but I can access any other website I want. Why just T Mobile? This doesn't make sense to me.  I think my IP address is blocked, but they say not. Very disappointed. 😞. I'm using my tablet to write this. I can read the comments on my computer, but can't log in to write a comment.

Userlevel 3
Badge +4

Wowza! Sorry to be so late to the party here but this seems to be an ongoing issue still. I would love to have my team take a deeper look at what is going on so we can find a full fix. I greatly appreciate that you all have mentioned what browser you are using and some of the troubleshooting that has been done. 

I have a few questions. Is this still going on for anyone? Is the T-Mobile ID being used to log in the same email that you are using for our Community space? Please don’t put your T-Mobile ID here because it is a public space, but it would be good for me to go to our Business partners with examples of who is having issues. 

 

Same issue as everybody else here. 

After TMobile tech told me it was somebody else's fault, I went first to my Dell support tech (my issue is with my XPS 15 laptop) and spent a lot of time with them. After they spent a lot of time troubleshooting, I ended up at their recommendation doing a clean reinstall of my windows 11 operating system. Of course that meant I had to spend a couple of days loading everything back in and getting all my settings set again. When that didn't fix the problem they suggested I go to my internet provider.

That call didn't take long, once we were able to open the site fine (using a different device, my Android phone) from the same network using the same browser (none of my three browsers will open the T-Mobile site on the computer) and was able to log in just fine. So that means the network isn't blocking me.

I even spent some time with Microsoft tech, since I have an account and had another issue to discuss related to the clean install. Once again, the issue comes down to T-Mobile.

So I returned to Tmobile, & insisted on the discussion with the T-Mobile webtech today. After walking through all of this and identifying the three separate error messages I get, she was baffled.

Apparently the f451 error message I get when I try to log in from the site (when I do get the site up, usually by doing a Google search) indicates some legal conflict, as if I was some government oversight agency or something ridiculous like that. So she actually created a support ticket and promised me a 48 hour turnaround from the engineers.

I will update this thread when I either get a resolution or they take it to the next step.

Clearly, I don't have anything better to do...

For those of you still having this issue, I was having the same issue until I realized that my Windows 11 machine has the Firewall rule set to public on the WiFI adaptor. You need toi change the Wifi adaptor setting from public to Private. This will allow the Windows Firewall to allow the cookies and scripts that T-mobile uses on their site to load, otherwise they get blocked and then you see error message that the site could not load or cannot be reached. 

Change network profile type for Wi-Fi connection (Windows 11) a similar set of steps can be used for Windows 10 machines. 

  1. Open Settings.
  2. Click on Network & internet.
  3. Click the Wi-Fi page on the right side.
  4. Click the Manage known networks setting.
  5. Click the active wireless connection.
  6. Under the “Network profile type” section, select the profile type, including Public or Private.

 

I followed this step by step, to no avail

Same issue, I see the header but nothing else 

 

Had the same problem signing in to T-mobile windows 11 

I enable my VPN  and problem fixed. Go figure!

 

Whoa, an actual solution!

Amazingly, I have the exact same problem, and have the exact same ability to set up a tmobile forum account… seems this part works… but can’t actually access my account to pay a bill.

If sprint hadn’t died, would’ve stayed with them.

After I told a coworker I’d gone to tmobile, he said “they’re the worst”, I didn’t realize it until now.

Makes me miss the big gaps in service from sprint that while I might not have calls, at least I could call their customer service, get on their website, and pay the damn bill.

SoU heard back from the T-mobile 'engineers' re: my trouble ticket. They basically said 'you accessed the site (from my phone, not laptop) so you don't have a problem.'

Uh, thanks you jerks. You haven't fixed anything.

I may have to try the VPN idea.

Userlevel 7
Badge +14

That’s strange that you can sign into the forums but not the account page since Tmobile linked the two after the recent forum update.

I usually use Firefox with no issue.

Userlevel 7
Badge +13

you are the primary account holder (PAH) for the business account correct? if im thinking correctly usually the business accounts have a rep they go to for issues etc..might be what you will need to do here.

Userlevel 7
Badge +14

I can successfully log in to my account but I can't see any information. The forum is obviously a different part of the website. 

 

Just tried in Firefox in another computer with the same issue.

This site uses the same Tmobile ID as the forum. I go from being logged into my Tmobile account to logging into this account without needing my password. Tmobile changed the forum so they know who the customer is by their username. Pretty slick now it’s not anonymous.

Reply