Internal Error 407


keep getting error when trying to do system update for PRL or Profile.  How can this be resolved?


27 replies

I just got a galaxy s9 and got it all set up. Then, as soon as I put my SIM card in, bam, I started getting this error. I've tried everything except removing the card, but I'll try that next, even though I'm not sure how it'll help.

 

That said, I discovered that you CAN TURN OFF THE NOTIFICATIONS! Thank goodness, or I'd be ready to buy another new phone. They're still there, but don't make sounds, and don't show on the screen as often.

Badge

I did not bring my phone over from sprint, (samsung galaxy s9+), it was always a t-mobile phone and nothing works. I get this #$%% notification every 15 minutes.

The UICC unlock DOES NOT WORK,

wiping the cache DOES NOT WORK,

reflashing stock firmware DOES NOT WORK.

restarting the phone in safemode DOES NOT WORK.  

 

NONE OF THE THE SOLUTIONS I HAVE FOUND ONLINE WORK.

 

I need something THAT WORKS!

Ariel82 Have you had any luck yet? It’s still driving me crazy!

 

I don't know if this help but you guy try to take the sim out and put it back. It works for me some how

Userlevel 1

Yeah I took it to them 2 days ago. They put in a new sim and said they only had 1 other person w the problemm and didn't know how to help. 

Take it to t-mobile.  They did help with the 2nd phone.  It is annoying as hell.

Userlevel 1

I've tried the sim thing. Sigh I'll  keep hoping for the best and try the update like a crazy person lol

I  believe so, but I tried so many things over and over that I am not 100% sure.   On the second phone just taking out the sim card and putting it back worked.

Userlevel 1

so did you just attempt the update over and over till the message disappeared? 

I absolutely know how frustrating this is!  I got two unlocked S10e phones and both had this error message.  I tried everything possible.  I used saucypuck's advice over and over.  But my message was a bit different from his and I couldn't get back to the error message.   I installed a program to uninstall unwanted system apps (which would not work on OMADM), plus any and all methods I found online.  Nothing worked, but suddenly after using the UICC and software update for the hundredth time -  error message gone!  This was at least a week.  On the second phone, same problem, slight difference in error messages but still 407 / OMADM error.  Worked on this phone forever but problem still persisted.  I finally gave up, took it to T-Mobile.  He did everything I did, but removed the SIM, which I had not done.   I'm not sure if that was it, but whatever he did worked and error message is gone.  PAINFUL!!!

Userlevel 1

You are right, it is happening more frequently than every hour. Extremely annoying when you're trying to record video or do something on your phone and it automatically stops whatever it is you're doing. I can't seem to understand why this issue has yet to be resolved. 

I also have tried EVERYTHING!!! My Samsung S10 has been giving me the internal error every 20-60 min since he update of July 8th was forced on me. Samsung and T Mobile must work harder to resolve the issue they have caused us all to endure.  What do we have to do to get some legitimate help??? 

 

Userlevel 1

None of these solutions worked for me. I have tried everything down to a software flash done by UBreakIFix. Nothing works and I have been dealing with this for over a month now. Every single hour I get notified my phone is trying to do a firmware update then get error code 407 or if I hit cancel, error code 400. I am beyond frustrated!!!

saucypuck UICC Unlock 


solution works , solved my problem , same here unlocked phone error 407

+1

Thanks a lot saucypuck! Was trying to fix it for almost 2 weeks already and nothing worked. Glad I found your suggestion. That resolved the issue. 

Thanks, I have an unlocked phone and was getting this error message. This cleared the problem. 

I know this is an old thread, but here’s the solution to the same error that came from the last Samsung update:

Go to 'Settings' > 'Software update' and hit 'UICC Unlock'

(It loads for a moment, then says SIM Restricted... blah blah blah)  Hit 'OK'

It takes me back to the to the 'Settings' > 'Software update screen'.  Hit 'Download and install'

(It loads for a moment, then says Your software is up to date... blah blah blah)

Then open that ever-present notification saying the profile didn't update.

(It loads for a minute, then says Profile updated... blah blah blah)  Hit 'OK'

(It loads again for another minute and says something similarly)  Hit 'OK'

Userlevel 6
Badge +15

Oooooh! That's interesting! I'm not sure what username either. Maybe for certain websites you registered too? Not sure, just a thought. 😊

No problem. You should be able to back up all your important info, but I totally understand passing on the reset if the phone's services are working.

In my old instruction manual it states:

'Update Your Profile

This option allows you to automatically update your online user profile information. If you choose to change your user name and select a new one online, you must then update the user name on your phone.'

Not sure what user name but I think we are ok.  Updates are set to download automatically & when I check manually it says we are up-to-date. 

I appreciate all of your help but at this time, I think I will pass on the reset as I don't think these will interfere with the use of the phone.

Thanks.

Userlevel 6
Badge +15

Ah shucks. Sorry that didn't work. I'm not too familiar with this profile update. I just wanna make sure this profile update isn't keeping you from using the service on our network.

Cache wipe unfortunately did nothing.  Not sure if I want to do a complete reset.  Will that wipe out everything including contacts and setups?  I read where it's not too critical if the PRL is not updated, not sure about what update profile does.

Cache wipe unfortunately did nothing.  Not sure if I want to do a complete reset.  Will that wipe out everything including contacts and setups?  I read where it's not too critical if the PRL is not updated, not sure about what update profile does.

Userlevel 6
Badge +15

Okay, thanks for giving that a shot. When you get the chance, try the cache wipe on your phone. This seems to be more related to the phones software so you may need to complete a reset, but that would be last resort.

I am in safe mode and I now just get an error that it could not be completed and to try again later.  "If the problem persists, you may need to contact Customer Service."  Same for Update Profile.

I'm going to exit safe mode for now.  Won't be able to get back to you until tomorrow sometime as we have out of town guests.

Thanks

Userlevel 6
Badge +15

Ah okay. I wasn't able to find this error in our internal systems, but after a Google search, this does seem to have happened on other Sprint devices. Can you try flipping it over to Safe mode and seeing if that allows the update to go through?

Reply