Question

iPhone T-Mobile App issue

  • 11 October 2021
  • 18 replies
  • 3153 views

Userlevel 1
Badge

Hi everyone,

When using the t-mobile app after signing in an error page keeps popping up. It says “Sorry, Something went wrong. We weren't able to process your request at this time. Please try again later.” There are two buttons at the the bottom that say ‘Dismiss’ and ‘Try again’. If you click the dismiss button it just brings you to a white screen with the t-mobile logo in the middle and the words ‘and done’ at the bottom. If you click try again, the same error screen described above re-appears over and over again. Neither of the buttons fix the issue.

I have an iPhone XR. I’ve downloaded, deleted and re-downloaded the T-mobile app multiple times to remedy the issue but it does not. My account is not pre-paid. Using a web browser, I can log into my account with no issues. Anyone else having these same issues? Anyone have a fix?

Any help would be greatly appreciated:)

 


18 replies

Userlevel 6
Badge +15

Hi and thanks for posting. You could also try clearing the cache and data for the app. I’ve seen this message pop up occasionally. A workaround is to continue using the T-Mobile.com website to make changes you need. The last option to help with the app itself is to contact our Tech Care team to have them file a Help Desk ticket for this and get our backend developers to check this out for you.

Same exact issue is happening to me and I’ve completely deleted and reinstalled the TMobile app several times.  Brand new customer here, never even used the app before.  I either get a “Something went wrong” or “You don’t have an internet connection” which is completely wrong, since I do.

Brand new customer here. The same thing is happening to me. I tried reinstalling the app and restarting the phone several times. Nothing helps. Could it have something to do with being a new customer?

I’ve been a customer for years. My app suddenly stopped working on my iPad. I deleted the app, restarted iPad, cleared cache… all the usual stuff. I then installed the app on my wife’s iPad… same bad result. Problem is undoubtedly in the app.

Userlevel 5
Badge +8

I’ve been a customer for years. My app suddenly stopped working on my iPad. I deleted the app, restarted iPad, cleared cache… all the usual stuff. I then installed the app on my wife’s iPad… same bad result. Problem is undoubtedly in the app.

 

Apparently a known problem with iPad iOS 15.2.

 

 

From the looks of it, this has been going on for several months and T-Mobil has done nothing to rectify this.  I was migrated over from SPRINT and have had a nightmare experience every since.

Did anyone out there come up with a fix?  I have tried everything suggested and still nothing.  My account on the web is messed up since the migration and they said use the app instead.. That would be nice if it WORKED!!!

Hi everyone I may know the solution!

I had this problem all of a sudden two days ago, took it to t-mobile they did every single thing they could and could not fix my phone. Then I took it to apple, and immediately he knew what was wrong because he said he had 3 customers within the last 24 hours come in with the t-mobile carrier with the same problem I had.

How he fixed it is I logged into my t-mobile account, went to restrictions, and he said he thinks there was a problem where t-mobile or whoever has accidentally switched the restrictions to high. when I switched it to no restrictions my phone was perfectly fine again! I was so relieved. Hope this works for you guys as well.

 

Where do I find “restrictions”? 

Thanks!

-This happened to my iPhone XR on day one of migration from Sprint to T-Mobile. Tech support has been working on it for 7 days and can’t figure it out.

Today they replaced the SIM card which didn’t fix the issue.

Please share where you find “restrictions” in settings.

 

Add me to the list. Migrated from Sprint. iPhone XR. Same problems as everyone else. We are sssoooooooooooooooo happy to be on T-Mobile now :(

Userlevel 5
Badge +8

Where do I find “restrictions”? 

Thanks!

 

It may be Web Guard.

 

Log into your account, Profile --> Family Controls --> Web Guard --> Permissions.

 

Check your permission level.

 

It’s not Web Guard. My settings default to OFF.

After several cycles of deleting and installing the App, it finally opens but won’t accept my login credentials. 

I talk/follow up with tech support every Tuesday. Hopefully they will have a solution today.

 

Add me to the list. It seems to be a problem that popped up in the last month or two. Hope t-mobile finds a solution.

I thought I was going mad. This has been a persistent issue. Has anyone had any luck resolving this issue?

Ive had the same issue for awhile now as well, it doesn’t matter WHERE I access the site, I’ll have the exact same issue, I’ve had it pop up when logging in on my Mac and android phone

Hey all. It has nothing to do with any settings on the Tmobile website. 
 

IPhone (Android similar), go into settings, find the app, find the section that says Tmobile Settings  near the bottom, there is a switch that says Clear App Cache on Next Launch. That fixes it. 
 

Rich

I have tried all suggestions noted above. Nothing works. I have given up. I now tell everyone the app is worthless. T-Mobile’s attempt to address this has been laughable. As long as the mbl service works, I can live going to the website. There is no way I would ever consider T-Mobile for any other technology offerings if they can’t handle something as routine as an app on an iPhone.

My situation is very similar to most people in here. I was migrated over from sprint just a few weeks ago and I’ve had nothing but trouble since. After chatting with two different “experts” about the app not working I was told that the engineering team was aware of the issue and that I just had to keep trying to login. Then today, all of a sudden, my iPhone notified me that my phone was not activated and I lost all cellular service just like that. I was so upset! I was ready to change carriers but before I did I was gonna try one thing that has helped this issue in the past. I turned my phone off, took out the T-Mobile SIM card, put it back in and restarted my phone and that worked!! I opened the app and it found my account over the network without even having to login!! So to make this long story short, if you haven’t already try taking out the SIM card and putting it back. This may only work for customers who have migrated over from sprint. None of the “experts” I chatted with mentioned this as something I could try so I want to make sure people are aware of this being a possible solution. Hope this helps!

Reply