Iphone XR not receiving group texts when on WiFi, after switching from AT&T

  • 14 February 2023
  • 1 reply


Hi all.


Posting to help others after spending weeks debugging this problem.


I recently ported my parents' iPhones from AT&T to T-mobile Connect.  My mom's phone worked fine.  My dad's phone mysteriously stopped receiving our family group text messages.


Further testing revealed the problem only occurred when the phone was connected to WiFi.  And specifically, only when my sister or her husband (Android users on AT&T) were included in the group message, either as senders or recipients.


I went through exhaustive testing with T-mobile tech support (many times with many agents), checking all the settings, etc. and even brought the phone back to factory settings at the Apple Store genius bar.  No luck. 


Went to a T-mobile store and replaced the sim card.  Still no luck.


I then spent a long, dark night of the soul pouring through forums when I came across a couple of tidbits in forums for other carriers. 


After playing with the following two settings, a miracle occurred and the phone finally works after weeks of frustration. 


1). Log into the T-mobile site, click "My T-mobile" at the top, choose “My Profile” and toggle all of the Blocking Controls and Family Controls, on and off again, waiting a few minutes with them on before leaving them all turned off.  (I did this a few times.).


2). On the iPhone, go to Settings->Cellular and turn off "Wi-Fi Assist."  It's waaaay near the bottom - scroll down below the giant list of apps.  (Note that on my own Iphone, that setting is found in Settings->Mobile Data)




I can't say which of the above solved the problem or if the universe finally took pity on me. But the problem seems to have disappeared.


Here is one last thing to try.  When a phone is ported from one carrier to another, apparently it's possible for the profile to not be completely released from the former carrier.  I called AT&T last night and the agent was confident based on my description that the profile was not properly released.  That turned out to not be the case, but it's something to try.  Also, that agent gets credited for the "Wi-Fi Assist" suggestion above.  (Thanks!)


Good luck!

1 reply

Userlevel 7
Badge +14

WOW! That is a whole adventure you went on to find a solution. Thanks for your diligence and sharing those steps with everyone.