Solved

MMS not sending

  • 15 September 2018
  • 26 replies
  • 7723 views

I've recently joined T-Mobile and I testing it out when I noticed that none of my MMS weren't sending. Everything else works perfectly fine. Any help?

icon

Best answer by magentatechie 15 September 2018, 19:05

My first recommendation would be to access the APN screen, press the 3 dots in the upper right side, and select Reset to Default. Reboot and test.

If this doesn't work, please try a new APN. As your current APN is already set with the default settings for T-Mo, perhaps set up a new APN also with the preferred settings, but fill in the MMS Port to 80.

  • Name: T-Mobile
  • APN: fast.t-mobile.com
  • Proxy: <Not set>
  • Port: <Not set>
  • Username: <Not set>
  • Password: <Not set>
  • Server: <Not set>
  • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
  • MMS proxy: <Not set>
  • MMS port: 80
  • MMS protocol: WAP 2.0
  • MCC: 310
  • MNC: 260
  • Authentication Type: <Not set>
  • APN Type: default,supl,mms
  • APN Protocol: IPv4/IPv6
  • APN roaming protocol: IPv4/IPv6 or IPv4 only when roaming internationally
  • Turn APN on/off: Grayed out unless there are multiple APNs
  • Bearer: Unspecified

Tap the 3 dots in the upper right corner, then select Save.  Attempt to choose your new APN as the default, reboot, and test.

Let me know how it goes!

View original

26 replies

Userlevel 4
Badge +9

Good morning!  I'm sorry you're having troubles with your MMS!  Did you bring your phone to T-Mobile from another carrier?  What kind of device is it?

My phone is a Samsung Galaxy s8 plus unlocked

Userlevel 4
Badge +9

Great! Do you mind checking your APN settings for me? If you could manage a screenshot, that would be awesome!!!

Settings>Connections>Mobile Networks>Access Point Names

You should have a T-Mobile APN set up, tap there and screen shot the page with the name, apn, proxy, etc if you're able. 😊

Userlevel 4
Badge +9

Thanks so much for posting your settings! Do you mind sharing the name of your phone's previous carrier?  It doesn't look like you have the ability to make any changes to the APN, we may need to look at adding a new one, I'd just like to know if there are any device/carrier specific settings that need to be adjusted. 😊

I used mint sim for a couple months but it was a bit slow and expensive so I tried out T-Mobile. Also, if I need to edit my APN I could always just make a new one.

Userlevel 4
Badge +9

I>

Userlevel 4
Badge +9

Alrighty, does that mean you got the phone from Mint?  If not, do you know what carrier it was locked to (if applicable)?

I bought the phone unlocked, which means that I'll have the freedom of changing carriers instead of sticking with it forever

Userlevel 4
Badge +9

Yup, I'm aware! 😊

I will give you an example of why I'm asking- Verizon Samsung devices have a tendency to require an MMS Port set to 80 in the APN, even though the official T-Mobile APN lists the MMS Port to be left blank.  I was trying to establish if we need to look at the original carrier's APN parameters to establish the best settings for your new APN listing.

Userlevel 4
Badge +9

My first recommendation would be to access the APN screen, press the 3 dots in the upper right side, and select Reset to Default. Reboot and test.

If this doesn't work, please try a new APN. As your current APN is already set with the default settings for T-Mo, perhaps set up a new APN also with the preferred settings, but fill in the MMS Port to 80.

  • Name: T-Mobile
  • APN: fast.t-mobile.com
  • Proxy: <Not set>
  • Port: <Not set>
  • Username: <Not set>
  • Password: <Not set>
  • Server: <Not set>
  • MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
  • MMS proxy: <Not set>
  • MMS port: 80
  • MMS protocol: WAP 2.0
  • MCC: 310
  • MNC: 260
  • Authentication Type: <Not set>
  • APN Type: default,supl,mms
  • APN Protocol: IPv4/IPv6
  • APN roaming protocol: IPv4/IPv6 or IPv4 only when roaming internationally
  • Turn APN on/off: Grayed out unless there are multiple APNs
  • Bearer: Unspecified

Tap the 3 dots in the upper right corner, then select Save.  Attempt to choose your new APN as the default, reboot, and test.

Let me know how it goes!

Userlevel 4
Badge +9

(oh, this doesn't mean that I believe the device was from Verizon, but I have seen an MMS Port assignment work for tons of unlocked phones with your same problem.)

It works! Thank you very much magentatechie!  

Userlevel 4
Badge +9

Awesome sauce! It was my pleasure! 😀

I am having the same problem but there is no option to reset to default. Just Delete APN, Save and Discard. And I am totally fed up with the unwillingness of any T-Mobile store employee to help.

Does not work.

Sorry - I just tried this and it doesn't work. I have an unlocked Pixel 3 that I bought from Google but I've had problems with MMS outside the US for as long as I can remember. This is constantly and permanently broken with T-Mobile. I've escalated to several tiers of support to no avail. You are better off using a messaging app that doesn't use the carrier because when it comes to MMS messaging T-Mobile couldn't find it's behind with both hands.

I tried all this, it did not work.

That MMSC link appears to be dead, maybe that is why? Any updated link?

Hello!! I just left ATT, for you guys T-Mobile and also I'm having same problem.... i have unlock Samsung S8, everything works except MMS......i try everything i can find in the internet and T-Mobile team !!

But still not luck please i really will appreciate any help!!

My husband got the new Samsung A10, (T-Mobile) and he also having same problem!! So don't look like it the cellular the problem!!

Userlevel 7
Badge +13

MMS was down in some areas yesterday.

I live in AZ and couldn't send mms till today.

Mine takes forever to send and sometimes I get failed messages and have to try again.  OnePlus 8 purchased from t-mobile last month.  I checked the APN and the settings match the screenshots above.  

My MMS text messages were not working, and all I had to do was turn on mobile data.  Go to Settings, Connections, Data usage, and turn on the Mobile data slider.  My plan does not have data, but it looks like the data is needed for SMS text messages.

Userlevel 5
Badge +9

My MMS text messages were not working, and all I had to do was turn on mobile data.  Go to Settings, Connections, Data usage, and turn on the Mobile data slider.  My plan does not have data, but it looks like the data is needed for SMS text messages.

You are absolutely correct! Mobile data must be turned on to send MMS messages and that has been true for a few years. However, you do not need to have data as part of your plan to send the messages nor will you be charged for data if data is not part of your plan. Hubby had two phones for years (work & personal) and we did not pay for data on his personal phone, but he still needed to turn data on to send messages. :wink:

This has helped greatly for me (just came from Verizon and have an unlocked (bought straight from OnePlus, full price) OnePlus 8 Pro.  The only thing now is that I tried to send a video; I use Textra on Android, it reduced the video quality, the file size was 825k, and it still gave the failure message “Error-permanent-contentnot-accepted”

 

Help?

Userlevel 5
Badge +9

Turn on data and restart your phone to re-associate to the towers.

Reply