Music Apps

Ever since got the Android update my music apps have not worked right. I have Rhapsody Premier that i pay for and i also use the Milk Music from time to time. When i open Rhapsody it is in Offline Mode. I have go to settings and check the offline mode box and then again to get it out of offline mode. So its in offline mode but the box isnt checked. When i start to play the music it only plays maybe a minute and a half of a song then it just stops. I skip to next track and same thing. Milk Music has been doing the same stop thing about a minute and a half through the song. This never happened til right after the Android update. I noticed below a streaming musuc problem as well. It didnt seem to me they are related.


Best answer by dgriff 19 April 2016, 19:55

I just opened Rhapsody on my tablet. ANDROID 5.0.2 APN IPV6 and it works perfect. Infact i noticed something else. Im not getting any messages in my Music inbox either.

View original

10 replies

Userlevel 6

Check your APN settings.  Make sure it's not IPv6 only.

Some apps don't work well with IPv6.

Ive been using this app EVERY for the last 2 years. Ive never had an issue til Marshmellows came. I used itbin the mornin just prior to installing the update. Later that  eveningafter update problem. Ive changedbthe APN settings a lot just messing around with stuff amd never bad problems.

Userlevel 6

I'm fully aware that things have always "just worked".

The problem is there's a limited number of IPv4 addresses out there, so carriers have started trying to push people off IPv4 and onto IPv6 (because there's exponentially more).

The problem with IPv6 is there's a number of apps that aren't compatible yet for whatever reason.  Generally it's VPN, but occasionally something doesn't work.  Carriers cannot test EVERY app out there.

It would be nice if apps with known issues like this would throw something in their error message saying "Yeah, try changing your APN to IPv4 if this doesn't work", but they don't.

You also might want to contact the app developer and say "hey, it's not working with IPv6 Only, can you get that fixed soon as carriers are pushing more towards that?"

I just opened Rhapsody on my tablet. ANDROID 5.0.2 APN IPV6 and it works perfect. Infact i noticed something else. Im not getting any messages in my Music inbox either.

I was trying to say ive used it ipv4, ipv6, and ipv4ipv6. But now i see its working perfect on tablet with 5.0.2 and ipv6. Wich i think my S6 Edge was before this started . So what else could it be

Userlevel 7
Badge +12

It's an IPv6 problem with Samsung code.

If you go to XDA, and other carrier boards most of the fixes that work for majority of people is switching from IPv6 to IPv4/6

I am not against giving it a try but it just seems odd that it worked perfectly fine on ipv6 prior to update and is still working perfect on ipv6 on tablet that doesnt havr the update. Maybe im more or less  trying to understand what changed in the update for it to no longer work. Ill try it to ipv4b and see what happens. Thank you for the advice guys.

Userlevel 7
Badge +12

Because Samsung messed up the code when they updated their devices to 6.0.X. Yes it worked before on various devices of theirs but as soon as they updated it places that are IPv6 primary are having trouble from Wifi to cellular. The S7/Edge for example slow speeds on T-Mobile, and at times weird DNS issues on wifi from ISP that are IPv6 (most of the world still using IPv4).

It's not strange at all it worked before and it stopped working. It happens sometimes when there are changes in code.

Ok i get it. Thank you. I appreciate it. So I didnt change anything yet cause i was having other issues and it was suggested i try a factory reset. So i was just gonna try that bit after a couple weeks all of sudden its working fine. For today atleast. Anyhow if it starts happening again ill do whats been suggested. Thanks you guys. Much appreciated.

Just thought if anyone cares. It was the Power Saving being on. Rhapsody finally put a little notice when you start the app.