Solved

Not receiving text verifications/website verification codes?


Hi all,

Been having this problem for a while and I feel like I've tried everything on my end-- my phone just won't receive verification codes from a number of websites I have accounts with, and I've checked my content blocking settings (which are off) numerous times. Some texts are received, but many are not. What can I do to fix this? Is there a way I can whitelist certain websites to ensure I receive their communications?

Thanks!

icon

Best answer by tmo_mike_c 16 April 2019, 16:43

Thanks for that info. Have you already checked our Manage privacy & notifications​ page to make sure these message aren't being blocked? If so, you'll want to Community-2153 and have our Care folks make sure your internal account isn't keeping these messages from coming through.

View original

22 replies

Userlevel 6
Badge +14

Ah shucks that's no good, but we wanna help. What kind of phone are you using? Are you traveling internationally, or on the T-Mobile network? Also, have you ever gotten these messages before, or has it never worked?

Userlevel 6
Badge +14

Hey! Just checking to see if you still need help. Please reply and let us know. Thanks.

Yes

Userlevel 6
Badge +14

Okay, we really wanna help. What phone are you using? Are you on T-Mobile's network or roaming on an international tower? I'm also curious if this has ever worked for you?

Have s9+, use to get them but from certain numbers and yes using tmobile

service

Userlevel 6
Badge +14

Thanks for that info. Have you already checked our Manage privacy & notifications​ page to make sure these message aren't being blocked? If so, you'll want to Community-2153 and have our Care folks make sure your internal account isn't keeping these messages from coming through.

My family is having the same issue, I have checked my privacy settings and blocked setting and I have everything off and still not recieving messages.

Were they able to fix this issue?

I am having the same issue. I consistently never receive text messages from about half of the accounts I am sent verifications from. Others deliver fine. It’s really frustrating. What causes this?

When I click on that “Manage privacy and notifications” link that tmo_mike_c posted above it just sends me back to this page.

Same problem with almost any SMS verification almost 2 years

we open google voice account and we geting the sms verification to them

Userlevel 5
Badge +9

This can happen also if short codes are blocked on your account because the phone number the business is sending the verification code from is usually a short code (or shortened phone number). Contact Tmobile and make sure short codes are enabled on your account.

I also do not receive verification  code via sms from FedEx and so many other companies. I'm actually frustrated with this T-mobile number and considering switching to another network. I get scared each time I'm registering for a service and the only option is sms code. For email verification, my Yahoo mail works perfectly fine, never had a single issue with email verification. Why can't T-mobile improve their service. This is very repulsive and disgusting quite frankly.

I’m also having this issue. All of my settings are on unblocked, but I still cannot receive verification codes for most websites, which is very frustrating.

 

I’m using an iPhone 12 and I tried tapping the link provided, I’m sent back to this page. 

I don’t understand why if so many people have this issue, and it requires t-mobile support to resolve, that t-mobile wouldn’t develop a system wide solution rather than reuquiring each of us to reach out for assistance. That is extremely inefficient. 

Userlevel 5
Badge +8

I don’t understand why if so many people have this issue, and it requires t-mobile support to resolve, that t-mobile wouldn’t develop a system wide solution rather than reuquiring each of us to reach out for assistance. That is extremely inefficient. 


not everyone wants short code on their phones..so its only added on a needed basis for each customer upon request. as it is with every carrier.

I’m also having this issue. All of my settings are on unblocked, but I still cannot receive verification codes for most websites, which is very frustrating.

 

I’m using an iPhone 12 and I tried tapping the link provided, I’m sent back to this page. 

FRUSTRATING. Can someone please either a) provide the actual link to the page for fixing this or b) explain to me what combination of logins I need to get to the right page and not back to this one?

Contact T-mobile using your Facebook messenger and they should be able to fix it within a few minutes. That was how I got my own fixed though they mentioned my settings were set to "blocked" certain numbers.

Contact T-mobile using your Facebook messenger and they should be able to fix it within a few minutes. That was how I got my own fixed though they mentioned my settings were set to "blocked" certain numbers.

Yup. That’s exactly what I ended up doing, although I just used the text message system for customer service on the T-Mobile app.

I also called in and they fixed it immediately. The default is to have these turned off for accounts. I agree that is a really frustrating default!

I just had this problem and what fixed it for me was I went to my phone settings and checked for a software update which there was none, but then I clicked on update PRL and update Profile which it did update and all of a sudden all my text messages came through.

I contacted T-mobile via Facebook messenger and they mentioned something like my status was set to "block" certain numbers so they had to remove it and now I'm fine.

I just had this problem and what fixed it for me was I went to my phone settings and checked for a software update which there was none, but then I clicked on update PRL and update Profile which it did update and all of a sudden all my text messages came through.

What is PRL? How would i do this as i am having same issue.

Userlevel 5
Badge +8

PRL=Preferred Roaming List.. phone dependent you can usually go into your settings to update this 

Reply