Solved

Numbers coming in incorreclty - showing as foreign countries


Whenever I receive a call from a number that is not saved in my contacts, the Caller ID shows it incorrectly. It appears as if it's adding a country code that is not correct, or just breaking the number apart incorrectly and showing it coming in from a different country all together. This has only been going on for about a week. The numbers below are in fact US numbers, if you look at the one labeled peru, it should be (513)-393-2193 - I dont know where the extra 6 is coming from.  The Argentina number, is actually 877 -698-3261. Again, no idea where the +54 is coming from and the Croatia number is 385 428 1000 - no extra numbers there, it just formatted it incorrectly.

Is anyone else having this problem? I've hard reset the phone numerous times, no fix

icon

Best answer by tmo_chris 30 July 2018, 19:35

View original

39 replies

I was having the same problem for months and just fixed it using what @jorfanakos wrote and it worked:

If you check under 'phone' in setting (iPhone users), the 'My Number' probably has a + in front of your phone number. I tried removing the + by re-entering my phone number and it would not accept the change.

So I looked further down where it say 'Show my caller ID" and clicked on it. What I did was turn it OFF, wait 2 seconds and then turn it ON again.

Then you return to the phone page and you should see the + is gone from you phone number when looking at the 'My Number'.

Et Voila! 😊

Hope this helps!

I think I figured out what's happening (in my case, at least).

I'm international (Spain) and have the $50 15GB add-on, so I'm calling back to the US a decent amount. My friends told me that when I call them it comes from a Russian number, so I asked for a screenshot which revealed a lot. My US number is in the 720 area code. Russia's intl country code is 7, evidently.

When I call then from Spain, T-mobile knows that I'm international, so they format it accordingly by adding a +. But they appear to not know that I'm dialing using a US phone, so they don't add the +1 (just the +). Therefore, the recipient's phone sees +7 and formats it as a Russian number.

I was having the same problem for months and just fixed it using what @jorfanakos wrote and it worked:

 

If you check under 'phone' in setting (iPhone users), the 'My Number' probably has a + in front of your phone number. I tried removing the + by re-entering my phone number and it would not accept the change.

 

So I looked further down where it say 'Show my caller ID" and clicked on it. What I did was turn it OFF, wait 2 seconds and then turn it ON again.

Then you return to the phone page and you should see the + is gone from you phone number when looking at the 'My Number'.

 

Et Voila! 😊

 

Hope this helps!

This definitely worked for me.

 

My issue was different, as my contacts when searching for a name in my text messenger app would add +52 Mexico Country Code to the front of all of them. Annoying to look at but didn't seem to effect anything.

But to reiterate, goto phone, the 3 dots, settings, supplementary services turn off caller ID wait a few seconds then turn on.

 

Thanks dlap!

Userlevel 4

Hey, @w053lxl​!

Welcome to our Support Community! Boy, do you have an interesting issue going on. Thanks for already trying the hard reset. It's likely a setting within the phone. Which iPhone are you using? Do you have a T-Mobile SIM inserted in the phone? Are you within the US when trying to call the numbers shown? Lastly, when this started a week ago, was this after a software update or did you change any settings? I'll do my best to help get to the bottom of this!

iPhone X, yes it’s a T-Mobile sim and no changes at all to Software or settings

>

Userlevel 3

Thanks for coming back to let us know what type of phone you're using! Amanda had a few other questions as well if you have a sec to fill us in:

Do you have a T-Mobile SIM inserted in the phone? Are you within the US when trying to call the numbers shown? Lastly, when this started a week ago, was this after a software update or did you change any settings? I'll do my best to help get to the bottom of this!

Thanks! 😊

I share exactly the same problem. Started 2 weeks ago after a T-mobile carrier up-date. My boss lives in Wisconsin and has a 920 area code. He is in my telephone book but he gets not recognized and it shows the call comes from +92 Pakistan. I even got a marketing message from T-Mobile telling that they are adding more countries to my international plan... I live in New Hampshire, area code 603 / +60 is Malaysia. Very annoying.

iPhone 7s / ~1,5 years old never had an issue before.

Userlevel 3

Whoa, that is odd @magenta1536507​! Thanks for providing the additional info!
I know we sent marketing messages about our recent changes to the Simple Global country list to many folks, so I don't believe that's related although the timing is super awkward. I am really curious about the fact that your phone is suddenly recognizing numbers you've had stored for ages as international numbers, though.
Although it seems the OP is using an iOS as well, we haven't seen a ton of action regarding this in our Community yet. Can you double check the country format in your contacts using these steps: iCloud: Change the country format for iCloud Contacts 

Userlevel 4

Sorry to hear you are also having issues with this. What is your current software version?

My iPhone runs IOS 11.4.1

Thanks for looking into this.

Sven

Sent from my iPhone

Userlevel 2

Do you store domestic numbers as +1920-xxx-xxxx etc.?  IOW, put  a "+1" before the area code in stored numbers and see what happens.

Yes I do, I travel a lot international and it ensures that I can call my contacts no matter of my location.

Send from my iPad

Userlevel 4

I am pretty stumped on this one. I have been searching the web for quite a while and this was the best thread I could find on the issue. Incoming Local Calls Displaying as Intern… - Apple Community​. Wanna take a peek through that and see if there is any value? 

Userlevel 4

Hey, @magenta1536507​!

Did you have a chance to check out the link Chris posted? If so, any luck? *fingers crossed*

I looked at it but so far no luck.

Sven

Sent from my iPhone

Userlevel 4

Sorry about that! This is a tough one cause it looks like it's a Apple SW issue with the formatting. Have you had a chance to reach out to Apple support?

I have been seeing the same problem for the past month or so - caller ids from all around the world, when they are actually from the United States.  

I have had the same Samsung Galaxy phone for over 2 years

I have a Samsung Galaxy phone (2+ years), and started noticing this same issue in October 2018.  Have been in the U.S. the entire time.  

Has this issue been fixed? My husband and I just started experience this today. Phone calls from my work are coming up as "Greece". I'm guessing since its a 303 number it's coming up as Greece because +30 is the country code for Greece. I have had my work number saved in my phone for 8 years...so why is this just now happening?

Try adding a “+1” before the affected contact‘s number. This worked for me

I have been having the same problem too for the past few months.

Device is iphone XS, iOS 12.1.2.

Been using iphones for about 8 years, never had this issue.

Just to re-iterate the problem:

(abc) def-ghij shows up as +ab c defg hij

So, a NY state number (315) abc-defg shows up as +31 5ab cd ef g (Zutphen, Geiderland, Netherlands).

This is regardless if the number is in my contacts or not.

Tried a plethora of software tweaks.

Apple feels is 'confident' that caller ID information is a product of the carrier, and the device will only relay the information provided by the carrier.

Please....help!

I am currently having this issue as well. Honestly, my issues started at the same time, and I have done all the tricks to get this to work properly. This is a T-Mobile issue, and not an IPhone issue. I also have a personal phone I use with a different provider, and I don't have this issue at all....this is the programming done on T-Mobiles end, and they need to fix it....

Feb 21, 2019 - same issue here on all our T-Mobile iPhones.  The other family iPhones / colleague iPhones with different carriers using the same current 12.1.4 iOS don't have this issue.  It does not seem to make a difference if the incoming caller in my address book or not, nor does it make a difference if they are in my address book and their number has  +1 at the front .... most of my incoming calls from local US numbers are all appearing as international inbound calls.  For example I live in 610 area code and calls are coming in as +61 Australia.

I have been working with T-Mobile tech support.  The reset the caller the ID on all the phones (disable / re-enable / re-entered the names) and reset the Home Locator Registry.  it has been 3 days and it *seems* to have fixed the problem on the phones.  We are monitoring and will wait for a full week from today before closing the ticket.

Reply