Solved

Problem With Visual Voicemail


I am subscribed to the Visual Voicemail version 5.21.7.80864 feature on my T-Mobile account on the Samsung Galaxy S8 running Oreo version 8.0.0.  Most of the time, it fails to synchronize my messages to the app.  I get a message that says it failed to synchronize messages and to make sure I am connected to the data network.  This is happening whether WiFi is on or off and I'm never in an area where I am not well covered by the T-Mobile network.  This is very annoying because I use my phone for business as well as personal calls and I need Visual Voicemail to work consistently! 

I have uninstalled and reinstalled the app and cleared the data cache several times already.

icon

Best answer by tmo_amanda 15 June 2018, 20:20

Hey Everyone!

Thanks for chiming in to let us know what's going on with Visual Voicemail. This is something our Engineers are already aware of and are working on fixing. At this time, we don't have an estimate of when it'll be back up and running as it should but we've collected enough examples to move forward with finding a solution. Once I receive an update, I'll be sure to update this thread.

View original

55 replies

Same issue. LG Stylo 3+. 

I have the Google Pixel XL.  I keep getting the message it failed to connect to server.  Out of nowhere it just quit on me. I'm running version 5.21.  I'm going to rtry and download an earlier version see what happens.  But I have cleaned cache deleted everything from storage uninstalled reinstalled many times it keeps saying the same thin. So like I said I'm going to rtry and download an earlier version.

I did everything, sort of a factory reset on my Samsung Galaxy S8.  I am

about ready to give up on T-Mobile's Visual Voicemail app and try a

third party service instead.  It sucks.

Userlevel 5

Hey Everyone!

Thanks for chiming in to let us know what's going on with Visual Voicemail. This is something our Engineers are already aware of and are working on fixing. At this time, we don't have an estimate of when it'll be back up and running as it should but we've collected enough examples to move forward with finding a solution. Once I receive an update, I'll be sure to update this thread.

I think I can confirm that they're working on this.  I began experiencing the problem this morning, which says that they're pushing changes.  Some things can only be tested in the field, unfortunately.  Before that, it was about 4 years with nary a hitch.  This is the first time I've used the basic voicemail in years - I'd forgotten how user hostile it is.

Moto X4

Android 8.0.0

Build OPWS27.1.3

I've been having this problem since April r so on my Pixel. Hopefully this is resolved soon.

I tried installing an earlier version of Visual Voicemail .Still the same problem however.  One thing I can tell you I'd get voice to text option .Even though I can't listen to my voicemails I get them by text immediately.  I realize this is a $4 plan .I called them told them why I needed it and in a 2 minute phone call was given a promotion to have it for free.

I had this problem too and seemed to have solved it.  I got a new Pixel 2 and T-Mobile Visual Voicemail would never sync, regardless of my type of connection.  I tried a lot of remedies and nothing worked until I installed an old version of the app.  I read these instructions on how to do it: How to Install Old Version of Any Android App and Verify it | TechWiser   I followed the instructions and found version 5.18.1.80670, which was the most recent previous version.  I installed it and it synced to the server correctly.  A few days later, it auto updated back to 5.21.7.80864, but so far it continues to work.  I hope this helps anyone else who is having this frustrating problem.

I also am having issues with Visual Voicemail syncing. This issue only started after the newest update 8.0 the other day. In addition my phone is sluggish in all functions all together and I also use my phone for business as well as personal matters and this is extremely inconvenience and frustrating. These issues need to be addressed as quickly as possible!

Update: when the auto-update to 5.21.7.80864 happened, visual voicemail seemed to work for about one day, then started having syncing problems again.  I went back to version 5.18.1.80670 and turned off auto-updates on my phone.  Unfortunately, it is not possible to turn off auto-updates for just Visual Voicemail; I have to turn off auto-updates for all apps).  But since then, Visual Voicemail is continuing to work using the old version.

Badge

Looks like Visual Voicemail is also broken on the BlackBerry KeyONE with Oreo 8.1. Used to work 100% with Nougat. I don't even think I'm getting standard VM notifications at this point on my phone although I continue to get them on my LG Watch Sport that's been linked to my primary number with Digits (with paired data). If I access voicemail (from my phone) the old way -- by pressing the 1 key -- messages are there.

The weird thing is that people are reporting no problems with T-Mobile and the BlackBerry Key2 with Oreo, so I'm baffled as to why this would have only broken on the KeyONE. It's frustrating for sure.

Same problem. Moto Z2 force Oreo 8.0Called support numerous times, ticket got written and sent to tech support to be called back in 2 business days, No call back since mid auback. Not that I expected it from T-Mobile. Currently waiting for Verizon to have a good enough offer for me to switch

Badge

I ended up having to install T-Mobile's Visual Voicemail app just so I could have voicemail notifications at all. Although the T-Mobile Visual Voicemail app does implement that service on its own, it should be completely unnecessary on most Android phones since Android 6.0 (aka "Marshmallow"):

https://www.tmonews.com/2015/07/android-m-will-include-native-visual-voicemail-and-t-mobile-will-support-it/

T-Mobile customers are now seeing voicemail transcripts in Google Phone app

any updates amanada?  i have the same issue for over a month when i transferred over

After the upgrade to Android 8.1.0, I am also not able to get Visual Voicemail in the native Keyone Phone app. Nor do I get v-mail notifications in the system status bar.

Badge

I've tried clearing the Phone app cache, checking permissions, enabling/disabling VVM (with and without wifi enabled). Reset network settings. Nothing helps and no error is reported in the Phone app when turning VVM on. I always end up just having to re-install the T-Mobile Voicemail app and using that instead (you cannot enable native VVM with the T-Mobile VVM app installed).

What I did notice is that if I uninstall the T-Mobile VVM app and then disable VVM in the native Phone App (so just relying on basic VM), if I call my phone from another phone and leave a message, the screen will flash briefly and the red led indicator will blink at the same time, but the message isn't there long enough to see what it says and the indicator stops blinking immediately. I'm think the phone is receiving a VM notification but its then getting consumed by some other process. ¯\_(ツ)_/¯

This is all very aggravating. I know other people on a variety of devices are having this problem. It's just not clear if its an Oreo problem, a device manufacturer problem, or a T-Mobile problem.

I spoke with BlackberryMobile Support, and they are aware of this issue. They said it's due to some certificate which needs to be updated, either t-mobile needs an updated certificate from Blackberry Mobile, or Blackberry Mobile needs a new certificate from T-mobile, I'm not sure which. The rep on the phone says that he believes they are working on resolving it, but isn't sure. Until the two companies resolve it, we will not have visual voicemail in the BB native phone app.

He did also mention that until that happens, it might be best to turn off the visual voicemail option in the native Phone app, because you will not get voicemail notifications in the status bar if that is on, until they solve the certificate thing.

I tried it: I went to the phone app settings, and turned off visual voicemail and now (after leaving myself a new voicemail) I am getting a voicemail notification icon.

I just got the Oreo update on my Keyone and no longer receive voicemail notifications or in the native app. I hope they resolve this soon because I called and had 26 voicemails that I didn't know I had.

Hi

Is there an update on this? I looks like it's been months since post the engineers were  that engineers were working on it.  Mine stopped working 4 days ago.  I had quite a few messages I was not aware of.  This is very disappointing and no ETA with no updates 5 months later is not very impressive customer service.

I am so disgusted with tmobile right now. Being able to have access to my voicemails is vital to my career and business. I cleared the data on the voicemail app after experiencing the same issue and now ALL of my voicemails are gone. This all stemmed from that update android kept prompting me to do. I had very important messages regarding my job and personal life and now everything is completely gone. I called the customer care number and they did not help one bit. I am so upset. I am going to speak with my mom about switching back to Verizon. I NEVER had any issues with them except that they're a little more expensive but I see now you get what you pay for.

A

This is what I got when I go to app store now.  I have not had vvm since December 2nd  and before that it would not update my messages . I messaged through app have not heard a thing.  Someone want to help it is a HTC U11 I am so aggravated.

I have a Samsung Galaxy S8 and I have not been able to us my VVM either for a long long time. It is very annoying. Just "Failed to Synchronize" error message.

Any updates?

It's been a while and this is really inconvenient.

I had this issue on my last phone. I recently switched and I'm still having this same issue.

Have you all checked to make sure that the visual voicemail app is set to ignore the battery optimizations?  This can cause problems with synchronization if it's not turned on.

Reply