Struggling to connect with App or Customer Care message/chat

  • 14 September 2020
  • 2 replies


I’m a new customer and I am unable to get set up on the app. It will say it is setting me up briefly, then I get an error screen that says “Sorry, something is not quite right here. Unfortunately the T-mobile App is not available at this time due to technical difficulties. Please try back later”. I tried waiting before attempting again, I tried turning my phone off and on, I tried deleting the app and redownloading it. None of the above worked. I googled and saw that others have had this problem. Any advice to resolve?

My other issue is, I’m having trouble getting my “carrier freedom” issue taken care of. I have not received a mailing label to send my two phones in. And I was told today on a call that I cannot submit my reimbursement request on without first mailing in my trade in phones. That same rep advised that I could message a rep instead of calling/being on the line and tying up time because I had to go to a meeting and had to hang up. However I see no where on the site that I can message a rep via chat or email/contact tool. The help, support and contact us pages only indicate being able to call or contact T-mobile via facebook twitter, etc. I do not do social media. How can I message a rep for help? I really need to get this issue resolved on the carrier freedom/sending my phones in/requesting reimbursement before I run out of time.


2 replies

Userlevel 6
Badge +13

You will need to contact Customer Care via 611.  

Userlevel 4
Badge +8

Go to settings > apps> choose the Tmobile app> storage > wipe the data & the cache> force stop the app and uninstall. Restart the phone. Go to the play store & reinstall the Tmobile app. Then it should work; it did for me & my hubby on different phones (LG & Samsung). It’s a quirky app that doesn’t like to work if it’s part of the transferred data.

P.S. This app won’t work for prepaid accounts.