Suddenly cannot connect to network

  • 30 June 2020
  • 5 replies


I have a pay as you go legacy SIM in an older Moto G4 Play Android phone. I powered it off in the middle of last week and powered it on yesterday.  It will not register to the T-Mobile network here in coastal Los Angeles.  It shows “Emergency Calls Only”. My wife’s phone connects to T-Mobile from the same location, also with a pay as you go legacy SIM.

Scanning for carriers, it finds T-Mobile and AT&T.  Selecting T-Mobile manually causes it to try to register for a while and then say my SIM does not allow connecting to the T-Mobile network.  Moving the SIM to a different phone shows the same situation.  I inspected the SIM and do not see any problems with the contacts, and no difference when I tried gently polishing them with a pencil eraser.

Can a SIM fail this way?  I think it is at least 10+ years old. The phone doesn’t report any issue like “SIM not detected” that I have seen years ago with other SIM-related problems...

5 replies

Userlevel 7
Badge +13

Have you tried swapping sims between phones to see if it’s a phone or sim card issue.

Sims cards can fail so you may need a new one.

Userlevel 4
Badge +8

YES! Try switching SIM cards with your wife. If your SIM doesn’t work in her phone, it’s the SIM. If your SIM does work in her phone & her  SIM doesn’t work in your phone, it’s your phone! :open_mouth:


Yes, if I swap them the problem follows the SIM.  Both phones connect normally with her SIM.

The T-Mobile tech support guy at 1-800-937-8997 said my account was in normal status and just suggested I go to a local store to have the SIM checked or replaced. 


I got a free replacement SIM at my local store and that fixed it. 

Userlevel 4
Badge +8

Woohoo! :cowboy:  (I’m sooo glad there’s a cowboy emoji!)