T-Mobile Galaxy Avant can't update T-Mobile Tuesday app!

  • 28 August 2018
  • 1 reply
  • 19 views

  • Anonymous
  • 0 replies

My T-Mobile Tuesday app says I have to update the app to continue but when I try to update the app on my Galaxy Avant, Google Play says that the current version is not compatible with my phone. T-Mobile either needs to update the phone or make the current app compatible with Android 4.4. It will be a few months more before I replace this phone.


1 reply

Userlevel 6
Badge +13

Ah, that's rough. I've checked for upcoming software updates and we don't have anything in the works for the Avant. The latest I've seen with the T-Mobile Tuesdays app is that the earliest Android OS version it'll work with is 5.0. Sorry for I don't have better news.

Reply