Solved

T-Mobile USA App for Android 6.7.1.5 not working


Since upgrading to the T-Mobile USA App for Android 6.7.1.5, it no longer works on an unlocked non-rooted Motorola G3 (Motorola G 3rd generation) with 2GB RAM and 16GB ROM. The prior version of the app (maybe 6.0.1.40?) worked most of the time. I have tried every known researched and suggested resolution options, including, but not limited to, deleting and reinstalling the app (probably at least a dozen times), rebooting the phone, changing T-Mobile password, clearing cache and data, force stop and restart, booting into recovery mode and clearing the phone system cache, deleting other apps, etc., etc., etc.

I have called T-Mobile support (very nice and trying to be very helpful), have engaged Executive Response (very nice and trying to be very helpful) and tried all known T-Mobile support options. So getting support is "an issue" when the T-Mobile app is not working, the my.t-mobile.com "Message Us" always says "Session expired" (will start a new discussion later on that one) and the Support Community access is/was deactivated and no T-Mobile email support option. A big thanks to Meisha via T-Mobile support call center and tmo_marissa for getting my Support Community access reactivated!

Anyway, when I upgraded the app and try to run after allowing all options, I always get into a recursive situation where the first attempt to run the app says "Getting your info" then "... technical difficulties ...", exit with "Not now", then the second attempt says "And done" then "... cannot authorize your account ...".

Here are the screenshots in the order of this wonderful (not!) recursive problem:

I select Not Now and here is the second set of screenshots:

Anyone else experienced this and can offer a solution?

Thanks!

Steve.

icon

Best answer by sfware 30 March 2018, 19:48

My Executive Response Specialist said this yesterday afternoon:

"We have identified the issue and it seems to be with non-T-Mobile devices.  My team is working toward a fix but has not found the resolution as of yet.  I will keep you posted as I receive updates."

So still just waiting "patiently"! ;-)

Appreciate the TMO Community Support team checking and follow-up.

Take care and thanks again,

Steve.


View original

29 replies

Userlevel 5

Ouch, you're right, @sfware​ - this sure does make it hard to get support when you need it. I'm happy to hear that Marissa was able to restore your Support Community access. As for the app, when you worked with our teams over the phone (CARE and Executive Response), did they file a ticket with our Engineers? We had an issue similar to what you're talking about happen last week but it has since been resolved per our Engineers. 

Hi Amanda,

Yes, I think that there were multiple tickets opened for me last last week. The one for the app not working is/was 1270126, I think. (Another one for Support Community access is/was 1270379, I think, and is resolved, as you can probably tell. 😉 But I may have the tickets and related issues reversed in my note scribbles - I would like to be able to review all of my T-Mobile support tickets, but I digress. If 1270126 is the right ticket for the app not working, it should still be open, as the app is still not working, as noted in my initial post here. If the ticket was closed as resolved, I/we need to open another ticket as it is not resolved, at least for me this evening. And you may want to look at all of the T-Mobile USA app reviews at Google Play for this latest version of the app, as some of the 1 star reviews are from others where the app is not working.

Thanks,

Steve.

Userlevel 6
Badge +14

I'm glad you're able to use the Support Community but we do wanna make sure we can get app working too. Filing a ticket is the right way to go. Have you gotten any updates on it? What were you told after it was filed for you?

Mike,

I called TMO support to get a status update on my ticket(s) but the agent wanted to open a new ticket for the app not working and take full ownership of the problem until resolution - sounds like a good plan. It looks like in the text he sent me it says trouble ticket # 19214331 although earlier in the call he read out ticket # 27182856. And he mentioned that trouble ticket # 27179563 is for the Message us/Chat not working (from a laptop with Firefox for Linux). Since both of these are possibly authentication/SSO related, I will try to get them both worked together by same engineer or engineering team, if/when I get a call back from the support agent with this most recent ticket status. But note that I have mentioned on prior support calls and to Executive Response that there is a possibility that these 2 issues are related.

As a customer, I REALLY would like to at least view the tickets to be able to assist in problem resolution (and for full transparency 😉. I realize that the current TMO ticket system is for internal use only. I was a bit disappointed that I was unable to easily call and get all current open and/or recently closed ticket numbers and the problem description text and last update status - that was the intent of my call. I would gladly accept a call (or email 😉 with all of the trouble ticket information associated with my account!

But looking forward to a resolution (soon) with the app not working as my notes indicate my first call to TMO support was on 27FEB2018, or about a month ago (but what's the rush 😉. I'm trying to be fairly patient as I can get to my account info. at my.t-mobile.com and via the USSD/##### codes.

Thanks, and take care,

Steve.

Just heard back from TMO support and it sounds like the issues are being worked (but they are swamped due to issues with some regional towers), so fingers (and toes) crossed for a resolution RSN!

Later,

Steve.

Userlevel 6
Badge +14

I hear ya, and we really appreciate you patience this whole time. I'm glad you heard back from our support team. I got my fingers crossed too, but I'm sure they can take care of this. Thanks a bunch for continuing to work with us.

Userlevel 6
Badge +14

Hi again. I see it's been a few days, but I'm curious if you've gotten an updates on your ticket. if so, please let us know how things are going. Thank you.

Have not heard a thing, but thanks for checking.

Steve.

Userlevel 5

Anything yet?

My Executive Response Specialist said this yesterday afternoon:

"We have identified the issue and it seems to be with non-T-Mobile devices.  My team is working toward a fix but has not found the resolution as of yet.  I will keep you posted as I receive updates."

So still just waiting "patiently"! ;-)

Appreciate the TMO Community Support team checking and follow-up.

Take care and thanks again,

Steve.


Userlevel 5

That is great to hear! I will mark your last response as correct for now but please feel free to reply back to this thread whenever 😊

I have verified that the current T-Mobile USA app for Android version 6.8.0.16 works fine now on my Moto G3. So feel free to have the TMO support team close the ticket(s?) I have open on this issue.

Thanks,

Steve.

Userlevel 5
Badge +11

Well, it's my turn. A couple of days ago I couldn't get into the T-Mobile app , and yes I am using aT-Mobile phone. If I need anything regarding this I can visit or call the corporate store a few miles south in Champaign.

Userlevel 5

Oh no! What happens when you try to access the app? Are you having the same issue on Wi-Fi and cellular?

Userlevel 5
Badge +11

Neither one. When I use the app I get to "We cannot connect to this page at the moment". I did contact Customer Care, and it seems they know there is a problem(s). The app will show when my money will expire, but not in the online account. I feel the expire date should be in both places. I do live about 8 miles from a corporate store in Champaign . I guess the store would be able to give me that date. On another item (with fingers crossed) I'm not getting all those FORESEE surveys.

Userlevel 5
Badge +11

I use WiFi to use the app. Don't know how to use cellular. If that uses data I don't have data plan just voice.

Userlevel 5

Thanks for clarifying @dc5fan 😊 If it is just specific content within the app that is not displaying then we will definitely need to get a support ticket opened up for that. When you spoke with our tech teams, do you know if they were able to get a ticket started for you?

Userlevel 5
Badge +11

The tech said she would send a ticket.  I am guessing that the site has done some changes. Something about turning off WiFi and wanting me to turn on data. Homey doesn't do data. I closed out the page and tried something else to come here. How many customers are having this problem? A couple of weeks ago the app was doing ok only I didn't see the expiration date when the money in my account would be wiped clean. Appreciate your looking into this!

Userlevel 5
Badge +11

I decided to check in. It appears that my T-Mobile online account is fixed. In the past would this account show the date when the money would expire? Also, I did check to login to the app, but I still "cannot connect". We're half way there. BTW, the online account looks good! Thanks.

Userlevel 5
Badge +11

My T-Mobile app is now working properly. That happened sometime this morning. I has answered this in another post.

Userlevel 5
Badge +11

OOPS! "Cannot connect"  this morning.

Userlevel 5
Badge +11

Chris: Is there any news regarding the app as far as being fixed? Is the app completely shut down, or are there members getting access? Just asking.

Userlevel 5

Oh man! What a roller coaster of emotions! I am not showing any issues with the app currently. Would you be able to try uninstalling the T-Mobile app updates and reinstalling them? Also, have you tried connecting on both Wi-Fi and T-Mobile cell networks?

Userlevel 5
Badge +11

Chris: Here we go. Uninstalled the app; reinstalled app (to 6.8.0.16); cleared cache and cleared data; tried the  app again; got Cannot connect. This is using my WiFi. I am lost at "T-Mobile cell networks".

Userlevel 5
Badge +11

I figured out "T-Mobile cell networks". I shut down the WiFi and used the phone as if I was calling (well, d-u-h) , and got to the account. Doing it this way I am taking it that I won't be using any minutes. So I think this has been the fix. Thank you!

Reply