Text messages coming in as email addresses

Lately I have been receiving text messages from friends as email addresses.


For example, a friend of mine (who I have their contact information saved in my Google account) texted me and it came up as ********* instead of as his name that I have him saved as in my Google contacts.


This has been happening for many of my friends.  I can not make sense of this, and have no idea why it is doing this.  Has anyone else experienced this?  And if so, is there a fix?


Even when I go to his name in my contacts on my phone, and then compose a new message to him, and send it, it then appears in my messages app as the email address, and not his name.  So weird...



***edited personal info Mike C.***

31 replies

Userlevel 6
Badge +14

That's strange this is happening with multiple people @kennetht. Normally this'll happen if the other personal is intentionally sending an email. Do you notice it coming in with an attachment or does it only have plain text? Also, are they using some 3rd party messaging app or the pre-installed app?

it only has plain text in it, and from what I have collected, everyone is using their phones pre-installed app.  this is happening not only to me on my end, but happening to them on their end as well.

Userlevel 6
Badge +14

Interesting. Have you tried typing in the number manually then giving it another shot? I'd just like to see if that makes a difference. Thanks.

just tried it, does not do anything.  once i hit send, it reverts to the number and then the

Userlevel 6
Badge +14

Have you tried the Force Stop and Clear cache options on the messaging app?

Did you get this resolved? Having the same issue.

I just switched from Verizon Wireless to T-Mobil. My incoming text messages are coming in as emails. I raised this issue with customer support. They told me the issue is with Sprint, because sender is a Sprint Customer. This answer doesn’t make any sense. HELP

I am experiencing the same issue. Text messages from my sister were received correctly on 11/28/17, but as of 11/29/17, they are coming to my e-mail address, not my phone SMS app. The sender is also a T-Mobile customer, so you cannot blame this on a different carrier. I have been receiving SMS messages successfully from other senders. The sender is located in Austin, TX. Is it possible there is a problem in that area?

I've been having this problem with Samsung phones on T-Mobile for 2 years now without a fix. And if I respond, the text doesn't go through. To respond, I have to compose a new text and choose the persons phone number from my contacts. Every time! Please fix this! They come from all carriers:,, - Please please fix this Tmobile!

Userlevel 2

Wow, the only time I've seen this is when I deliberately send someone a E-mail text from my email. question is the sender add in email domain in with your number?  example if I wanted to send a text to email from my phone id enter in the recipient box normally where the number goes and if I wanted to send jondoe a text msg from my email to his phone  I would put I'd would check how the contact info is stored, and see if that solves the problem.

I have to send email to text's almost daily because no phones allowed on the job site.  TMO Chris the above number is fake no need to delete

So I've discovered that this occurs with Wifi texting only... Since this post has been "assumed resolved" (and is clearly not) I'm going to start a new thread..

I was able to contact the sender who confirmed that they had unintentionally sent their SMS messages to my e-mail address instead of my cell number. I had no idea the SMS app could send to e-mail addresses. I learned something! My issues is resolved (sender error), but I hope everyone else finds a solution for theirs.

Userlevel 2

It's simple if I text you via my email, and you store my contact info that only has my email info. what'll happen is You'll receive the text as a MMS msg, and when you reply you msg will go to my E-MAIL, then when I reply back from my email you'll get the msg as a MMS Text " Multimedia message Service".

Without getting into the technical aspect "MMS" rely on both the carrier, and internet to transfer the data from the sender to the recipient.  

Wifi calling and or having a mobile device connected via WIFI,  should make no difference. So check how the contact information is stored, I'm almost 100% positive, that's the issue.

I did a test today, I sent a msg from one phone to another,  I entered (***)***-****, as the recipient, the receiver converted the MMS to SMS as a Text, I replied back and the original phone got the msg as a SMS text.

So in short SMS are typically 160 characters or less, anytime this is exceeded the system automatically converts the msg to MMS. MMS can be used to send larger amounts of data such as pictures, video, and sending SMS to Email, and vice versa Email to SMS.

Mine is happening with all text, and I have tried every fix that anyone has offered on here. I went as high as Tmobile engineers, and they took weeks to look into it and simply said they did not know. It is annoying, as they are not only being sent by her email, but my responses hardly go through to her.

That would be nice if it was that easy. Have tried every fix under the sun. Tmobile engineers said that they have no idea. It is very frustrating.

Also still no solution here either.. 😥

Userlevel 6
Badge +14

Sorry to hear this is still going on. The engineering ticket is usually the last step to get something like this resolved if this is a network issue. I'm curious if you've ever tried your SIM in another phone to see if the messages still show up as an email. Is this happening with specific contacts? Are you using the pre-installed messaging app or a 3rd party app? If so, you'll want to uninstall any 3rd party apps, give the phone a restart, then test out the messaging again to see if the show up like normal.

This has happened to me and this is what I discovered:

Go to email app (settings)

go to exchange microsoft activesync settings

turn sync messages OFF

voila... whew this haunted me for 2 hope this helps all...have a great one

This has happened to me and this is what I discovered:

Go to email app (settings)

go to exchange microsoft activesync settings

turn sync messages OFF

voila... whew this haunted me for 2 hope this helps all...have a great one

I'm having the same problem and have had for years. I got the S9+ on release day but have yet to activate it because I do not want the same problem on it. I believe it started in my case many years ago when I was paying per text message on a different carrier and also couldn't type well on my phone. So I often texted people from my email and when they replied it came to my email.  It all worked fine until I got my first smartphone.  I suspect that somehow Google won't forget that alternate contact - even though it does NOT show up in the person's contact.  But like someone else, instead of selecting them, I type in their phone number manually, all looks OK but after sending I see it's sent to the phonenumber@emailforcarrier instead!  It's been so frustrating and no Tmobile employee has ever been able to fix it.  I even tried creating new contacts with nothing but their phone number for the few people it still messes up with and it doesn't help. Help please!  It also seems to be related to SMS/MMS since for some people it's only a problem when I reply to a group text, not text them directly. I hope someone can figure this out.  I believe that their contact for me is contaminated as well.  Thank you.

i work at T-Mobile, and i believe i might have found another solution, besides having the exchange issue.

reset network setting

set the APN settings to most up to date settings

erase ALL text messages in the phone, or else it wont work.

this worked for me instantly, after calling tech and not getting any answers.

I just purchased a new Kyocera Duraforce smartphone, and after setting the phone up and importing contacts and data from the old phone, I too started receiving emails of all phone text messages I received, also as an email message on my Hotmail account.    This was happening even with using the second phone on our T-Mobile account that was not changed, to call the first phone number on the new replacement Kyocera Duraforce phone.   Funny thing is, we never before even had linked our emails to receive notifications on our phones, or vise-versa.   The problem started immediately upon setting up the new android phone using google set up.

  Upon reading all the input on this forum, I followed literally every suggestion, and nothing worked.   Until I followed this input from vinay1sharma.   So I deleted the current setting, and rejoined the active T-Mobile network.

  But although I had previously turned off POP and IMAP in Gmail, and turned off sync in Hotmail, & Gmail, I thought about the sync settings of the actual internet browsers on the new phone.   There is Chrome, and the Android internet App, so I opened each of them and found that Sync was turned on in both browsers.

Now I am not sure whether resetting the APN did the trick, and/or turning off the browsers sync settings (as well as phone sync and any other sync setting I could find), but I am no longer getting emails also, of all text messages being sent us (on either phone line)

I don't know if somebody already said this but I was having the same problem. Getting text messages as email.

For me the problem was not my phone or carrier. It was the person sending the text message. If they try to send a SMS message but they use your personal email and not your phone number you get the impression that Tmobile is forwarding your text messages to the email.

In my case it was a group text and somebody used my email instead of my phone number. The other person was Tmobile also.

I'm guessing its a feature of SMS. If you type an email in the "TO" section instead of a phone number it will send your SMS message as an email for you.

Just tell whoever sent you a message to use your number.


This seems to have fixed the problem on my phone.  As a bonus after deleting the messages to and from the contact I was having this problem with I then backed up all the rest of my messages using Samsung cloud (I have an Galaxy S8) and then restored them after following your directions.  Now when I try to send the contact a message instead of showing up under their name and it having to be converted to a multimedia message (automatically) just their regular phone number shows up now.

What did you do exactly? I looked for the Microsoft activesync but I don't have it in my email settings as one person said. I also reset the APN and deleted all messages to and from the contacts that default to email and MMS. I then even cleared my cache for good measure, but I still have the problem. I wanted top follow up with what was working for others.