Tmobile App Does Not Work on My Pixel 2 - Any Fix?

Badge +1

When I start up the Tmobile app on my Pixel 2 I get a screen that says "Sorry, something is not quite right here."

I have had this problem for some time, but right now I am on Android 9 (Pie) with the October 5, 2018 security patch, and version of the app.

I have tried uninstall/reinstall.  Also, based on what I saw on some other thread, I enable all permissions for the app.

Is this a known problem?  Is there a fix?


Best answer by rinsf 11 October 2018, 20:49

View original

14 replies

Userlevel 6
Badge +15

This is kinda tough. Since T-Mobile doesn't sell this one, we can't guarantee it'll work with our services including the T-Mobile app​ We don't have any know issues with the app, but have you tried using this on a T-Mobile branded device running the latest software we support?

Badge +1

Well, I have over a hundred apps on my phone - they all work just fine and are carrier agnostic.  There is a difference between things like VoLTE which one would expect might not work with all phones - and an Android app which one would expect  to work on all phones regardless of carrier.

Of course the app would work on another phone - it worked on this phone in the past, does not now.  I assume the problem might have to do with compatibility problems with your app and Android Pie, given that it worked at some point before the Pie upgrade.  I was not expecting an immediate fix - but perhaps a referral to the developers to determine why the app does not work with the latest operating system on a popular phone might be in order?

Are you by chance using a VPN or an adblocker? When I first installed the app when I changed over to T-mobile with my Pixel 2 I had an issue when I had my Adblocker/VPN running (and I didn't white list the T-Mobile app) so itit was stopping the T-Mobile app from running. It was blocking the web address the app would log in through. If you have them, whitelist the app or turn it off and try again.

Badge +1


No ad-blocker or VPN.

So @ @unsungzer0 you have a Pixel 2, running Pie, and the app loads for you?  If so, that would suggest something is interfering with it, although all of my other apps run fine.

Yup. Once in a while I load it and it just spins. I'll close it and reopen it and its fine. It happens regardless of being on wifi or just using the wireless network signal? The error you are getting seems more like its an issue with the app not being able to connect. Did you happen to port your number over? Or was the account always on T-Mobile? I have heard some people had issues with logging in after porting their phone number from another carrier (which is what I had done as well). Either way, it is not related to Android Pi or the Pixel 2 (Which is a completely carrier unlocked phone and works on project FI which runs partially off the T-mobile network)

Dumb suggestion.. since you would assume installing and reinstalling would work and accomplish the same thing. Have you tried closing it after opening the app, then clearing the app data/cache?

Userlevel 6
Badge +15

It's possible that Pie and the current version of our app are incompatible, but since our devices aren't running Pie, it's hard to test something like that. However, I'll bring this up with our devs. As you mentioned, I can't guarantee a quick turnaround time for a fix, but this is something worth reporting.

I also own a Google Pixel 2 and had this issue with older versions of this app. I mostly experienced the issue when traveling abroad and having the phone connected to a roaming network. The app never worked outside of the US for some reason. Once I returned to the US and connected to TMo the app opened with no problem. I did a factory reset a couple of months ago to clean up my phone a little bit and the current version of the app works just fine. If you want to keep your data take a different approach as mine and clear the cache and storage and see what happens.

There is no compatibility issue as far as I can tell. Like I said above, I am on a pixel 2 running Pie (on the October security update) and outside of when i have issues with network connectivity to the server for the app, I have no issues.

Userlevel 6
Badge +15

That's awesome it's working for you. It's just that we can't guarantee it'll work for Non-T-Mobile devices or devices not running the latest software we support. Like other services and apps, it can be hit and miss with devices T-Mobile doesn't carry.

I understand you can not guarantee the app will work for Non T-Mobile devices because you pretty much have to say that. But, what I'm saying is I have the exact same OS, the same security update as him, and the exact same phone as him. I ran into the same problem which resolved the same day. The only time it has re-occurred is when I have an issue connecting to your t-mobile servers. I am explaining that it is very likely an issues with his account (some problem that I would not be able to see) OR a server connection issue. The OS really is unlikely to be the issue here (especially since another person with the pixel 2 said he had issues outside the US and it resolved after reinstalling / factory restoring his phone). But, believe me, I understand what you are saying.

Badge +1

Original poster reporting back - I figured out the problem and the solution.

The message I quoted in my original post ("Sorry, something is not quite right here") is the message the app gives if you have a non-Tmobile SIM, or, on some phones, no SIM at all in the phone.  I tested this on an LG G4 bought from T-mobile to make sure that that message was not unique to the Pixel 2.  It would have been nice if I had been told this by the T-mobile rep in response to my original inquiry as it applies to T-mobile sold phones as well.

Once you get that message because you have no or a non-Tmobile SIM in the phone - simply replacing the SIM does not make it go away.  This is the case both on the Pixel 2 and G4.    If you simply replace the SIM, you get the same message.  You have to do some combination of uninstall/reinstall/clear cache/erase data to get it to work.  It does not seem to be consistent.

In my situation, I downloaded and installed the Tmobile App while overseas and on a project FI Esim.  I got the message, figured it has something to do with being overseas, and forgot about it until recently.

To get the App to work on the Pixel 2 it wasn't enough to clear cache and memory and uninstall/reinstall.  I also had to remove the eSIM profile from the phone, even though the eSIM was not active. However, I could not recreate this problem - when I created the same condition later, an uninstall/reinstall/clear cache and data was sufficient.

I should have gotten at least part of this answer from T-mobile support instead of the answer I got.  The wording of the message for no SIM or a non-Tmobile SIM, and the fact that it does not go away simply by replacing with a Tmobile SIM, applies to T-mobile phones  (at least to the G4.)

Also, the excuse that it's not a T-mobile phone should not really apply in this case, as T-mobile had a promotion when the Pixel 2 first came out and Tmobile encouraged its customers to buy the Pixel 2 by providing bill credits.

Thank you so much for sharing this. I agree a hundred percent with you. I also don't bite on that excuse that the Pixel 2 is not supported. I bought the Pixel 2 because of the TMobile promotion just to get denied at the end for no apparent reason. FML.

Just clear cache and app data .. On my note 9 I cleared cache and app data. . I was able to get in. Good luck