Solved blocking messages

  • 2 September 2017
  • 21 replies



My home automation system sends me SMS messages using T-Mobile's email to SMS gateway.  I have been using it successfully for a number of months, but recently, my messages have been blocked.  I have included a sample rejection notice below.  Does anyone know precisely why my messages are being blocked all of a sudden and how to get around this?


Thanks so much for your help.



Error Icon

Message blocked

Your message to has been blocked. See technical details below for more information.

The response was:

550 permanent failure for one or more recipients (


Final-Recipient: rfc822;

Action: failed

Status: 5.0.0

Remote-MTA: dns; (, the

server for the domain

Diagnostic-Code: smtp; 550 permanent failure for one or more recipients (

Last-Attempt-Date: Fri, 01 Sep 2017 19:15:53 -0700 (PDT)


---------- Forwarded message ----------

From: Home Automation System <>

To: "" <>



Date: Fri, 01 Sep 2017 20:11:32 -0600

Subject: <message subject>

<message body>


Best answer by tmo_amanda 8 September 2017, 22:40

View original

21 replies

Userlevel 3

Looks like the email was blocked intentionally @magenta2540820 - There are a few similar threads - check them out and post back if you don't get anywhere...

email to sms gateway issues

email to rejected for banned content

Thanks for your reply.  I looked through those posts, but couldn't find an answer.  I'm using gmail SMTP to send my email and Gmail seems fine with my authentication/authorization.  When I look at the headers of the email, it passes SPF, DKIM, and the other checks mentioned in those posts.  I'm not sure why my emails are being blocked all of a sudden and what the rules are that I need to follow for them to work successfully with the service.  Thanks again for your help!

Userlevel 3

From what I read, it appeared that there was some learning/training to identify good/bad inbound messages.  Since it's something on the backend, probably out of scope for a customer facing support portal.  Did you try the enterprise support that was referenced?  Wonder if any of the @tmo_ users can comment...

Userlevel 4

Hey, @magenta2540820!

I'm not sure why it stopped all of the sudden, but as @j.a.r.v.i.s mentioned, you aren't the only one this is happening to. I just chatted with one of our Engineers regarding this and here are a few things he recommended trying:

  • If you're a DIGITS user, we recommend installing the app on your phone. Messages are successfully being sent and received through the app.
  • If there's an option for the email to be sent via HTML format, it should force the email to stay as MMSC. I know this option isn't always available especially if it's coming from a larger company such as your home automation system.

If neither of these workarounds work, the next step would be to contact Tech Support and file a ticket with them. The more tickets that are filed, the easier it is for our Engineers to determine why this is happening.

Having same problem. Started last week.

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its

recipients. This is a permanent error. The following address(es) failed:

    host []

    SMTP error from remote mail server after end of data:

    550 permanent failure for one or more recipients (

I've had no problems for many years....except when sending a url. I have to remove http.

I am getting the same message as of last week and reported it to Tmobile support but they do not have an answer yet the very same barracuda network device is associated with Tmobile.

This is part of what I get back as being blocked.

Remote Server returned '< #5.0.0 smtp; 550 permanent failure for one or more recipients (>'

Original message headers:

Return-Path: <>

Received: from (localhost [])

by (Postfix) with ESMTP id 3zQDgr04l1z2hsWBB

for <>; Mon, 22 Jan 2018 14:43:20 +0000 (UTC)

X-USANET-Received: from [] by via mtad (C8.MAIN.4.10L)

with ESMTP id 598waVoro4736Me4; Mon, 22 Jan 2018 14:43:14 -0000

Started failing for me two days back.  But, I had not used it in a while, so I cannot say when the problem *would have* started for me.  That said, all fail, to all addresses, from all email accounts/servers.  Also, I tried plain text and html.  Nothing in this thread is pointing in the right direction for issue I am seeing.  Is it working for anyone?  I am curious because I would like to use it, but have no huge need so I am not putting in a ticket.  Thanks to anyone for any help 😊 .

PS: I can hit Verizon, AT&T, Sprint and even Tracfone people from my email today.  So, it is not on my side.

I too started having the same issue.  I have an extensive network system/home automation/live support system at home (IT guy here) and rely on getting security/power outage/system changes, etc notification via my TXT messages on my T-Mobile phone.  I cannot stress how important it is that I don't miss any of them.

Well, yesterday I was configuring a new set of APC Smart UPSs with NMCs and email and text notifications were sent int the process.  I tested notifications through management console and everything passed but I never got any messages.  It wasn't until I checked my email that I noticed that except for the initial set, they were ALL rejected.
    host []
    SMTP error from remote mail server after end of data:
    550 permanent failure for one or more recipients (


I have the same issue, and it started  yesterday. I was able to send messages from my Gmail account, but now they come back as Error 550 - blocked. It's very frustrating as I like to send myself notes from my PC to my phone.

Userlevel 4
Badge +10

@nocebeca​, so sorry to hear that you're having issues with your messages!  When you're sending out the messages, are they in plain text (without any HTML)?  Also, it's definitely worth checking to see if you have a block placed on your line.  You can reach out to 611, use the Message Us link on this page, or reach out to T-Force via Facebook or Twitter.  I can't say as to why a block would suddenly appear there, but it's worth a check.  If there isn't a block, you will need to have your rep file an engineering ticket.  Let us know how it goes!

Thanks for the quick reply. I've already checked on my T-mo app on my phone, and there are no blocks. I knew that already as I regularly used to send myself notes. I sent my msg from Outlook in whatever format it is set to, but again that should not be the issue as I sending only reminders (text only). I will reach out to T-Mo if it the issue continues. Thanks again!

did you activated digits for the line to which you are trying to send email to text? I have observed that if digits if activated, it immediately starts blocking messages.

did you find any solution to this problem?


Hey, is anybody here hearing anything concrete about what these "RATE LIMITS" are for sending to: TMOMAIL.NET ???

I'm sure that's the NUMBER ONE (1) REASON why MOST of us are here reading this Thread RIGHT NOW...

So MOST ALL of us,

1) NEED to get a certain email "unblocked" from our NUMBER@TMOMAIL.NET account

and also

2) NEED to KNOW what these RATE LIMITS are that got us "BANNED" in the FIRST PLACE.... It's PRETTY HARD to KNOW when they aren't posted up anywhere and it's literally almost TABOO to find any information at all on the Subject... it's really riddiculous: the Internet is supposed to stand for the EXACT OPPOSITE kind of thing...supposed to be a Wealth of KNOWLEDGE...Guess i'm WRONG on that....


Did you get any resolution on this?

My home automation system's messages suddenly stopped on January 23rd (day of last message).

It was cleared up and it works fine now. Thanks for checking-

Thanks--James On Friday, March 1, 2019, 1:55:31 PM PST, magenta1986533 <> wrote:

#yiv6901079955 * #yiv6901079955 a #yiv6901079955 body {font-family:Helvetica, Arial, sans-serif;}#yiv6901079955 #yiv6901079955 h1, #yiv6901079955 h2, #yiv6901079955 h3, #yiv6901079955 h4, #yiv6901079955 h5, #yiv6901079955 h6, #yiv6901079955 p, #yiv6901079955 hr {}#yiv6901079955 .yiv6901079955button td {}


T-Mobile Support

| blocking messages

reply from magenta1986533 in Account & services - View the full discussion

Did you get any resolution on this?

My home automation system's messages suddenly stopped on January 23rd (day of last message).

Reply to this message by replying to this email, or go to the message on T-Mobile Support

Start a new discussion in Account & services by email or at T-Mobile Support

Following blocking messages in these streams: Inbox

This email was sent by T-Mobile Support because you are a registered user.

You may unsubscribe instantly from T-Mobile Support, or adjust email frequency in your email preferences

What was the resolution?

I am seeing this behavior as well.  The irony is that I run a website that supplies rebates to T-Mobile Customers when they purchase new phones, and these customers are not getting their SMS confirmations because they are being blocked by T-Mobile's barracuda network dragons.  I would appreciate knowing what magic incantations are needed to get past this blockage.  An example message blockage looks like this:

2019-03-10 21:19:40 1h3CPb-000678-8Z ** {phonenumberdigits] R=dkim_lookuphost T=dkim_remote_smtp [] X=TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=yes: SMTP error from remote mail server after end of data: 550 permanent failure for one or more recipients ({phonenumberdigits}

Is there any solution to this?  We host domain emails for a client that uses a program to send text reminders to her patients before their appointments.  T-mobile is blocking.

How do we correct?

Here is an example (I've replaced the recipient phone number with x's and the sender email with y's) :

<>: host[] said: 550 permanent

failure for one or more recipients ( (in

reply to end of DATA command)

Reporting-MTA: dns;

X-Postfix-Queue-ID: 707C81A1D9A

X-Postfix-Sender: rfc822;

Arrival-Date: Wed, 15 May 2019 14:22:19 +0000 (UTC)

Final-Recipient: rfc822;

Original-Recipient: rfc822;

Action: failed

Status: 5.0.0

Remote-MTA: dns;

Diagnostic-Code: smtp; 550 permanent failure for one or more recipients


Good day. I'm having the same problem with my phone as well. It started several months ago.

It wasn't important then, but my position at work has changed and it's becoming necessary that I get these messages now.

Can anything be done about this?