Solved

Unable to purchase phone online

  • 10 November 2018
  • 45 replies
  • 13896 views

I've been trying to purchase a phone upgrade for my wife. At least 20 times now and every time I get to the end I get, "oops we've hit a snag". Then it kicks me back to the page showing the phone I want.

Anyway to get around this silliness?

icon

Best answer by tmo_mike_c 19 November 2018, 17:03

View original

This topic has been closed for comments

45 replies

I doubt that.  T-Mobile is providing this and other tools to help customers help themselves, such as being able to change your services yourself.  It is very disappointing to see this problem--which I had as well when purchasing devices online--has been going on so long.  I don't think there is a motive to creating and allowing a problem like this to continue to go on.  It makes T-Mobile look incompetent.

When I had the trouble, I think same as this, it was roughly a month ago and I was purchasing two devices.  I closed the browser and started again or refreshed pages until it worked.  Shouldn't need to do it, but that's what I did.

I am also having this issue.  I wanted to try to upgrade to the white S10 (backordered) and was even willing to do it in store but when I stopped in today, I was told to go online since it is sold out.  I tried multiple times with different browsers on three different computers and on the T-Mobile app on my Galaxy S9, all with no luck.  Nothing happens once I click trade in device...

This has become very frustrating and a complete waste of time and is clearly a T-Mobile issue given all the people here who are having similar issues.

@magenta644033 try calling in to order it, worked with me and went smoothly, explain to them that this is a known issue and they shouldnt charge you the $20 upgrade fee.

Thank you! I called and was able to place the order over the phone (they

also waived the fee). The representative was also very helpful in

explaining exactly how the promo works and was very knowledgeable. A

significantly better experience compared to the website/app or in store.

If you’re looking at this in 2019, hopefully this helps you! I found out the issue was my card. For some reason, the system wouldn’t let my Discover credit card complete the order. When I swapped over to a Visa the order went though fine. Sucks because I wasted a Messaging Expert’s time but hopefully this explains the mystery for some people. Try a different card maybe?

I think I have found a solution to this issue.  After dealing with this for 6.5 hours with a retail store, online messaging, telephone CSR's and finally the TMobile Twitter Support team, I tried using an old ZIP CODE while checking out..... and it worked.  I moved over a year ago... I used my current address, but changed the ZIP CODE in the billing portion to my old zip, and it worked.  I have had the same issue with Chevron gas as well..... my address is current in all of my banking institutions and bills.  This was an enormous hassle and waste of time - this needs to be corrected immediately - there is no reason so many people should be having these issues due to a faulty payment services system. 

Tried upgrading my phone again today and still have this problem. Different browsers and operating systems, even tried the app on my I-Phone. With this problem being unresolved for close to a year with a who cares attitude from T-Mobile someone please tell me why I should stay?

Close to a 30 minute drive to the nearest store for me. In short WTF!!

This is obviously an ongoing issue! I'm not paying extra for assistance over the phone because this site is sub-par. Fix the glitch! I've tried multiple browsers and the app, I just want to buy a damn phone.

Wow, have literally tried upgrading from the iPhone 8 Plus to the iPhone 11 and all I get it the Oops we hit a snag! message that everyone is seeming to get. I’ve tried multiple browsers, the T-Mobile app itself, etc. Crazy how this thread is a year old and the same issue is still occurring.

WOW OVER A YEAR AND STILL NO RESOLVE

Today is 12/18 and I have been having this issue for over 2 months,  is the site ever going to work. it is a little ridiculous that I am forced to go to the store,  to purchase a phone only because the site just never seems to work. I have tried, different browsers, clear history, clear cache, etc.... and NOTHING. PLEASE FIX THE SITE   😥

Userlevel 6
Badge +15

Is anyone here still having trouble upgrading and getting this same error message? I'm not seeing this issue should be going on, but I wanna make sure folks are able to get phone's purchased. Thanks!

Yyep all day! Absolutely ridiculous for a company of this size to have such an error while trying to make you more money! People want to shop online for the convenience. This is NOT allowing that. So frustrated!

Userlevel 6
Badge +15

Are you getting the error only when you try to buy through the phone or have you tried purchasing online through a computer?

Still unable to make a purchase through either the app, or browser. The forever response is "Oops we hit a snag!"

Yes, same problem. Tried over a few different days, on the phone, on Safari, on Chrome, on Firefox... no difference. You guys have GOT to fix that stupid error message. It's bad enough that it's uninformative, it's worse that it's falsely reassuring ("The page did not load for some reason, but you are still on track."). I tried, for days, I really did. But that "Oopsies lolz!" message...

The year is 2020 and currently experiencing a pandemic. But good news if you want to upgrade just go to a store and pay $20 for no freaking reason... oh wait, we can't! You STILL, after 3 years of being reported, CANNOT upgrade devices online or on the mobile app. Think it's time I consider leaving this carrier...

Good news guys, it’s March 2021 and I still can’t buy a phone online. What is the point of having the option? And why does the message say we’re still on track lmao! Unbelievably annoying. 

I’ve try to upgrade my phone through the website using apps, phone, Tmobile app, different computers, etc. They all have the We hit a snag error. I can’t believe how long this problem have been going on for over 2 years, and you guys still can’t figure out the fix. It’s ridiculous!

This is still happening. Here’s the details from the debug console in Edge Chromium v 90.x:

 

{
    "failureType": "API Failure",
    "message": "Failed to post estimate installment to the underlying system.",
    "errorDetails": [
        {
            "code": "500",
            "message": "Failed to post estimate installment to the underlying system.",
            "details": "Failed to post estimate installment to the underlying system for Cart Id: mrsdinjqmnrgkljugjstsljugyztillche4willfgm2dcndemezgen3dmi=.",
            "errors": [
                {
                    "code": "dcp-api-checkout-v3-error-2659",
                    "message": "The call to enterprise systems to estimate the installment plan details have failed. Please resubmit the request.",
                    "details": "Error has occurred with EIP"
                }
            ]
        }
    ],
    "stackTrace": "Error\n    at modalInstance.uibModal.open.controller (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:120550:43)\n    at Object.invoke (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:20065:20)\n    at $controllerInit (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:26087:35)\n    at resolveSuccess (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:58396:35)\n    at processQueue (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:32278:38)\n    at https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:32326:28\n    at Scope.$digest (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:33463:16)\n    at Scope.$apply (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:33851:25)\n    at done (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:27723:48)\n    at completeRequest (https://my.t-mobile.com/app.ee6713aaf48a4031e1e4.js:27980:8)"
}

 

From the message, it looks like your EIP web service is broken. You need to engage your SREs to get this back online because THIS IS COSTING YOU MONEY.