Unable to submit rebate on T-Mobile Promotions - images aren't uploading

Hi I am trying to submit a rebate, but the images of receipt and box are not uploading. The website gives me an error - unable to upload, Retry. However, retrying didn't work.

I have tried this on 3 separate days, with 2 different browsers (Chrome and Edge) and two different PCs. Can someone please help?

I tried chatting with T-Mobile support, but they couldn't help either.


Best answer by tmo_mike_c 20 May 2019, 17:39

View original

42 replies

Userlevel 6
Badge +15

Ugh, that's pretty tough, but we wanna get this working. Are you able to take a new images and try to upload them? I'm just thinking there could be something going on with those particular files.

I can confirm the uploader appears to be broken.  Problem does not appear to be with the source image files, rather uploader.

Confirmed uploaded isn't working via several uniquely created PDF, jpg files, and png files, all attempted to be uploaded in Safari on 12.1, Firefox 66.0.3, and Chrome 74.0.3729.131 on Mac OS X 10.14.4 as of 5/10/2019 at 8PM PST.

I am having the same problem right now. I'm trying to upload my files and it's giving me the same error. Please help.

Confirming it is still not working as of 12:30PM PST.  Please post with solution or fix timeframe.

Here is a screenshot of the error I keep having.

I am having the exact same issue as of 3:17 CDT on Saturday, May 11.  Please fix or provide a work-around. 

Hey Folks, I got some info over twitter. So hopefully we can turn in our rebates soon!

I am the original poster - i had tried several different images large and small in size but it hadnt worked. finally combining these images into one PDF seems to have worked. hopefully it did submit the file effectively.

please try that - print all your images into one PDF. has to be less than 5MB.

Thanks for the advice.  I went ahead and tested again using this method (a method I used originally to see if it would work) and still not working.  I've used two different PDF creation engines to create the PDF as well with no difference in result. 

As of 05/12/2019 @ 11:07 AM PST it isn't working still via combined single file PDF or other separate image formats.

Hopefully they have this fixed per the Twitter update from ria616 by Thursday.

Yes i can confirm the same we still have same issue even tried uploading with single pdf file size 1.5 MB not working.

Userlevel 6
Badge +15

Please keep us posted on this and let us know if it's working on Thursday. Thanks for posting.

I also have same issue, I tried on 5/9 it was not working tried in jpg, pdf (single / multiple) error comes out with red boxes. One thing that I found today while upload and submit, there were around 5 submissions already done and denied because of no documents available.

I tried my best TMobile reps are saying to contact Costco wireless and they are saying to contact T mobile. Finally I found this thread hope someone can fix this issue.

I am also having the same problem

Nope, it isn't working either.

Userlevel 6
Badge +15

Might need to file a Help Desk ticket with our Care team. Please contact them so they can get it escalated for you.

is there a time frame when this issue will be fixed?

I am having the same problem. already tried all combinations and wasted a lot of time. when will be the solution?

Having same issue...why does it take them a week to fix this issue?


Solution : This error is due to some authentication issue. Click on error symbol at the end of URL  which is next to Bookmark symbol.

This will solve the issue and upload will be successful

Is this fixed yet, try for a couple days and getting same error. I tried numorous file formats and only one file and less than 200kb

Sorry, still does not work. When o clock on the error symbol, the file disappears and there is nothing to upload

Sent from my iPhone

Uploader still doesn't work correctly as of 05/14/2019 @ 08:47 PM PST on Safari on 12.1, Firefox 66.0.3, and Chrome 74.0.3729.131 on Mac OS X 10.14.5

Can you be more specific.  Your answer doesn't seem too specific.  What symbol at the end of a URL?  URL are just links. 

hemachandradmask it seems you are speaking in relative terms to your specific browser and GUI.  What browser are you using on what OS?  (Specific version numbers etc.)

Got it to work, thanks. George Wasyliwgeorge@fusiontechs.comwww.fusiontechs.com630-887-6611

Apparently the solution at this point is to use Google Chrome for Mac OS X (or Windows) (Version 74.0.3729.131 confirmed working on Mac OS X 10.14.5) and to click on the error / shield icon per hemachandradmask in the URL/Search Bar in Chrome after a failed upload.  From the dialogue that appears you can choose to allow scripts to be run via the insecure sources.  This appears to be a problem with how T-Mobile has designed the site to load some resources from a bad SSL certificate and website design.  Chrome just allows you to easily see the issue and override common web browser protections to allow for the upload since the overrides are as apparent as a feature in Safari or Firefox.

I tried submitting in unsecure mode as mentioned below, still does not

work. please help