USPS lost my trade in phone needed for a rebate

  • 26 November 2019
  • 27 replies
  • 3001 views

I purchased an iphone 11.  It has a rebate of $580.  The rebate requires a trade in, and I mailed in my old iphone 6s to Assurant with the prepaid label given at time of purchase.

 

The tracking number shows no activity after the iphone 6s was accepted by USPS.  (Tracking number: 92162901067815500230947524).  It simply says "in transit" and has said so for 2 weeks.  I have opened a a "missing mail" inquiry (USPS Missing Mail Search ID: 7879319). 

 

RIght now, T-mobile has notes in my account that I have inquired about this, and that I have filled out a missing mail search with USPS.

 

The phone must be received by December 4 or else the rebate is denied. (At this point, I assume the iphone 6s will never be found.)

 

My question:   Has T-mobile ever honored a rebate if the trade-in phone is lost by USPS?


27 replies

Userlevel 5

Greetings!

It's entirely situational, but there's a possibility it may be honored.

-Lauren

Userlevel 6
Badge +14

You're welcome to reach out to Care folks and explain the situation. It's worth a shot to see what can be done.

Just following up on this. 

At first, every person I spoke with at Customer Care about the post office losing the trade-in was cheery and was certain that T-mobile would do SOMETHING to "make this right."  So every 5 or so days I would call back to see if anything had changed...if maybe the device had shown up despite the tracking number showing no activity past November 17.  But it never showed up. 

Only after I insisted, someone finally did a "handset research form".  (I had to ask for it, based on what I read on the internet.) 

I called back in 2 days ago to see how that was going.  and I spoke to a customer care person again, and she laughingly told me that she checked the tracking number herself and could see that post office hasn't had any movement on this since November 17.  The "people in the back" will look at this and resolve it, she assured me.  They will contact the post office and and deal with the insurance and this will work out. 

Well, today I just got the email regarding the "handset research".  The email said the warehouse never received the device.  That was all the email said.

So I called Customer care once again.  Suddenly everything was different - I was now  told I would not get the $580 rebate --  "there was nothing that could be done since they never received the device", I was now told. 

All I could say was "Why didn't you tell me this was policy 3 weeks ago when I first called".  Why did you ask for the tracking number and then check it while on the phone with me....since none of that would make a difference. 

Three weeks ago I should have been told the truth: "If the phone doesn't show up, you get nothing."  Simple and direct.  Honest.   Why all the sweet talk and statements like "Tmobile will make this right" if the truth is:  "If the phone doesn't show up, you get nothing."

I would have immediately returned the iphone 11 to Costco, cancelled the phone line, and just cut my losses. 

Very disappointed.

quick note:  I was logged in under our main account, which is why that above "follow up" has a different name attached.  All responses are from me.

Hey, Any update on whats the final result? I am in similar situation but the next promotion of $700 one. Being helped but don’t have final result yet.

i see multiple people having these issues from 2017.

Krish007 - did your issue get resolved? I returned two phones with USPS on Dec 14th and they still show as "in-transit". The phones are worth $700 each in trade in credits. Thanks!

Also, if there is anyone who was in a similar situation but was able to get the issue resolved please let me know. I'm being given the run-around by tMobile. I don't understand how this can be the customers fault when the customer followed tMobile's instructions at a 100%.

I am facing similar problem now. i upgraded my Phone to Iphone 12 through costco. shipped trade in device on 02Nov2020.  It’s still on Transit.  I am calling tmobile every week. first week, tmobile request to wait for week and second day they want me to go to USPS store and check where is  the device. I went to USPS and checked.  USPS requested to file missing mail . I filed missing mail and no further update.  After 2 days, i called tmobile and checked for the trade in credit.  Tmobile representative informed, we will process trade in when we received device.  Today, i called again,  Tmobile Agent responded as “We are filing handset research form”. You will get credit in 5 to 7 business days. How i am responsible when i ship trade in device through shipping label generated by T-Mobile ?

@RMani im going through this exact situation right now.  I mailed 2 phones (separately) each worth $830 in credits.  Mailed them on Nov 18th and one arrived on Nov 30th after sitting “in transit” for several days. The other is STILL listed as ‘In Transit’ since November 25th. Opened a case with USPS 4 days ago and have t heard anything back other than they are looking into it.  
 

Contacted T-Mibile with the IEMI of the two phones (since neither had arrived yet) and they said:

 

“I appreciate you contacting USPS to inquire about the trade in devices. 

As long as you mailed the devices before the grace period ends and we have received them, you can be assured that you'll receive the trade in credits for the phones.

 

I have submitted the handset escalation. Please allow up to 5 business days for an update on this escalation. 

No need to contact us back. You'll be receiving an email update about this from our Handset Research Team. 

I'll make sure to monitor this as well.

 

That was nearly five days ago and I’ve heard nothing since, even though one of the phones was supposedly delivered.

Mine have to be in by Dec 12th and now it’s already almost December 4th  

 

 I used their label, so they should honor the credit and they should be dealing with USPS to resolve this. 🙁 

 

Contacted T-Mobile again about this and their response was “as long as you’ve sent the device back using the label you’re all good...you’ll continue to receive those device promotional credits.” I’ll believe it if/when the deadline hits and they haven’t received the phone. At least I have it in writing. I wish they would follow up with USPS and put some pressure on them, especially if I’m not the only one having issues  

 

USPS lost my trade-in also.

I shipped 3 trade-ins on November 23rd.  2 arrived, 1 did not arrive and has been in transit status for over 10 days after the 2 arrivals.  I reported to USPS through the online problem reporting immediately.  I then called the customer care at Tmobile.  I was told by TMobile to report to USPS.  USPS responded that the phone is missing and I need to contact TMobile since I used the TMobile printed shipping label.  USPS has a serious missing mail and mail theft problem.  Forcing customers to use USPS for trade-ins especially during holidays seems like a scam to funnel as many as phones to theft as possible and tie the customers hands in filing any claims.

Badge

USPS lost my trade-in also.

I shipped 3 trade-ins on November 23rd.  2 arrived, 1 did not arrive and has been in transit status for over 10 days after the 2 arrivals.  I reported to USPS through the online problem reporting immediately.  I then called the customer care at Tmobile.  I was told by TMobile to report to USPS.  USPS responded that the phone is missing and I need to contact TMobile since I used the TMobile printed shipping label.  USPS has a serious missing mail and mail theft problem.  Forcing customers to use USPS for trade-ins especially during holidays seems like a scam to funnel as many as phones to theft as possible and tie the customers hands in filing any claims.

I have the same issue. I even went in store for them to print out the return label. My tracking number hasn’t been updated since December 2nd and it just says “in transit”. Have you called and asked if your credit will still be honored? 

I have not asked about the status of that yet.  As for the last in-transit status, I noticed it was updated 3 times at least from November 30th to Dec 1st to Dec 3rd.  I had never seen a last in-transit status updated 3 times for all the packages that I mailed through USPS in the past.  I feel someone is changing information in the USPS tracking to confuse investigators if it is ever investigated.  

More research info - according to USPS section 609 1.3 Filing Indenmity Claim for Loss or Damage - the sender or the receiver or the contract holder ( in this case TMobile ) can file a claim between $50 to $100.  The maximum is $100.  Must show acceptable proof that it was mailed and the value mailed, which TMobile should already have.  So it is no wonder Tmobile Customer (don’t) Care gives their customers the run-around given the maximum that can be re-imbursed for each loss if they bother to file the claim at all.  As a sender that is you and me cannot show that we paid for the shipping since it was a printed pre-paid label.

Same issue for me, I traded in two devices for iPhone 12s and moved over to T-Mobile. USPS tracking hasn’t changed since Nov 28 and still shows in transit. I chatted with customer service and they first said since it was shipped on time, there should be no issue. Just got an email saying the warehouse did not receive the devices. Not sure what to do now, I definitely don’t want to pay $1700 for the phones :( 

Folks any updates on yours tradein return lost due to usps. I am in same boat as all you are.

Send 3 pkgs 12/8 two got received by tmo and got the proper credit. But one was checked in Lewisville TX post office on 12/13 and never get up dated as delivered still saying in transit. 

Open a case with usps and they still saying they looking into this. No final say from them.

Escalated to Tforce and told them about the whole situation and tell them a case is open with usps. They told me they filling a Form not sure what that means. Currently just waiting on Tforce. I am pretty sure usps has lost the pkg to theft. $730 credit for iPhone 8 will be my LOSS. 

Did anyone get this resolved?  It looks like I'm also headed in the same direction, as it's been days and the only USPS tracking updates recorded are "In Transit to Next Facility".  This has posted every single day at 12am.  Not looking forward to dealing with this.

Did anyone get this resolved?  It looks like I'm also headed in the same direction, as it's been days and the only USPS tracking updates recorded are "In Transit to Next Facility".  This has posted every single day at 12am.  Not looking forward to dealing with this.

 

I got a favorable Resolution Finally. USPS never reply to me even though i open a ticket.

Same time I contacted T-force and let them know whats going on. They also waited for USPS reply .

Then i got the email from TMO that they going to remove the credit since I never send them the tradein back. Then T-force Rep contacted me and told me that they understand its not my fault but USPS fault.

They decided to remove all my installment on the Device . So now I own the Device and zero due.

Way to go T-force (Twitter) they took care of all of my issue.

So anyone having issues escalate to T-force.

That is great news.  I will do just that.  Thanks!!  Appreciate it!

Did anyone get this resolved?  It looks like I'm also headed in the same direction, as it's been days and the only USPS tracking updates recorded are "In Transit to Next Facility".  This has posted every single day at 12am.  Not looking forward to dealing with this.

I too am in the same boat. I shipped on Feb 1 and tracking still says in transit to next facility. 

Did anyone get this resolved?  It looks like I'm also headed in the same direction, as it's been days and the only USPS tracking updates recorded are "In Transit to Next Facility".  This has posted every single day at 12am.  Not looking forward to dealing with this.

I too am in the same boat. I shipped on Feb 1 and tracking still says in transit to next facility. 

I have already called USPS, got a service request # and contacted T-Mobile.  T-Mobile will be following up with me on Monday to see if I get a response from USPS.

Did anyone get this resolved?  It looks like I'm also headed in the same direction, as it's been days and the only USPS tracking updates recorded are "In Transit to Next Facility".  This has posted every single day at 12am.  Not looking forward to dealing with this.

I too am in the same boat. I shipped on Feb 1 and tracking still says in transit to next facility. 

FYI, I just got a notification from T-Mobile that my trade-in was received, even though the USPS tracking data has not been updated since 2/7.

How did you guys contact T-Force? Been talking to Tmobile “Experts” 3 times. They reassured me I will get my credit. Now that the deadline has passed and Tmobile dropped the monthly installment. I contacted T-mobile Help on Twitter. The person is giving me the run around again and said she will issue another “search” even though USPS told me they have lost the phone and the fact that T-mobile has searched and found nothing three times.

This is the second time I am dealing with USPS not delivering my trade-in to Assurant. I recently traded in my Samsung Galaxy S9 for a new Samsung Galaxy S21. They supposedly to deliver two days ago, but still showing “In Transit, Arriving Late” on USPS.com. I have contacted T-Mobile and they told me to wait for 10 days. Then, I decided to email USPS and the supervisor emailed me back and told me they might have delivered my package but forgot to “scan it”. In addition, she asked me to contact T-Mobile or Assurant to see if they have received my old phone. This is very frustrating and stressful.  

How did you guys contact T-Force? Been talking to Tmobile “Experts” 3 times. They reassured me I will get my credit. Now that the deadline has passed and Tmobile dropped the monthly installment. I contacted T-mobile Help on Twitter. The person is giving me the run around again and said she will issue another “search” even though USPS told me they have lost the phone and the fact that T-mobile has searched and found nothing three times.

Update: Assurant is super scammy. They took a picture of a random flip phone and said they got my phone even though usps declared my phone lost. Note that i shipped in an iphone Xs max. 
Assurant or Tmobile gave me an option of accepting the value of $0.00 or return the fake phone to me. It’s crazy how many people are experiencing this. There’s a good chance phones are stolen and I cannot even lock the phone since I had to turn off find my iphone.

Who have a flip phone nowaday? Could you file a complaint with Better Business Bureau? I am worried about my case and this is the second time it happened to me.

Reply