Solved

Website account Payments Not Working with Chrome.

  • 28 February 2017
  • 7 replies
  • 362 views

After a TMO website support rep told me Monday, Feb-27-2017, the website Payments problems will be resolved in 36-72 hours, I have now determined that the website Payments just has a problem with the Chrome browser.

This morning I tested Payments using Internet Explorer and everything worked perfectly, Payment Method/credit card page did not close and revert back to account profile in 1-2 seconds.

icon

Best answer by edward_ 10 March 2017, 18:49

View original

7 replies

Userlevel 6
Badge +15

Since IE worked for you, did you already process the payment or did you go back to Chrome and test it out before making the payment?

Hello

I processed my payment using IE, but did go back to chrome and retested with the same results, 28-Feb-17.

Now, today (10-Mar-17) I tested the 'Refill your account' and the payment method page displays properly.

It does not revert back to the account page after 2 seconds.

This issue appears to be solved.

Userlevel 6
Badge +15

That's great news!

Thanks so much for coming back and keeping us updated on this. 😊

Umm, no, I dontd think this has ever been resolved.

For the past three years I have tried to make online payments using Google Chrome and I've been forced to use Edge every time. I've reported this issue several times, and they go through the usual, "follow the database and walk the user through all the browser related fixes, rlevant or not" routine, in spite of my telling them I've done all that, to no avail.

I don't think I was taken seriously even once. I've done cache clears, uninstalls, installs, etc. They just won't accept that it's sever-side, not client side. It's even been suggested that I compromise my browser's security settings to try and get it to work.(not gonna happen) This is happening regardless of hardware or OS platform. My discussions with tech support has been frustrating as I try to explain it to them to say the least. do I have to upload a video of it happening?

Back in the '90s, I hand coded HTML to create websites, and made sure it all worked in most of the browser out there, and this issue should NOT be happening. Browser testing is fundamental in website design. I gave up, because I was close to giving tech support a verbal bludgeoning and I find it distasteful.

I don't like usuing MS products much any more and try to avoid doing so, simply because they are inherently vulnerable to malcious code injections. Their website development apps, fromthe beginning used WAY too much code, 20 lines when just 1 would get it done (bandwidth pigs and load speed killers), and reading the code to debug it is nearly impossible. I don't care to toss my private information around on Edge, nor do I want to install applications that have only ONE momentary use.

So, having said all that, (BTW, this online editor is insanely obnoxious and difficult to use on Android Chrome), do you think T-Mobile can take a serious look at this issue?

Userlevel 6
Badge +15

Wow, that's surprising this has gone on for so long. Have you tried making payments on another browser to see if it's only happening with Chrome? This is normally something we'd need to file a Help Desk ticket for. When you spoke with Tech, did they mention doing this for you?

I just found this thread. My payments in Chrome have also not been working since I joined t-mobile - I always ended up making the payment through the t-mobile app on my phone but honestly that's a pain. Why can't the webpage work in Chrome? When I click the payments or "make a payment" button it clears the screen and displays the eight dots that seem to rotate indicating I have to wait - but it never changes.

Userlevel 6
Badge +15

Can you try clearing your cache and history in Chrome then give it a restart before trying again? I'd also make sure that the browser is up to date. If you've tested other browsers, please let us know if the payment goes through. Also, are you testing the Chrome browser on a mobile device or a computer?

Reply