APN settings unable to send MMS

  • 22 November 2013
  • 11 replies

I bought a 16GB Nexus 5 directly from Google and I put my T-Mobile SIM card in the phone. I can make/receive phone calls, send/receive text (SMS) messages, and use the internet no problem. However, I have two problems which I did not have on my old phone:

1) My phone keeps flip-flopping between 3G and 4G every few seconds.

2) I am unable to send MMS messages


From what I have gathered, this could be due to the "APN" settings.


I looked in my phone, and here is what I have...

APN: fast.t-mobile.com

MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc

MCC: 310

MNC: 260

APN type: default,supl,mms

APN protocol: IPv6

APN roaming protocol: IPv4


Are these settings correct? If these settings are correct, what else could be causing my problems?

11 replies

One item at a time :-)

3G/4G "flipping" --> This is normal. 4G is only used when your phone needs to send data. So to conserve power and bandwidth, it stays in 3G until an event requires it to switch to HSPA+ mode (aka 4G). On my N5, I also see LTE/4G/3G. The switch between LTE and 4G is because LTE is not officially implemented in my area yet... but by what I am seeing, this might be soon.

MMS messages --> It works on my Google purchased N5 (I just sent another picture that was converted to MMS). By the way, I use the built-in Google "Hangouts" app to exchange SMS and MMS messages.

Hi acbarberi,

Did you get the MMS working?



Yes, it is working now. Thanks for the info and help from flashfox 😊

Glad we could get this great device up and running! If you find you have any other questions please let us know!

Userlevel 5

Hello! It's been more than 36 hours since our last comment so we are now marking this post as assumed answered. You can continue to post, and other community users may respond, but if you would like assistance from T-Mobile or T-Force please create a new discussion.

I have an T-Mobile Flip Phone.

Here are what my settings look like:

  • Set Name
  • Access Name
  • Auth Type
  • User ID
  • Password
  • Protocol
  • Home URL
  • Proxy Address
  • Linger Time (sec.)


  • Advanced Settings

They are blank though. I need the information to fill them in.

Andrew - I am having the same issue as the one raised here (and am also a TMO employee).  When I go to the APN settings, they are greyed out and I am not allowed to change anything.  I spent 30 minutes with TMO tech support who couldn't figure out anything.  Do you have any other ideas?  When I go to the APN access points, there are two: T-Mobile Data (fast.t-mobile.com) and T-Mobile MMS (fast.t-mobile.com).  But, everything is greyed out when I go into either one so I can't make any changes. 

hi I had the same problem, but I just fixed it by using the link I will add here. I went to help at motorola and they had easy to follow step by step instructions how to reconfigure your phone settings to allow mms and photos sharing through texts. it works beautifully, as I just did it with 3 photos to my sister.  make sure you allow or accept afterwards when a prompt message asks for permission to access or share videos or photos, do yes for both.  also, I didn't change  things on the instructions as they were set to my location, which was the MCC which had already setting for my location. anything that I changed, I first wrote down the original setting incase I needed to put it back. the 2 things that they say may vary for location, leave those alone unless after following all instructions, and turning off then on, it don't work, then use their numbers. the rest follow exactly what they have. I went from not being able to send any photos to being able to do photos and video instantly. works beautifully. If I can do it, so can you as, I am no techy, just crazy or brave enough to try it out, otherwise my new phone would have been useless for me because I need to be able to send instant photos for work.  suggestion is to screen shot or write down any settings before you change them so you can easily revert back to what you had,especially if you arent sure how to put things back to default.  then change away, because you can always put them the way they were.

anyway its working great for me and took less than 10 minutes to resolve once I found the solution! good luck!


I have similar problem with my Sony XA1 ultra and the issues seems to occur after upgrade to the newest Android (?8) in March 2018.

Called T-mobile support that was very helpful, but back and forth.

Cut long story short,  I was clicking, went to SETTINGS, then to NETWORK & INTERNET, and then I tried, and click on "internet settings", and it  downloaded the setting for internet and MMS (this is what it says there) with wifi on.

After a while, it says downloaded and (I think) installed.  I restart the phone, and magically, I can receive photos.

Hope the above helps.

Thank you for the Motorolla link, what a beautiful step by step instruction to set up MMS messaging. for MCC i put 310, and MNC 260, I don't know what they are , but now my MMS works fine. Thanks again

Couldn't send or receive MMS on a new LG Stylo 4 I set up for the wife to replace an Honor 6X which is having the delayed texts and calls sent to voicemail without ringing problems discussed in others threads.

All I did was install the same apps as on old phone, copy data off the micro SD card, and swap SIMS so she would still have the same number. Based on  the previous message, went to network settings and found 2 almost identical TMO choices for settings. Chose the other, rebooted and it started working immediately.