Solved

Apps not loading/working with data connection


I have an LG Stylo 2 Plus. I recently had to get a new SIM card because my other one was causing problems. My phone works fine now (send/receive calls & texts, connect to wifi, connect to data), but when I am out and about and have data on, I can't use any of my apps. I get a notification that data connection is allowed. The 4G LTE symbol is at the top of the phone. But if I try to open/refresh Facebook, my Yahoo Mail app, or any games on my phone, nothing loads or refreshes. I can use them all fine on wifi, but data is a no-go. Has anyone else had this problem after getting a new SIM card? Is there some way to fix this? I've reached out to T-Mobile support via Facebook and someone was trying to help me, but nothing was working. I'm at my wit's end trying to figure this all out. What can I do?

icon

Best answer by pixiestyx12 15 August 2018, 00:05

I finally, FINALLY, got my data working today. The rep from Facebook did get back to me, and he said someone decided to finally look at the actual issue and take the billion tickets that were submitted and escalated into account. Now I have data, and they credited me for the hassle of spending the last almost 2 weeks dealing with this. I'm just happy everything is working now.

View original

38 replies

@pixiestyx12

Contact T-Mobile T-Force support via Twitter DM. And request them to provision data in your new SIM card. At the backend, while they activate the new SIM card, they often make this mistake and do not provision data. Even if the data is not provisioned, you will still see 4G LTE symbol since the network is available. It's just your SIM that cannot accept LTE data due to non-provision. It should be a quick fix for T-Force. Please keep me posted.

I did contact them to ask if they can provision data to my SIM. According to T-Mobile, my account still shows pending on their end (no idea why, since I activated service 5 days ago and my account shows active on my end), so they're "working hard" to get this taken care of so I have data. Apparently I have to wait until Thursday to see if anything changes. This has been more hassle than it's worth, it seems. I've had nothing but problems since I activated service on the 1st.

Userlevel 5

I know we are just hitting Thursday, but please keep us updated! If there's anything we can follow up on, we'll be happy to.

According to the tech support person I talked to late last night, it's showing the data was provisioned on the T-Mobile end. However, I still do not have data. I can turn it on, but I can't connect to any apps or view any websites while data is on. I even factory reset my phone, but that didn't help. I have no idea why my data is not working with this new SIM card.

Have you checked the APN settings? You can find it under Settings-> Network -> Access Points

I did check the APN yesterday. I even tried adding a fake APN and then resetting default settings that way. Nothing worked.

Userlevel 4
Badge +9

Do you have data limitations enabled? Settings>Mobile Data>Limit Mobile Data Usage

I do not have data limitations enabled. I honestly have no idea why I have no data with this SIM card. The Facebook support/customer service rep I've been dealing with said data shows it was provisioned on their end, and it's active, but I still can't get apps/websites to load while data is on. Only wifi.

Userlevel 4
Badge +9

I see, thank you for checking that setting on your phone.  Did you recently make any other changes to your account? Plan changes or anything like?

I haven't made any changes. When I first activated service, I had an account that didn't work. And by that, I mean the number I was given didn't activate with my SIM card, and I couldn't log in with the number or anything else. So I had a customer service rep help me close that account (I assume they closed it on their end) and set me up with a new number and new account on a new SIM card. Everything was working fine (data, wifi, calls/texts), but the next day, the SIM card somehow reverted to the old number (the problem one that wasn't working). So I went and got this SIM card I have now, and it activated with calls/texts and wifi, but data doesn't work. I can connect to data (it shows the 4G LTE icon at the top, and it says data connection is allowed), but nothing works while it's on.

Userlevel 4
Badge +9

You said you're on a Stylo 2 Plus, right? Is it a T-Mobile branded device?

Yes, it's a T-Mobile device. It's an LG Stylo 2 Plus K550.

Userlevel 4
Badge +9

Alrighty, could you do me a favor and check your APN settings?

You can find this by going to Settings>(Networks tab)More>Mobile Networks>Access Point Names

Can you tell me how many selections you have posted there? If you can manage a screen shot, it would be great.

These are screenshots from when I click Access Point Names.

Userlevel 4
Badge +9

Awesome, thank you for doing that! Do you have the option to change your APN protocol to IPv4/IPv6?

I don't think so. If I click on APN Protocol, nothing happens. I can't edit anything within the T-Mobile APN.

In the APN screen, top right side, press the three vertical dots and then do "Reset to Default". And then go to Settings->System->Reset Options and Reset Network/Reset Wif, Mobile, and Bluetooth. Reboot your device. Please post how it goes.

I don't have that option. When I click the 3 dots, my only option is to add an APN. And I've already tried that. I created an APN with the same APN link (the fast.t-mobile.com one) and called it FakeMobile. Then I did the reset. I also tried resetting the network, but none of that worked.

Userlevel 1

Weird normally the change should not take more than a couples of minutes to do so if it's data we are talking about did you try and get to a website to see if anything loads if the problem is your account it should redirect you to a t mobile site if not then something is wrong with ethier the phone or the sim card

Userlevel 4
Badge +9

Have you performed any resets on the phone since getting the new SIM card? Either a network settings reset or factory reset?

I can't get any websites to load except the T-Mobile website, but only if I manually type in the link. It doesn't redirect me to T-Mobile. It just gives me an error when I try to access any websites.

Yes, I had another customer support person tell me to try network settings resets and even a factory reset. Neither of those worked. When I have data on and try to load websites, this is what I get:

Userlevel 4
Badge +9

Oh, I'm sorry I had you repeat information.  I just went back and reread the thread trying to think if there's anything that we missed in checking.  I'm honestly stumped.  Do you know if your phone is still under warranty?

No, that's ok. I don't think it's still under warranty, but I'm not sure. I'm actually getting ready to go to the retail location I got this SIM card from to see if they can help me figure it out.

Userlevel 4
Badge +9

It certainly won't hurt to ask about the warranty while you're there 😉. Good luck with everything

Reply