Automatic time zone setting keeps turning itself on.


I cross a time zone daily for work and don’t want the phone to change time. When I disable automatic time zone and set my desired time it works until the phone is rebooted, then switches back to auto mode. How can you permanently disable auto mode?  Samsung S9

3 replies

Having the same issue on my Note 20 Ultra 5G. I’m a truck driver and this has messed me up more than once. I have actually changed the automatic to off then restarted the phone and quickly went into the settings and watched it change from off to on. Have you been able to find a fix?


This problem has been going on for years. I live 10 miles from a time zone and cross it twice a day to and from work and can't stop my phone from changing. It's ridiculous.


If you find the answer to this, please post it here.