Solved

Cannot download or update apps after pie upgrade


I recently upgraded my Samsung Galaxy S8 to Android Pie. Since then, I am having problems downloading new apps or updating the existing ones.

The only workaround I have online in forums is to stop the Google App and restarting the phone. But that allows to download or update the apps that one time. I wish to do it again after a few days, I have to do it again. In addition, this brings the problem of not being able to use the Google Assistant, since the Google App has been forced off.

Does anyone have a better or correct solution?

Thanks

icon

Best answer by davekimo 13 May 2019, 16:31

View original

25 replies

Userlevel 6
Badge +15

Can you post any error message you're getting when you try to update/install your apps? One thing worth trying is wiping the cache then giving it another shot to see if that works.

Already tried that. Basically, I do not get an error message. It just

simply shows downloading but no progress. It stays like this for days.

I have to stop the Google app and restart the phone. But then, I can't use

the Google assistant.

B Gomez

Userlevel 4
Badge +9

Have you turned on battery power saving? It can suspend connections during sleep to save battery (WiFi) and I have found that can mess with both data & WiFi connections. Google tries to download the app updates before the phone reconnects from sleep.

Also, have you wiped the cache of the Google Play app & any other relevant Google apps?

I'm having the same issue on my Galaxy Note 9 ever since the last Security update to CSD1 with the April Security Patch. It's annoying as anything! Nothing really fixes it. I'm also 99% certain this is an issue with the security update that got pushed.

FYI, there is no error message given apps just start to download and some hang at 100%, others at 98% and it goes on like that for hours, whether on Wi-Fi or the T-Mobile network. T-Mobile needs to look into this issue.

I have not turned on power saving as I use my phone a lot for work. I have wiped the cache twice on the Google Play, Google app and the phone itself.

Userlevel 4
Badge +9

Ok...have you checked all your settings on Google Play? Credit cards are up to date, your phone is still listed, etc.? I'm just trying to think of any possible glitch that could be causing trouble...

I'm having the same issues with my Note 9 and I've tried every solution mentioned above,  this is very frustrating as I like to keep my apps up to date.

Userlevel 4
Badge +9

All I have left is to use an sd card to backup your device with Smartswitch & factory (hard) reset your device. You WILL lose EVERYTHING so ​don't forget to BACKUP!! 😮

Userlevel 4

Just checking in here to see how things are goings. Did you get a chance to backup, reset, and restore?

I haven't done a reset yet, I'm a little worried about losing all the settings I've established on my phone.

Is this a phone issue or a Google Play Store app issue?

Userlevel 4
Badge +9

Smartswitch is a Samsung app that came on your phone and is made for backup & restoration. Read up on how to backup to an sd card and just rip the band-aid off!

I backed up and did a hard reset yesterday (Wednesday) around 6pm, it is now 11:30am (Thursday) and 44 out of 75 apps have been uploaded so far from Google Play Store therefore I think I can conclude that the reset didn't help my issue. Any thoughts?

To add to my comment above, I have the Samsung Gear S3 and the reset Note 9 is trying to load the watch faces but it's just spinning. It appears I'm in worse shape now than I was before the reset. 😥

It sounds to me like you may have a bad app installed. It could be a game, photo editing software or something like that.

You can back up everything to the Samsung Cloud and put remaining files on an SD card or your computer.

You may look at your apps and remove anything that is 3rd party. Let us know if this fixes things.

If it has already 'infected' your phone, I don't think there's much you can do except back up your data, doing a full factory reset and then update.

Again, sorry, but I am pretty sure it's an app.

It could also be the phone that is defective, so if this doesn't work, you should use your warranty. Best of luck!

UPDATE: I went to the T-Mobile store and after trying several different remedies they finally reset Google Play Store back to a previous version and that seems to work for updating apps but downloading apps still gets hung-up.

Userlevel 6
Badge +15

Is the device freezing when you download new apps or are you getting an error messages? I'm also curious if you've tried downloading other apps to see if that works.

When I download new apps or update current apps the download gets to 100% and then just hangs there. If I'm updating more than one app the first app says 100% and the other apps show pending but nothing happens. This is very frustrating, I thought it was fixed after I left the T-Mobile store but it's the same as it was before.

Userlevel 4
Badge +9

Try going to settings>connections>more connections and turn on Download booster. Make sure you have a solid connection not a spotty one. And finally, if you get the opportunity to update Google Play again AND you have a fast solid connection, DO IT!

Userlevel 1
Badge +1

Don't know if this will help or not. I also have a T-Mobile S8 that's been updated to Pie. And it does have a different characteristic when downloading updates.

So, FWIW, when Pie hit my cell phone I went ahead and did the update. And, after checking it out a bit, did my usual two bits when an update of this magnitude strikes:

1. Rebooted the phone.

2. Rebooted the phone into the how-to-wipe-the-cache-partition mode, and wiped the cache partition.

3. Then, after it came up, rebooted it again.

I'm weird that way, and, yes, I do wear a tin-foil hat.

In any case, after all these follies, the usual bunch of Play Store updates came down. And they tended to show the same behavior of which you speak: The download would be complete, or nearly complete.. And then it would just hang there, sometimes for fifteen minutes, sometimes 30 seconds, sometimes a couple of hours.  Eventually it would quit stooging around and go in. I vaguely remember that in at least one case, I restarted the phone and it went in after that.

And, in general, as compared to Oreo, installation of apps appears to be more fraught. I had to install Intune (a company mandated app) a couple of times before it took, something that hadn't happened before.

My general impression is that, over time, these half-hung installs are getting fewer and fewer and take less and less time.

But, knowing nothing about Android App Development, that let's me make up weird theories to throw out there. So, here's one: With Pie, I suspect that the build process has changed somewhat, although Pie is backward compatible enough to accept apps developed for previous versions of Android. The phrase here is "compatible enough" which may (I am making this up) translate into a class of, "sometimes it works speedily, and sometimes it doesn't".

So, you're not alone, there are weird things going on with app installs. It just seems like you've got a bad case.

If you download  the newest Google play store apk it fixes  the problem

Userlevel 1
Badge +1

Yesa butta. It's still doing that, "slow to start download. Or starts download and hangs at 94/95/99%. But eventually installs it anyway" trick, and that's despite a Play Store update on the Play Store in the last week or so. I mean, it's not days; at worst, it's an hour or so. And it usually downloads, installs, and flies straight after a few minutes. So, a minor pain, but not the end of the world.

I have discovered that the issue is being caused by Lookout Mobile VPN on my S8+. In order to download updates, I have to disconnect from the VPN, download then starts and update installs. Unfortunately, I have had to perform this each time and it is quite aggravating. I hope this information is helpful in getting the issye resolved.

I too have Lookout Mobile VPN on. I have an S8 as well. Now recently I received a software update from TMobile. I installed it and the problem went away.

FINAL UPDATE: Last week I went back to the T-Mobile store and they gave me two choices, take it to Best Buy and have a Samsung rep. do a factory reset and if that doesn't work either live with it or get a refurbished Note 9. I went to Best Buy and they factory reset my phone and again I got the same results so on Thursday I went back to T-Mobile and they ordered a refurb for me. I was a little hesitant about getting a refurbished phone but I didn't have any choice either. On Friday the phone arrived, I picked it up and everything is working great, updates are fast and smooth and downloading new apps is quick.

I appreciate all the advice this forum has given me unfortunately nothing seemed to help. I do wish I could find out what exactly was the problem but I don't think I'll ever find out. Kudos also to the staff at the Apple Valley, MN T-Mobile store that worked diligently on trying to find a solution for me, this would never have happened at Verizon!

I believe I found the solution to this problem. I have the exact same issues that you described. None of the workarounds that I keep hearing over and over never worked, clearing cache, reinstalling, factor reset... Etc.

I believe the problem was created after the upgrade. To me the problem seems to be apps wanting to upgrade, but seem to either conflict with each other OR there is an app(s) that need upgraded first, don't know which apps is causing the problem. I fixed my problem by manually upgrading each app individually.

This was a real pain in the beginning because all the apps wanted to Auto upgrade while I was manually trying to do it so you have to turn off all of the auto upgrade buttons... turn off auto upgrade in settings and also for each individual app.

In the beginning you may still have to clear the cache and data for Play Store (that will allow you to get at least one app upgraded) but when you do do that, everything resets back to Auto upgrade ( this will take a lot of patience in the beginning because yes it will still hang at 99% or 100%, but eventually  the problem begins to be less of an issue) I upgraded all the Google and Samsung apps first. After you get that one app or apps upgraded that may be causing the problems it's easy sailing after that

Reply