Question

Cannot send any MMS on new S20+

  • 8 October 2020
  • 3 replies
  • 142 views

Badge

I have tried to troubleshoot everything, even reset the phone and didn’t add my back up or anything and I still cannot send any MMS. I have tried the regular message app the phone comes with, I’ve also tried downloading the Google message app. It will say sending for 15min then fail. I’m at a loss and I really don’t want to go back to my iPhone because I cannot send any picture message for work or anything in general. I have Wifi on/off, Data on/off doesn’t matter it just wont send. I’ve had this problem since day one with the phone but this is the only problem I have. 

 

Anyone have any other ideas? Or should I just return this phone and go back to my iPhone..

ALSO! I can receive MMS but I just cannot send..


3 replies

Userlevel 6
Badge +13

Have you checked the APN settings?

https://www.t-mobile.com/support/devices/not-sold-by-t-mobile/byod-t-mobile-data-and-apn-settings

Userlevel 1
Badge +1

Do what Syaoran wrote. you can also try defaulting it.

 

Install google messages. allow and accept everything, even if you did uninstall it after.

 

It will ask you or tell you about chat features, something about this step, it helps adjust the phone so it can work with data/mms etc. generally it will tell you Its ready when its done and it’s under settings in the messages app when you are going to do a new text, etc.

 

if you have issues…

 

https://support.google.com/messages/answer/9363493

 

make sure this is installed or updated.

 

https://play.google.com/store/apps/details?id=com.google.android.ims&hl=en_US

 

 

I can't do anything with my S20+....no calls, no texts, no internet. Seems to be related to Carrier Hub app which I did not download and is a Sprint thing.

Reply