Device Unlock - Server Not Responding

  • 13 October 2017
  • 15 replies

I've tried several times to permanently unlock my phone with the app. I paid for it fully before I left the store. I've tried different towers, WiFi hotspots, towns, and times. Every time I get "Server not responding." I called customer support and they said they would email an unlock code in a day or so. Then I get the email... This device can't be unlocked with a code, use the device unlock app on your phone.


Best answer by tmo_marissa 17 October 2017, 03:40

View original

This topic has been closed for comments

15 replies

Ok, I know I didn't actually ask a question. Can anyone help with this?

Userlevel 3

Hey, @iphydeauxi​! Whether or not you technically used a question mark, I still totally understand what you're asking. 😊
What kind of phone are you using, and how long ago did you purchase the device? When the device is paid in full, there are still some other requirements that need to be met to be eligible for unlock -- is it possible that there's a hang-up on the usage or refill requirements outlined here: Unlock your mobile wireless device​?

- Marissa

I am using a Galaxy S8+. I've had it since June or July. From what I'm seeing, it doesn't look like an account issue but a communication issue. I've unlocked an LG Aristo and an LG G6 with this method before without issue. I have tried different connections and times of day to no avail. I've rebooted the phone and even pulled and reinserted the SIM card.

Userlevel 3

Gotcha -- that is definitely a lot of attempts! Have you been using the device on the T-Mobile network since you got it this summer? If the answer to that question is yes, then you'd definitely have satisfied the usage requirement if you have a postpaid account and it's in good standing. If you're trying this on and off of Wi-Fi and getting the same result, then here are the basic troubleshooting steps we'd recommend before we'd encourage you to Contact Us:

  1. Turn Wi-Fi off.
  2. Verify you have at least 2 bars of 3G/4G/LTE signal.
  3. Check for app updates, and install them.
  4. Clear the app cache.

If you've confirmed your eligibility against the link above, and tried these steps without success, then we'd want you to reach out for assistance so that we can try to get to the bottom of this. The app is definitely the only way to get one of these devices unlocked, so I'm sorry to read that we previously took up your time filing a request. If it's an option for you, then I'd recommend working with our T-Force team on FB (via Message) or Twitter (via DM) -- you can link to this thread since we've already discussed so much here!

- Marissa

I had the duh/aha moment as soon as I read number 4. I was almost to the point of a factory reset. I cleared the cache and also the app data. It asked for access to my calls which I granted. It shows that it went through. I'm about to restart now. Thank you for your help. I'll report back if I have any issue.

Userlevel 3

I hope this is working out OK! Please keep us posted if there's any more trouble! 😊

- Marissa

OMG thank you! Clearing the cache fixed the issue.

I think the edge case that makes us all get the "Cannot connect to server. Please try again" error is if we try to unlock when our phone is ineligible to unlock. Then, months later when our phone is eligible for unlock, it hiccups when we press the unlock button again.

Clearing the cache resets that process though so it does the necessary checks, and all is well.

Userlevel 3

Hooray! I'm so glad to know this, and to know that it worked. 😊 Thank you and thanks again for reaching out here!

I have the same problem. But i bought the phone and came outside US, and now i try unlock my device and it says server not responding. What to do?

Userlevel 3

Hi there! Sorry to read that you're bumping into trouble unlocking your phone! What kind of phone are you using -- did it come with the app pre-installed? Have you double checked the requirements to Unlock your mobile wireless device to make sure that this isn't what's causing trouble?
As long as you're attempting a permanent unlock and you meet those eligibility requirements, you should be good to go with a solid WiFi connection, and if you're still having trouble, we'd recommend following the steps outlined in the answer marked correct on this thread. A temporary unlock can only be completed on the network, though, so it won't be an option once you're overseas. 😥

I have the same problem. Have tried multiple times to use the unlock app on my Galaxy S6. Phone is paid off, account in good standing for many years, good connection with or without wifi. No matter what, I get the “cannot connect to server” message. I have updated and cleared the app cache. Next? I M ready to take it into the store.

Go to the app's setting (the device unlock app in your Tmobile apps) you can hold it and you should then see the app's setting or app's info. Go to storage and clear the cache and make sure under permissions you have given it turned on. Try again. If that didn't work then go back to the app's storage and select clear data. This will wipe all info in the app. Open the app again, it should look like you're using it for the first time. Try to unlock again, this worked for me. Good luck.


Tengo el mismo error con un oneplus 7t imei: 990013830668922

OK, so it’s a long time since this topic was created, just providing an update.   I have a galaxy S9,, and Tmobile just sent me a text, “you’re elegible for your phone to be unlocked”

I of course had tried many many times with the stupid device-unlock app that kep failing.   Decided to try again.

Same error as before, “cannot connect to server”.

But after reading this, I tried clearing the app’s cache:   same error
Then tried clearing the appp’s cache AND DATA:    Yes, that worked.

So, to summarize:  clear the app’s cache AND DATA and try again.