Fixed Galaxy S7 APN issue

I bought a Samsung Galaxy S7 Active through AT&T and switched over to T-mobile. I unlocked my phone and everything worked for about a month. All of a sudden my phone stopped connecting to internet off Wi-Fi. My phone still made calls and sent and received texts, but the data wouldn't work. I made sure my data was turned on and tried restarting my phone, and even did a factory reset. Still didn't fix the issue. I called T-Mobile for help and they reset my APN info back to their default, but it still didn't work. They ended the call by basically sorry we can't help, sometimes phones from other carriers default back to the original carrier and there's nothing we can do to fix it. THIS IS COMPLETELY WRONG. Here is the solution.

1. Go to Settings>Connections>Mobile Networks>Access Point Names

2. Click on each name and in the top right corn click the 3 dot menu icon and click Delete APN. Delete ALL of them.

3. Restart your phone.

4. Repeat step 1 and go back to Access Point Names.

5. Click ADD on the top right and fill in the APN information exactly like this: Network, APN, and VoLTE: Samsung Galaxy S7

6. Click the 3 dot menu icon in the top right corner and hit SAVE.

7. Go back to Access Point Names and make sure your new APN is selected.

8. Restart phone and Voila! Your data connection should work again!

You're Welcome.

42 replies

Does yours work in areas with only Band 12?

I can verify this fix works!

I had a Samsung S7 Active unlocked from AT&T with this same exact issue. I called T-Mobile support and they had me go through all the debug steps - New APN entry, clearing cache on my browser, clearing storage on multiple apps on the phone. None of it worked. I stumbled across a work around on my own - turn airplane mode on, wait a few seconds, and then turn it off. Data would come back every time. But only until the next reboot when I would lose it again. These steps provided here in the OP work as a permanent fix. Data is on every time after a reboot. Thanks for posting the fix! I only wish that the T-Mobile tech had thought of this.

Before I deleted all the existing APNs, I noted that there were about a dozen of them on my phone. My theory is that the S7 is not defaulting to the correct APN for the T-Mobile network - even after we add a new one and select it as the new default. So on reboot, another one of the APN configs is probably being used from cache, and that's why we are seeing this issue. The new default config created by following the T-Mobile knowledge base article in the last comment is loaded when turning data off and back on again with airplane mode but for some reason is not loaded with a reboot.

When we delete ALL the APN configs save the one, correct config for t-Mobile, then the phone has no option but to load that config at reboot.

That's my two cent theory and I'm sticking to it!

On the APN Type make sure is not set

like this:

APN type: not set

I had put in Internet+MMS and my data was still not working, I delete it and now its set on to not set. This work for me, also following what galaxyowner7 said.

Hope this helped as well! 😊

Wow, this worked! I've been having this problem for months! The settings you linked did not work for me, however. The following settings, however, worked like a charm:

Name: T-Mobile


Proxy: Not set

Port: Not set

Username: Not set

Password: Not set

Server: Not set


Multimedia message proxy: Not set

Multimedia message port: Not set

MCC: 310

MNC: 260

Authentication type: Not set

APN type: default,supl,mms

APN protocol: IPv6

APN roaming protocol: IPv4

Turn APN on/off: APN turned on (this is grayed out)

Bearer: Unspecified

Mobile virtual network operator type: None

Mobile virtual network operator value: Not set (this is grayed out)

The key, as you say, is to delete the other APN settings completely.

Ive been having the same issue as well, this is the only solution that worked for me except the part that says APN type:

I typed Internet+MMS and it wasn’t workin. When I delete it, it worked like a charm!! Thanks alot for this solution

So I had this same issue, deleting all the access points and then deleting APN type really worked!

Here is the link to my screenshots so you can see exactly what I did. (Its Google Drive so no viruses I promise )

T-Mobile S7 Edge - Google Drive

WORKS.  But add a name above the apn.

5. Click ADD on the top right and fill in the:

    name (i just used two letters, it would not let me save the apn info without it)

    APN information exactly like this: Network, APN, and VoLTE: Samsung Galaxy S7

6. Click the 3 dot menu icon in the top right corner and hit SAVE.

Thank you so much, I was getting very flustered after hours of searching for fix.

This actually worked perfectly after a very frustrating call and a possible trip to a store.  Thank you SO much.  I had the exact same issue and this solved it.

No problem guys I'm glad I could help!

Again, the above solution is great, except for one problem that I cant seem to fix.  I can not send nor receive pics on text messages.

I did try adding MMSC:  

It cuts out the LTE connention and I have to remove  it.

Any ideas and help would be appreciated!

Thanks in advance....

My hero!  Didn't even have to restart after I added the T-Mobile APN back and this solution worked flawlessly!

hi, does this confirm volte works on s7 active?

also, will i be able to be on a call and use data at same time? my s6 active always kicks me off data when a call comes through.  network switches to E

Thank you so much, this worked like a charm. 😊

Thank you!  This has worked for me perfectly. 

The APN type "default,supl,mms" worked!  All other APN types did not work.

Thanks everyone!

I'm having the same issue. However I have a sprint phone. Not sure if that makes any difference. But I was told that the internet won't work. I'm at a loss with.

Hi, I just switched to t-mobile yesterday and have spent more than my fair share of time trying to figure out why I have no data. I was with customer service for way too long and they pretty much told me after two hours to go to the store to see if the problem was the sim card or my phone.

I had a perfectly working phone yesterday, so I'm struggling to believe it's  my phone.

Anyway- I have played with the Access Point Names for about 3 hours now and I FINALLY think I'm set. I have data!

So do not give up- because no internet is sheer BS.

I'm so thankful for this thread.

They key for me was: DELETE ALL ACCESS POINTS. Edit or Add ONE of THEM to the LINK Provided above in the forum. Play with everyone's suggestions as to the APN type. The one that worked for me was "Not set"

So this is what I have


T-Mobile US LTE








APN Type

Not set

APN Protocol


APN Roaming Protocol


Then Turn your data off and on again.


You should be set. If you're not- change the APN Type  to everything possible

That worked perfect!

Just pulled the switch from AT&T , our Iphones worked immediately, however the Galaxy 7 EDGE phones could not connect to the internet on the network.

performed your fix , and all works well .

Thank you.

Hi Did you switch from Sprint? I switched from sprint and data dont work!! Tried all the fix'es mentioned in this thread

No I was not able to. When I was making the switch the rep on the phone said I was able to use the phone. I would never had switch if I knew I couldn't use the phone. Waste of money

Sent from Yahoo Mail on Android

On Fri, Mar 9, 2018 at 1:28 PM, annikottpraveen<> wrote:

#yiv0740755646 * #yiv0740755646 a #yiv0740755646 body {font-family:Helvetica, Arial, sans-serif;}#yiv0740755646 #yiv0740755646 h1, #yiv0740755646 h2, #yiv0740755646 h3, #yiv0740755646 h4, #yiv0740755646 h5, #yiv0740755646 h6, #yiv0740755646 p, #yiv0740755646 hr {}#yiv0740755646 .yiv0740755646button td {}


T-Mobile Support



Fixed Galaxy S7 APN issue

reply from annikottpraveen in Android products - View the full discussion

Hi Did you switch from Sprint? I switched from sprint and data dont work!! Tried all the fix'es mentioned in this thread

Reply to this message by replying to this email, or go to the message on T-Mobile Support

Start a new discussion in Android products by email or at T-Mobile Support

Following Fixed Galaxy S7 APN issue in these streams: Inbox

This email was sent by T-Mobile Support because you are a registered user.

You may unsubscribe instantly from T-Mobile Support, or adjust email frequency in your email preferences


Thank you so much! I just recently talked my mom into switching over to T-Mobile and she decided to keep her old AT&T phone. She was ready to bite my head off because she was having the same problem and THIS saved my life! Lol truly 100% thankful for this!

I tried the fix a few minutes ago and I can say it definitely works! Thanks so much! I wish the T-Mobile reps would read this message board. I spent over an hour talking to him with no fix.

I've tried a number of these and most work for data, but nothing has worked for MMS.

Anything else I can do to sort that out?

Hi all,

I had high hopes for this fix, but found that I didn't even have the option of deleting the APN when I went through the settings.

I have a Verizon S7 that I switched over to T-Mobile, and after hours of effort I simply cannot find any way of deleting the Verizon APN, which I believe is interfering with my new service. I've set up the T-Mobile APN but I hardly ever have any call service anywhere (and I live in a major city). Data works fine, but phone calls constantly fail to even dial.

I wanted to try removing the previous APN as instructed in this post, but apparently it's not possible with Android 4.0 on Verizon devices. Does anyone have a clue how I can delete the Verizon APN, short of rooting the phone?

worked on my s6 that had same problem THANK YOU!