Fixed Galaxy S7 APN issue

I bought a Samsung Galaxy S7 Active through AT&T and switched over to T-mobile. I unlocked my phone and everything worked for about a month. All of a sudden my phone stopped connecting to internet off Wi-Fi. My phone still made calls and sent and received texts, but the data wouldn't work. I made sure my data was turned on and tried restarting my phone, and even did a factory reset. Still didn't fix the issue. I called T-Mobile for help and they reset my APN info back to their default, but it still didn't work. They ended the call by basically sorry we can't help, sometimes phones from other carriers default back to the original carrier and there's nothing we can do to fix it. THIS IS COMPLETELY WRONG. Here is the solution.

1. Go to Settings>Connections>Mobile Networks>Access Point Names

2. Click on each name and in the top right corn click the 3 dot menu icon and click Delete APN. Delete ALL of them.

3. Restart your phone.

4. Repeat step 1 and go back to Access Point Names.

5. Click ADD on the top right and fill in the APN information exactly like this: Network, APN, and VoLTE: Samsung Galaxy S7

6. Click the 3 dot menu icon in the top right corner and hit SAVE.

7. Go back to Access Point Names and make sure your new APN is selected.

8. Restart phone and Voila! Your data connection should work again!

You're Welcome.

42 replies

can you be a little more clear on these settings thank you

If you need flash file to flash your g891a to t-mobile i have it 

Doing this did NOT work for me and I was experiencing the same problems as OP. But what I did do instead was I turned "International Data Roaming" on and that allowed me to get data. Now I have a feeling on my next billing cycle I will be given a huge bill, but whatever - I am inside US using data I'm supposed to be paying for anyways. So because of this I wonder if the geolocation of the Samsung Galaxy S7 Edge is throwing it off - or something. I don't know.

If you have ever or know someone who has flashed a phone it can be flashed with T-Mobile software very easily being that T-Mobile did sell the s7 edge if something you would want to do you can go to XDA developers website and find all that is needed to do this just make sure you get the correct version of Odin and the flash file to match your model of phone for example (SM-G930) this will work on both the s7 and s7 edge and can be done with the U or T firmware file and for all who may read this I am working on a file to do the s7 active aa I need it myself and as soon as i can find the right modem file I will post it here all the newer phones like the s8 and s9 they made it easier to debrand or uncarrier your phone

SOOO THANKFUL FOR YOU!!! I had to use this LAST YEAR and then when wanted "group chat" (which hadn't been working) T-Mobile phone people "fixed" that. ALSO FIXED phone back to NO INTERNET!  OH...BTW...after I entered your GLORIOUS INFO phone asked me for a Name - I just put what someone under this box put "T-Mobile" - IT WORKED - I'VE GOT INTERNET AGAIN!!!!!!  p.s. now to see if have group chat (not as important 😊 ) THANKS SO MUCH!

Could you let me know if there is a firmware file for an AT&T S7 Active moved to t-mobile.  I'd like to get an active for my wife because of it's longer battery life, but worry about the phone not working with T-mobile network.

I read this post plus the second one below.  For my case, with my Samsun S7 active by ATT, I simply deleted all APNs except for T mobile APNs with connections.  I then simply turned on and off the airplane mode and internet connection immediately came back for me.  Good luck to everyone in getting your ATT Samsung S7 actives up and running again. 

This is the only solution that worked for me. Thank you so much for posting!

I ported an unlocked S7 Active from AT&T. I had none of the problems described here until I traveled to Canada. T-Mobile claims to provide 4G LTE roaming in Canada. My phone does voice and text fine, but no data whatsoever. I followed the advice above, including deleting all the other APNs. I also spent nearly two hours on two separate calls with T-Mobile tech support. But I still can't get any data in Canada. International roaming was the main reason I switched to T-Mobile. Having to buy a new $800 phone kinda defeats the purpose. Have you had similar problems when roaming? Any suggestions?

Userlevel 7
Badge +15

Have you tried manually selecting the roaming network?  Do you have Data Roaming enabled in the Settings, Connections, Mobile Networks? 

Bell or Telus (same network) are T-Mobile's roaming partner for Canada.  AT&T was Rogers and Fido/Chatr (same network).  Make sure the device is not trying to roam on to any of the Rogers networks.  If that doesn't work, try adding the APN's for Bell and Telus but do not set them to the default.  Power off the device for a few minutes, then power it up and see if your data works. 

Bell Canada APN settings:


Proxy address:

Proxy port: 80


MMS proxy address:

MMS proxy port: 80

MMS protocol: WAP 2.0

MCC : 302

MNC : 610

Telus Canada APN settings:



MMS Proxy:

MMS Port: 80

MMS Protocol: WAP 2.0

MCC: 302

MNC: 220

Thanks for that. It makes sense, but unfortunately it didn't work. The S7

Active won't save an APN with an MCC other than 310. Weird and

disappointing. Much as it pains me, I may need to change back to AT&T.

This also happened to me.  Went back to the field below nad made sure to delete "Internet+MMS" and just rvert it back to blank.  Boom.  Worked.

  • APN type: <Not set> OR Internet+MMS

Thank you all for your help!

Userlevel 7
Badge +15

AT&T is well known for preventing changes to their device configured settings on devices sold by AT&T.  They don't want you taking your device and using it on another carrier. 

I am having the same issue.  Did you ever find a solution?

Did you ever find a solution to this?  My wife and I just switched to T-mibile and her S7 wont send or receive MMS.

I have the same problem. I got the internet and the pictures now by doing the following.

  1. Select the default APN T-Mobile GRPS
  2. Delete the rest of the APN.

If you look into the T-Mobile GRPS APN, the MMSC: not set.

I hope this will work for you.

It worked.