Question

Galaxy Note 10 Wi-Fi Calling Preferences Updated Automatically

  • 16 September 2020
  • 50 replies
  • 7117 views


Show first post

50 replies

I'm having this same issue on my galaxy s20 fe. Wi-Fi calling works much better in my house but it's constantly switching back to cellular preferred. It did it in the middle of a call which dropped the call. It's definitely not optimization. I silenced the constant notifications but that doesn't fix the actual issue. Hope there's a fix soon. 

I have a Samsung Galaxy S9+ and the exact same issue is happening 100+ times  a day, it is so annoying as it sounds like I am getting a message all the time I am at home within range of my WiFi signal. I think it pops up when it detects a stronger cellular signal and then reverts back to WiFi when the signal dips again as I live in a rural area with not great coverage indoors, not bad outside but poor signal inside. It never used to do this until the last security patch update.

Use tidypanel from play store to hide the notification. Tidypanel doesn't use any battery and works well in free version.

This worked great! Until a real fix is released this will do nicely...no more annoying notification sounds for no reason...thank you!

Badge

Does not stop switching from wifi to cell, that is the root problem. The notifications will go away when its solved.   

Does not stop switching from wifi to cell, that is the root problem. The notifications will go away when its solved.   

I’ve not experienced it turning wifi calling off without permission, only being inundated with notifications that have no purpose (or way of silencing). But yes, I’m certain they will go away once this is fixed. I’m very much looking forward to not having to have a crappy bandaid work-around.

Same Same Same! I have lost calls, and am sick of the constant notification! I called support and they had me reset my network settings. I did that and am still getting it. They said if it happens again to call them back from a different phone. Really? I am working from home and have one cell phone, and no landline (who does anymore?) so...not sure how I’m supposed to do that. Maybe they want me to facetime them?  Another issue is my Galaxy S3 watch is giving me a roaming notification now too. As I was typing this, I got 3 notifications that it switched. Please T-Mobile - GET THIS FIXED!

Same issue on my Note 9, for about the last month. I work from home and moving slighltly will drop me from 2-0 bars. Because of this I have had lots of dropped and missed calls. Very un-happy and this acoount has 10+ lines.

This happened just a few days ago and will not stop. Coverage is awful AND I NEED WIFI CONNECTIVITY  !!!!! Get that T-Mobile???

 

This has been going on since last update on my S8 on Oct 3. Like Magenta396 above, was told by Tech Support to reset network settings and restart, but that only worked for an hour or two. Perhaps like numerous others, thinking very, very seriously of switching service to another carrier, and very soon!

Same issue here...incredibly annoying. Please T-Mobile...fix it!

 

How about letting us know what rogue program is changing the settings without permission so we can KILL it?

There needs to be a fix for this as it would cause me to switch service that I’ve had for almost 20 years.  The phone updated and I can’t even turn of the wifi to cellular optimization notifications.

Userlevel 2
Badge

go to settings > notifications > recently sent > see all > vertical more menu (3 dots) > show system apps > wi-fi calling > categories > wi-fi calling > notification style > silent and minimized

hope this helps

credit to reddit user banterjsmoke for posting the fix

this is not a fix, this is just silencing the alert. 

This doesn't work on my Note 10+. It's a system app and you are unable to turn it off. This has got to be fixed as it's driving me off my rocker. I get notifications every 5 mins! I stopped looking at my phone so I'm missing work. Why does T-Mobile not answer us?! 

Badge

Moved from my Note10+ to a new OnePlus 8T+5G and guess what? I am still seeing the same problem and I have lost calls.

Seems to happen when it switches from Wi-Fi to Cell and vice versa. Tired of these messages. Had to reboot the 8T+5G twice in the past few days to get cell service back. Seems to me like this is NOT a phone specific issue but a “T-Mobile” mess-up.

It would be “nice” if someone from T-Mo came on and told us what was happening? Just acknowledging that something is wrong and that they are working on it will be very helpful.

Same issue on a Note 10+ . I was able to silence the notifications based on the suggestions here,  but that's not the main problem. The phone is deciding incorrect preferences and causing missed or dropped calls. If I decide wifi is preferred,  it needs to stay that way until I decide otherwise. 

I may have found a fix to this. I did this about an hour ago on my Note 9 and have not had the notification pop up since. You need to use nova launcher to access a mobile network settings screen that I can't seem to find in the regular settings menu (if anyone knows how to get there without it, please let us know). The easiest way is to assign access to an unused gesture input. Once you get to the menu, you will see an option for wifi calling, which may be under an "advanced" sub menu. Then select "wifi only" and you should be good to go. Here's a link to screenshots of the process:

 

http://imgur.com/gallery/shOl17K

 

YMMV, as I have not fully tested this for a long period of time so I don't know if it provides full functionality. But for me, so far so good with receiving and making calls and texts. 

Userlevel 1
Badge +1

Having this issue on a Galaxy S10.  Hiding the notification isn’t a work around.  I need it to stay on WiFi Preferred.

Userlevel 2
Badge

Having this issue on a Galaxy S10.  Hiding the notification isn’t a work around.  I need it to stay on WiFi Preferred.

Why does NO ONE from T-Mobile ever answer us?

Appreciate the attempt, Aolson22, but that doesn’t work…  There is no option under categories in the menus for “notification style.”  The “show notifications” option is grayed out and there is no way to turn it off!  Very, very annoying.  I hope they patch this really soon.

Tap the Wifi-Calling and it will expand into further options

Userlevel 2
Badge

Appreciate the attempt, Aolson22, but that doesn’t work…  There is no option under categories in the menus for “notification style.”  The “show notifications” option is grayed out and there is no way to turn it off!  Very, very annoying.  I hope they patch this really soon.

Tap the Wifi-Calling and it will expand into further options

This worked for me, for the most part. I still get the message but not as often. The biggest issue is that the phone automatically goes from WiFi preferred to cellular preferred on it's own. This causes me to lose calls. Everyone need to dial 611 and report this to T-Mobile as they told me they don't monitor the forums and only open tickets get stuff resolved. 

Just happened to me this morning. Was getting a notification like every 10 seconds...super annoying! Setting Network Preference to WiFi preferred works for a bit but it randomly switches back to Cellular preferred and the cycle starts all over again.

As of November 23, 2020, this is still happening. My S20+ started doing it about a week or so ago and I have had a terrible time with calls and text messages not going out or coming in. I restart my phone several times a day just to reset this annoyance so I can make or receive a call. I live in an area with lousy signal, plus my phone still won't work when I am in town and on Cellular and have 5G and full bars.

This problem is two months old on this post. You'd think by now they would have a fix.

  

As of November 23, 2020, this is still happening. My S20+ started doing it about a week or so ago and I have had a terrible time with calls and text messages not going out or coming in. I restart my phone several times a day just to reset this annoyance so I can make or receive a call. I live in an area with lousy signal, plus my phone still won't work when I am in town and on Cellular and have 5G and full bars.

This problem is two months old on this post. You'd think by now they would have a fix.

 

I have tried a lot of settings and so far this has worked for me. I am using a Tmo Galaxy S10e and this started happening with the latest update. Here’s the link to try to see if it works.

https://us.community.samsung.com/t5/Galaxy-S9/Wifi-Calling-Preferences-Notification-wont-stop/td-p/1425562/page/5

“It started on my note 10+ after the-mobile security update over the weekend. It does look like they made some Wifi changes. 

 

Edit: I turned off "Show Network Quality Info" under Settings>Connections>Wifi>Advanced and the notification stopped. “

 

  

As of November 23, 2020, this is still happening. My S20+ started doing it about a week or so ago and I have had a terrible time with calls and text messages not going out or coming in. I restart my phone several times a day just to reset this annoyance so I can make or receive a call. I live in an area with lousy signal, plus my phone still won't work when I am in town and on Cellular and have 5G and full bars.

This problem is two months old on this post. You'd think by now they would have a fix.

 

I have tried a lot of settings and so far this has worked for me. I am using a Tmo Galaxy S10e and this started happening with the latest update. Here’s the link to try to see if it works.

https://us.community.samsung.com/t5/Galaxy-S9/Wifi-Calling-Preferences-Notification-wont-stop/td-p/1425562/page/5

“It started on my note 10+ after the-mobile security update over the weekend. It does look like they made some Wifi changes. 

 

Edit: I turned off "Show Network Quality Info" under Settings>Connections>Wifi>Advanced and the notification stopped. “

 

 

Ok after a bit, the wi-fi notifications came back. I looked into it further and went to the wi-fi app settings, cleared the Cache and Data, then rebooted the phone. So far nothing for at least an hour. I will report back if this doesn’t work as well. 

Same here, been happening for the last month or so.  All of a sudden my phone will go crazy switching between Cell Preferred and WifI Preferred.  This will happen for at least a 100 times.  During this time my phone displays “Emergency Calling Only”.  The only way to stop it is to turn off Wifi-Calling.  Which, I can’t do because I have not service in my home.

I have turned off “Switch to mobile data”, cleared cache, restarted my phone.  Nothing helps.

T-Mobile tried to tell me they have never heard of this issue and that this issue is probably coming from Samsung.

Ugh, T-Mobile

 

We see this in the computer field all the time.  The software companies blame the hardware companies and the hardware companies blame the software companies.  A vicious circle.  No one wants to take responsibility for their stuff.

Reply