Question

Galaxy Note 10 Wi-Fi Calling Preferences Updated Automatically

  • 16 September 2020
  • 35 replies
  • 4253 views

Userlevel 2
Badge

I received the September security patch last night (N970U1UES4CTH1). When I’m at work, I have to use Wi-Fi calling to get texts or calls since I am on the ground floor where there’s no signal. I’ve never experienced any issues with this, however since this morning, I’ll randomly get a notification stating “Wi-Fi calling preferences updated to optimize network experience”, and suddenly I can’t call or text anymore. I go into the settings and it’s switched it to “Cellular preferred”. If I change it back to Wi-Fi preferred, it’ll continue to work for an hour or so then it switches it back again following the notification.

 

Any way I can stop it from making changes? This is really frustrating, I feel that I should have control over my Wi-Fi calling preferences.


35 replies

Userlevel 1

S20, brand new, low price of $1400… No 5G - if 5G network is enabled, it randomly disconnects from data and phone towers. Now WiFi calling is not working anymore due to T-Mobile’s utterly incompetence.

Time to return this POS phone and switch to a different provider.

Userlevel 2
Badge

I just moved to a new location and in my new house the signal sucks and I HAVE to use Wifi for everything! Now I get this incessant message sometimes 2 times a minute if I clear it. I get it at least 50 times a day and it's driving me nuts. There is no way to disable this notification. It only started recently and even if I set wifi calling to cellular preferred it still notifies me anyway. And when I set it to wifi preferred (which is what I need) it changes it back to cellular preferred and I'm missing calls. What is TMobile doing and why have they not answered us?! 

 

Edit: I forgot to mention my wife has the same phone and this isn't happening to her!? 

Userlevel 1

So what's the point of this "T-MOBILE" community if no one from T-MOBILE comes in to address the issues plaguing it's customers? This notification is so incredibly annoying and absolutely useless to the user. I  can't imagine why there's no easy solution. I hate T-MOBILE for so many reasons including this one. 

This is the most annoying thing - this stupid notification will NOT go away and if you do a long press on the notification, it returns a message saying this notification CANNOT be disabled. ARE YOU KIDDING ME T-mobile? It keeps popping up CONSTANTLY and interfering with what I’m doing - galaxy note 20.  You need to fix this, dumbest update EVER!!!!!!  To think I just switched from Verizon, might be going back over this. 

go to settings > notifications > recently sent > see all > vertical more menu (3 dots) > show system apps > wi-fi calling > categories > wi-fi calling > notification style > silent and minimized

hope this helps

credit to reddit user banterjsmoke for posting the fix

The same problem on my Note 10+, it is really very annoying, I check on the Web and everyone reports it, but the proposed solutions do not solve this issue.

Badge

TMobile - this is beyond a little bug… it’s killing productivity for some of us who have poor coverage;  we need wifi. 

Userlevel 1
Badge +1

one way I deal with it, if you are only going to use wifi for a while is to turn airplane mode on, then toggle wifi back on. This turns off the cell radios, forces the phone to use wifi preferred mode.

 

if I can find anything else, I’ll share it.

 

 

I contacted support this morning when mine stated doing this again... the last time it took days for it to stop. I'm hoping it won't take that long this time. They said engineering is working on the issue. 

I'm having athe same issue with my note 9 and so is my wife with her note 9. Has anyone gotten an answer on this yet?

Having the same issue. It just started today after an update. I had this happen on my s9 last year and it magically disappeared after a few months worth of updates. My s20 is not even a month old and I have to deal with this again. I do not have a signal in my home, so this is needed. I’ve used the airplane mode trick on my old phone, but seriously shouldn’t have to go this route.

go to settings > notifications > recently sent > see all > vertical more menu (3 dots) > show system apps > wi-fi calling > categories > wi-fi calling > notification style > silent and minimized

hope this helps

credit to reddit user banterjsmoke for posting the fix

this is not a fix, this is just silencing the alert. 

Appreciate the attempt, Aolson22, but that doesn’t work…  There is no option under categories in the menus for “notification style.”  The “show notifications” option is grayed out and there is no way to turn it off!  Very, very annoying.  I hope they patch this really soon.

I’ve had the same issue in the last few days. Call T-Mobile Tech. Service and was suggested to have either the Mobile data ON or the WIFI Service ON. Do not have both turned on at the same time.

It’s strange because I always have both turned ON in the last 2 years, no problem.

Now I have to remember to switch the mobile data when I am on the road and turn it off when I am at home. 

UPDATE: Follow T-Mobile Tech.’s suggestion, but the problem is not fixed.

Same issues on 2 of our Samsung phones (not same models).  Has been happening for several days, assuming from the update mentioned in other posts.  Has this been reported to Tmobile or has anyone seen any response from them?

Been having the same issue for a couple of weeks now on my note 10+ and a note 8. It’s been getting really annoying 

I am having the same issue with my S20, I have not found a solution either. 

Agree this is a pest. Even using Settings, Apps, three dots at top right, system apps, Scroll to Wi-Fi Calling, Force Stop is only a temporary reprieve. it auto restarts.

Does not stop switching from wifi to cell, that is the root problem. The notifications will go away when its solved.   

I’ve not experienced it turning wifi calling off without permission, only being inundated with notifications that have no purpose (or way of silencing). But yes, I’m certain they will go away once this is fixed. I’m very much looking forward to not having to have a crappy bandaid work-around.

I am facing the same issue on S10+.. it is extremely annoying and doesn't go even after choosing either 1 of the two options. Tmobile please fix this bug.

Same Same Same! I have lost calls, and am sick of the constant notification! I called support and they had me reset my network settings. I did that and am still getting it. They said if it happens again to call them back from a different phone. Really? I am working from home and have one cell phone, and no landline (who does anymore?) so...not sure how I’m supposed to do that. Maybe they want me to facetime them?  Another issue is my Galaxy S3 watch is giving me a roaming notification now too. As I was typing this, I got 3 notifications that it switched. Please T-Mobile - GET THIS FIXED!

I have the same issue on the Note 20 Ultra. What is happening?

Use tidypanel from play store to hide the notification. Tidypanel doesn't use any battery and works well in free version.

go to settings > notifications > recently sent > see all > vertical more menu (3 dots) > show system apps > wi-fi calling > categories > wi-fi calling > notification style > silent and minimized

hope this helps

credit to reddit user banterjsmoke for posting the fix

That works to turn off the notification, thanks. It does NOT stop the phone frome  unilaterally switching from Wifi to cellular perfered. Thats a big problem for a lot of us. 

Badge

Been seeing the same on my Note 10+ and my wife’s S9. We wound-up with dropped calls as we moved in the house. We have solid Wi-Fi calling but this “new feature” is now creating problems that didn’t exist before.

Why have Wi-Fi calling if the system switches and drops you???  

Any T-Mobile person willing to explain what is the “advantage” of this new “feature”? 

Reply