Solved

Galaxy S6 won't update to 5.1.1

  • 17 July 2015
  • 8 replies
  • 57 views

I just received the Galaxy S6. It has Android 5.0.2 installed. I tried updating it but it says the software is up to date.

icon

Best answer by asdalton 28 July 2015, 02:58

I was able to receive the OTA update (630 MB) today. I now have Android 5.1.1.

View original

8 replies

What's the baseband version of your phone? Page Software versions & updates: Samsung Galaxy S 6 (G920T) might be of help.

Hi, thanks for the reply. The baseband is G920TUVU1AOCG. I looked at that page before. I just got the phone yesterday, overnighted from Tmobile. I also tried updating from the computer, but no update shows up. Thanks again for the help.

I just got my s6 yesterday and I'm having the same issue..running 5.0 but phone says up to date and no update through the Samsung switch program..any progress?

I have the same issue as you jadams7. Bought the phone 2 days ago and cannot get it to update to the newest software, says already up to date even using Smart Switch or Kies. I have same baseband as you mention also.

Won't someone from T-Mobile respond to this?!

I have this problem, too. It's for a replacement phone that I received on July 17.

I see that I'm not the only one. I searched around and found this. http://forums.androidcentral.com/samsung-galaxy-s6/556497-my-t-mobile-galaxy-s6-not-prompt-get-5-1-1-update.html

Hopefully it comes by the end of the month.

I was able to receive the OTA update (630 MB) today. I now have Android 5.1.1.

Yay! After reading your reply about the update I checked my S6 again and it sent the 5.1.1 update OTA too!

Reply