Solved

Galaxy S8 can't send MMS with LTE and wifi calling on


I've had the Galaxy S8(for T-Mobile) for about 3 days now. Last night I tried sending a picture message to a friend and noticed it wasn't sending. I tried texting pictures to myself and it kept saying "failed". I looked on the web for many different solutions such as creating a new APN profile and nothing worked. The only thing I didn't try was factory resetting the phone because I didn't want to go through that whole thing and it still not work.

 

The only solution I found is if you turn wifi calling off and switch from LTE, 4G, 3G, 2G to 4G, 3G, 2G.

 

Is this happening to anyone else? Is there a fix? Or should I return my phone for a new one?

 

I do not accept not having wifi calling and LTE or going back and forth to switch it out. Or having to download a 3rd party messaging app. If I'm going to be charged x amount of money for a flagship phone then I want all my options available. I refuse to pay for something that doesn't work properly.

 

I'm a little upset, because I need a new phone, and this is the only flagship phone I like that is currently available.

icon

Best answer by tmo_marissa 24 May 2017, 23:40

Hey, @gkrc717​! I haven't heard of anything like this before -- and I definitely agree, a fantastic device like this should work on LTE. Are you still having trouble with this? I know it's been a few days since your post, did you wind up moving forward with a Master Reset? I understand saving that as a last resort -- what troubleshooting did you try already? APNs typically aren't an issue with a T-Mobile branded device, but resetting them can't hurt! Did you do a cache wipe as well? What about testing in Safe Mode? Please let us know if you're still having trouble!

- Marissa

View original

3 replies

Userlevel 6

Hey, @gkrc717​! I haven't heard of anything like this before -- and I definitely agree, a fantastic device like this should work on LTE. Are you still having trouble with this? I know it's been a few days since your post, did you wind up moving forward with a Master Reset? I understand saving that as a last resort -- what troubleshooting did you try already? APNs typically aren't an issue with a T-Mobile branded device, but resetting them can't hurt! Did you do a cache wipe as well? What about testing in Safe Mode? Please let us know if you're still having trouble!

- Marissa

Userlevel 6

Howdy, @gkrc717​! Just wanted to check in with you and see how everything's going!

- Marissa

Userlevel 6
Badge +13

Hey @gkrc717!

I just wanted to swing by one last time to see if this is resolved. If you're still experiencing the issues with your S8 and MMS, please take a look at the questions Marissa posted above and get back to us. Thanks!

Reply