Solved

Galaxy Watch LTE duplicate messages


As the title says I am getting duplicate messages to my galaxy watch. When im connected to bluetooth everything works fine, texts sync properly when read on one device. However whenever i disconnect from my phone and switch to LTE i get every text ever all pver again. Literally 1000's. You would think the solution would be to leave lte on all the time? Wrong. When i leave lte on all the time then my watch and phone dont sync! If i read the text on my watch it wont update ththe phone anand vice versa. The point of the watch is to be able for the phone and watch to sync AND to leave your phone behind. Ive read dozens of users experienceing the same problem whats the fix tmoble? Ps this isnt an issue with the apple watch lte

icon

Best answer by tmo_amanda 4 December 2018, 23:58

@dupsla and @magenta6238774 , thank you both! I sent a PM your way which should be in your inbox. I also agree about the latest update which is something I'll include in feedback because I do think @magenta6898941 has a great point.

View original

153 replies

Hi, im having the exact same problem with my Samsung Galaxy Watch.... once i disconnect my watch from bluetooth, a bunch of my old messages begin to come in and my watch keeps buzzin and buzzin. Any help with this issue? Thank you

Hey guys dont waste your time with this

Spoke with tmoble and unfortunately this is how the samsung galaxy watch was "designed" for the lte model. I put it in quotes because it wasnt designed that way, they rigged it to work lol. This issue doesnt exist with the apple watch. The apple watch works and synce correctly on lte and its because of imessage. So the issue isnt 100% tmobles fault but come on tmoble your killing it right now, dont sell subpar equipment just to get it to consumers. Im reading literally 100's of people all across the internet (reddit, here, other forums, etc) return this device. Ive made more peofiles across more websites over the last 24 hours to discuss this issue then i have all year. To summerize the watch is broken on lte. Great watch, get the bluetooth model. Or switch to apple unfortunately if you want a working lte watch. Please do not mark this as "solved" you saying the watch is working as intended doesnt mean that it is.

Thanks for the information, this is bull*$*$. I also was on the phone with Tmobile and supposedly they have no reported issues and will be creating a "Ticket." Whatever the sht that means.  unforuntely i will have  i i will be returning the watch as well, makes no sense to pay all this money plus the service for something that does not work properly and thats how its "designed " good job tmobile and samsung  

Userlevel 5

Hey, @magenta6231016 and @floresr639​!

This would drive me up the wall and thankfully my watch doesn't do this. I'm going to check with my Samsung guru to see if I can get a solid answer on this. I'll make sure to hop back on this thread once I have an answer which is hopefully different from the ones you both have been given. *fingers crossed*

Thank you that would be great!

I am having this problem as well. It's so frustrating!

Hello, i was wondering if perhaps you had any update on the duplicate text messages issue. Thanks

Still happening. Add to that the fact that LTE uses 20% of the battery per hour without even using the watch and this thing is going back to T-Mobile 

Yea im sending mine back as well,  screw this nonsense!

Userlevel 5

Hey everyone,

I just received an update that the person that our Samsung guru will be out of the office until the end of next week so I will likely not have an answer for you until then. I'm incredibly sorry this is happening as I can't imagine how frustrating it is. If my Apple Watch did that, I honestly probably wouldn't use it as much as I do now. I'm going to keep searching for answers and different contacts in the meantime.

Look at all these returns, it’s nothing short of embarrassing. Go look anywhere on the internet everyone is talking about how the lte version doesn’t work lmao. Switched to an iPhone X and the Apple Watch series 3 and couldn’t be happier. Thank you for at least making the switch easy. Please stop seeing the galaxy watch until Samsung figures out lte.

Userlevel 5

Hello, Everyone!

While some of you may have return the Galaxy Watch already and no longer need updates on the issue, I'd still like to keep this thread updated. My Samsung contact got back early from his time off which means I should hopefully have a response no later than tomorrow.

Thank you, hopefully the issue will be fixed soon

Thank you for pursuing this! I haven't given up hope on getting this issue resolved.

Userlevel 5

Alrighty, I have a few steps for you guys to try.

  1. Launch Gear Manager
  2. Go to Watch connection
  3. Toggle Remote connection on
    Note: The first time you select "Remote Connection" it will ask you to log in to your Samsung account. Once you log in, forwarding will be enabled for your Watch that is connected to your handset.

Please give this a shot and let me know if that fixes the issue!

Userlevel 5

Happy almost Friday!

I just wanted to check in to see if anyone has had a chance to try the steps I posted a few days ago. If so, did the duplicate texts stop coming in once you connected to LTE?

Hello, and thanks again for pursuing this solution. I wanted to test for

a few days before replying.

Unfortunately, it did not provide a good solution. On turning off that

setting and then back on, I didn't get duplicate messages. However, it

became clear that this was because all notifications from the messages

app. On reallowing messages to send notifications, I am once again

getting duplicate messages.

Some additional information, I am predominantly using the watch tethered

through bluetooth, with LTE in auto mode (turns on if bluetooth

disconnects). It is when the watch and phone get out of bluetooth range

that the duplicate messages arrive, perhaps 15 minutes after disconnect.

Yea im done with this stupid watch. $375 and we cant even get it to work correctly. RETURNED!

Userlevel 5

@magenta6238774, thank you for the detailed response. When you disconnect from Bluetooth do you have DIGITS enabled or disabled?

@floresr639​ , I'm sorry we didn't get this fixed in time but I appreciate you taking the time to help get the Watch working as it should be.

After disconnect, DIGITS is enabled.

Thank you!

Same issue as original poster. Has anyone found a fix? I tried the above and it did not work. I have called tmobile and they put in a ticket and told me it would be fixed in 72 hours. It's not.

Userlevel 5

Thanks for getting back to me, @magenta6238774​! Sorry for the delayed response as I was out of the office for a few days. If DIGITS is enabled, the remote connection should be off. Can you make sure your Watch is set-up that way and let me know if the duplicate texts still come in when you step away from your phone?

Hello, @dupsla​! We're working on a fix now and you're welcome to join in the troubleshooting conversation, if you'd like. I'm working with a few people from T-Mobile and Samsung to get to the bottom of why this is happening.

Userlevel 4
Badge +9

A good question would be do you have the DIGITS app (native or otherwise) enabled on your phone with your phone number? I ask mostly out of curiosity because when I have mine on, I get multiple notifications from DIGITS regarding messages that I've already read in my regular Android Messages app.

No I don't. I have my main number off in the app. When I spoke to the rep he said it's supposed to do that when it kicks over to Mobile networks/disconnects from bluetooth, all your messages are supposed to come thru. He said to turn on mobile networks on my watch to stay on all the time. My watch was dead in 3 hours. I had 100's of messages come thru at a time. Another issue I am having and I sent him pictures, I have 2 contacts when they text me it comes thru as if its from my watch number.

Hello, and welcome back!

I wanted to check, does remote connection refer to both Bluetooth and

WiFi connections? Using LTE alone (which would result from turning off

remote connections by my understanding) really drains battery.

Reply