Google Nexus 5- Hangouts "couldn't download MMS.  Touch to download again."

I purchased my Nexus 5 in April from T-mobile and I've gotten used to using Hangouts as my SMS/Chat app.  However, recently (once when my signal was not good) and today (when my signal was fine), I missed several texts from my friends who are iphone users.  I received the same error message every time "Couldn't download MMS."  I tried to "touch to download" the message but it did nothing.  I've tried disabling "imessages" on my ipod touch.  I've changed the APN name on my phone from MetroPCS to TMobile GPRS.  I've tried clearing the cache in the hangouts app but I am still missing some texts and I can't understand why.

6 replies

Userlevel 6

Sounds like Thread-70845

And.. well... I can add that my response in that thread... well, it was from an iPhone.

Maybe it has something to do with iDevices?  There was a post recently something about iPhones hijacking MMS.

Userlevel 6

to add more

iPhone Won't Deliver iMessage Texts To Android - Business Insider

It seems like it's an apple problem because I get other texts just fine but it seems like Apple is only telling folks to delete and then re-add their android-using friends.  Oddly enough I was getting texts regularly until today.

I'm having the same issue, but it is specifically when I'm connected to wifi. I am missing mms messages (group texts from iphone and android users across carriers) as well as phone calls periodically. The problem seems to be well documented on google and t-mobile forums and has something to do with how the Nexus 5 is routing the MMS because it doesn't have wifi calling capabilities. I'm getting very frustrated as I'm connected to wifi 80% of my day and t-mobile continues to suggest that I file a warranty claim through the manufacturer.

Here is something to try:

Go into Hangouts, then Settings, then SMS.

Click 'Access point names.' By default, mine was set to 'MetroPCS,' I changed it to 'T-Mobile GPRS,' try that or another.

Another possible solution here: Solution to Picture/Group MMS on WiFi

There was a known issue around the time of this post: I had the same issue.