Solved

"Invalid Battery" shuts down phone

  • 20 October 2015
  • 9 replies
  • 297 views

My G4 came with 2 batteries which I switch around every month or so, using the other as a spare. (Both genuine LG batteries)  Prior to my last switch attempt, there was an Android update for the G4 and ever since then the only battery which works is the one in the phone during the update.  If I install the other battery, the phone boots ok, runs for about 30 seconds, reports 100% charge, and then shuts down after a brief "Invalid Battery" message.  This is bad!  Does anyone have any idea what's going on here?

 

I've tried the following:

1: Cleaned the contacts to make sure all four connect well.

2: Checked that none of the contacts are bent.

3: Cleared the cache.

4: Many, many reboots.  The problem follows the battery.

icon

Best answer by rallyr 17 November 2015, 23:53

I got the battery back today, and it works fine.  I can now use both  batteries same as before.  They did not say what the problem was, but obviously there was a problem with the battery itself.  This makes me very happy that I didn't do the "factory reset" that the phone tech wanted me to do, since it obviously would not have worked and I'd have been stuck re configuring my phone for a week!

View original

9 replies

Userlevel 6
Badge +14

That's a really unique issue you have there @rallyr‌! The battery that gives you the error, it's the exact same size as the working one? It doesn't have any additional grooves or bevels on it? When you look at the battery prongs in the phone, they don't appear to be bent down or damaged in any way?

The two batteries are identical and undamaged!  I bought them at the same time, directly from LG, and until the last Android update they both worked correctly.   BTW, not that unique either.  The LG support site and other Android discussion boards are full of the same complaint, but so far LG has been silent on a solution.

Userlevel 5

That's definitely worrisome. :/

Have you tried a master reset on the device to see if that resolves the issue?

-Lauren

I called LG service and they told me to send back the battery, which is still under warranty.  I have my doubts that this will fix it, but I'll let you know as soon as it returns.

Mike

Userlevel 6
Badge +14

Hey just wanted to see if the battery fixed the issue.

I just received notice that the battery is in shipping back to me.  I'll let you know if anything is fixed when I receive it in a few days.

Userlevel 6
Badge +14

Cool, thanks for keeping me the loop!

I got the battery back today, and it works fine.  I can now use both  batteries same as before.  They did not say what the problem was, but obviously there was a problem with the battery itself.  This makes me very happy that I didn't do the "factory reset" that the phone tech wanted me to do, since it obviously would not have worked and I'd have been stuck re configuring my phone for a week!

Userlevel 6
Badge +14

That's awesome the battery is working for you!!! 😊 I'm glad to hear that!! You're right, it does appear to just be an issue with that battery. I know setting up the phone after a reset is VERY time consuming but, at least you don't have to do that now. I'm happy it's working for you and thanks for posting!

Reply