Is anyone having WiFi calling issues since Pie update

  • 14 February 2019
  • 95 replies
  • 4291 views

My Wi-Fi calling was working fine prior to the pie update. Now it works sporadically. I can text and make calls fine on the network, but Wi-Fi calling is another issue. I've had no issues prior to the update so I must assume that the update is the culprit. Anyone else having similar problems?


95 replies

By the way I'm on a Galaxy S9 Plus.

@magenta3045461

Have you tried to wipe the cache partition after the update? Please do it if you have not done it following the Wipe cache partition: Samsung Galaxy S9  .

Are you seeing any particular error messages? Like REG091 etc?

Just did the update this morning and wifi calling doesn't appear at all.  Wiped the cache partition and no change. Is this a bug in T-mobile Pie, or just Pie?

No error messages, just no wifi calling.

I can't even, receive calls at all from anyone since my update.

I'm also on the Samsung Galaxy S9Plus

I am having a problem with the wifi calling going on and off and everytime it comes on my notification ringtone goes off...this never happened before the update. How do I fix this?

Same thing happened to me. I upgraded to Pie and wi-fi calling disappeared on me to.  I tried the same thing to no avail.

Ok, I was able to enable WiFi calling under Android Pie using the Phone App.. I clicked in the 3 Dots on the upper right hand corner. This will bring up the menu for Speed Dial Numbers, Voicemail and Settings. Under SETTINGS here they placed the enabling feature for WiFi Calling. So the originals sittings from OREO might have been causing problems. This is where to set them in PIE

I'm also experiencing wifi calling switching back and forth from cellular to wifi.  No setting I change fixes the issue.  I'm on an s9+.

Updated to Android 9 yesterday. I am experiencing issues with the WiFi Calling on both Samsung S9+ phones on my account. Same persistent, IRRITATING notifications regarding changing modes from "Cellular Preferred" to "Wi-Fi preferred". What gives?

It is not a PIE issue. It is the Carrier Configuration that is forcing this. Carrier Configuration is pushed by TMobile and Samsung has nothing to do with it. You can go to Settins-> About Phone -> Software Information and look for Carrier Configuration. If it is more than 2.350001, then this behavior will happen.

My configuration is only at 2.34000 and it's still going back and forth

from wifi to cellular service

Go to Wi-Fi, select "Advanced", do you have enathing enabled under the "Adaptive Wi-Fi"?

Meaning: Swtich to mobile data and turn on Wi-Fi automatically?

If you press the Wi-Fi calling button on the drop down menu, what option it has selected by default: cellular or wi-fi?

Adaptive Wi-Fi had the "Switch to mobile data" turned on in "normal" mode. I switched that option off, hopefully that option being on was the culprit behind the switching back and forth on Wi-Fi calling. "Turn on Wi-Fi automatically" is on.

Also switched to "Wi-Fi preferred" under Wi-Fi calling. Previously this option would switch back and forth between Cellular Preferred and Wi-Fi preferred on it's own, with the accompanying persistent notifications.

I figured out a fix for the notification switching on and off. Go into your settings and search for wifi calling.  There you can toggle the notifications off. I'm on a galaxy s9+.

Looks like a global 9.0 PIE issue. The Phone automatically decides what it thinks you should be on and there is no way to force it to stay on Wifi Preferred. Huge issue for some like me that lives in a horrible Cell coverage. When I called T-Mobile they are claiming they know nothing about this but its all over the internet from multiple carriers and phones since PIE was released. Any answers T-Mobile?

It is in fact a PIE issue as there is know way to default the setting. Its also happening across multiple carriers.

Getting the notification and sometimes no network when trying to call out. After upgrading to PIE.

I am having the same issue and it is driving me nuts. I have tried everything suggested and that I could think of. Nothing is working. This issue needs to be fixed. I need WiFi calling. I cannot turn off the WiFi calling notifications. It won't let me.

I am also experiencing the same problem.  The issue only appeared after upgrading to Pie.

Same problem here!! Never did it before the update!!

Did you try my fix for the notification bouncing back and forth? Go into the settings menu and click the magnifying glass to search.  Search for wifi calling and disable those notifications.  That stopped the notifications for me and still makes wifi calling available.

I have notifications disabled, but it doesn't fix wifi calling. It

still switches back to cell preferred

HELLO .......ATTENTION T-MOBILE......WE WANT A RESPONSE OR A FIX......PLEASE AND THANK YOU!!!

Same prob here. Updated to pie today. All good except wifi calling. Note 9

What is the settings of your Adaptive WiFi available under Settings-->Connections-->WiFi-->Wifi Direct? Can you post a screenshot here?

Reply