Is anyone having WiFi calling issues since Pie update

  • 14 February 2019
  • 95 replies
  • 4570 views


Show first post

95 replies

Also, go to Settings--> Apps--> Hi the three vertical dots and show system apps. Scroll down. Clear data and clear cache for each of the apps Wi-Fi calling, Wi-Fi Direct, and Wi-Fi Tips.

Did that. Still not working.!!!

With WiFi calling do you see something like the following image Settings->About Phone ->Status->SIM card status. Where do you see IWLAN?

If you see the following image, I know where is the problem.

I just noticed that it is working. I made a phone call now and i showed it was on wifi calling. And when i open the dialer app, the dial button shows on wifi calling. There the wifi bars added to the button. However, i have no notification icon on my status bar that shows wifi calling connected as it used to be on oreo.

Yes, PIE update removed the icon. But the IWLAN should have been in Mobile Voice not on Mobile Data. It is wrong. I am now blocked on wifi alone if I need to make call.

Now i m on wifi calling. All working great. Here s a screenshot of my sim status.

I finally fixed mine. Go into wifi settings, choose your wifi connection, go to advanced, change IP settings to static, change DNS 1 to  8.8.8.8 then hit save.  Then go to wifi calling and change to wifi preferred. Fixed mine. Able to make and receive calls and texts over wifi.

This is NOT a fix for the wifi calling switching back to cellular preferred

I'm having the same issue with my Samsung S9+. My phone is constantly switching between wifi and cellular preferred. Any update/answer for this yet?

I have been guiding T-Mobile customers to use the multi line settings and digits program. Similar to wifi calling but better. As a work around till a new update fixes these issues. First unlock the multi line settings,go to my.t-mobile.com, sign in, go to phone, manage digit settings, unlock for the line in question, then proceed with the following steps after power cycling the device. Settings> Accounts> multi line settings> sign in. DIGITS: Samsung Galaxy Note9  You should be good to make VOIP calls using digits, sms, and manage voicemails. Digits is a great program altogether, and a great way to resolve wifi calling issues with nontmobile phones as well. Those will need to download the new tmobile digits app. Hope this helps!

I'm about to throw my phone in the garbage disposal if tmobile doesn't fix this issue.  I've had a dozen dropped wifi calls in my house today alone. Galaxy S9

If cellular signal is not bad (~ -95 dbm or more) in your home, you can use cellular preferred without any drop calls. It will revert to wifi preferred if cellular signal is weak.  You can check signal strength in Settings->About devices->Sim STATUS.

Samsung needs to fix this, it may be a PIE issue, not specific to T-mobile.

Same problem here, dropped like 6 calls yesterday. I do not have network at work, but my phone automatically switches to cellular.

I can make calls and send text messages just fine when I'm not at home and out of my wifi range but as soon I get home and in range all that is gone, this issue is extremely frustrating especially when my zone is a dead-zone and need wifi calling.

If I may, I can suggest some workaround which may sound stupid but it will work.

As soon as you are in office, please turn on AirPlane Mode and then just turn on WiFi. Make sure you have WiFi Preferred selected. This will prevent the preference to go back to Cellular Preferred. Once you are out of office, make sure you switch off Airplane mode for the cellular connection to go alive.

I finally found the solution....at least for me. I have also had issues since updating  the software/firmware.

The WiFi calling icon was moved from "Settings". swipe down 2 x from top to bottom on your home screen and you will find wifi calling and other icons. You can turn your wifi calling off and on and select it as cellular preferred or wifi preferred like you used to.

Since the Pie update, all calls were going directly to voicemail on my Note 9.  After spending all day troubleshooting, I was able to find and solve the problem. In my case, it was a Call Block app that I installed a couple years ago. There's a setting in the app that answers the call and hangs up if the caller is in your list of blocked numbers. The app was answering and hanging up on ALL inbound calls (not just the ones in the list). Apparently, the app has compatibility issues with new version of Android. Uninstalling the app solved the problem.

Call blocking is now native to Android OS so there's no need to update the app.

Short answer: If you're having trouble calling with Pie, uninstall all apps that have permission to hang up the phone. Then, add apps back one at a time and test after each reinstallation.

What is the fix to this problem Tmobile???

I've tried the airplane mode but causes some of my calls to straight to voicemail while I'm connected to wifi. I've reset my network settings, still getting the annoying optimizing wifi notifications and dropping calls. This is horrible for people with bad signal and depend on wifi for calling. For tmobile or Samsung ignoring this issue, you are about to lose a lot of customers. I'm reading a bunch of try this fix that doesn't seem to work,  what is the main fix here?

I updated to Pie on Tuesday. I have no idea if wifi calling is working or not as I would typically get a wifi calling icon showing up at the top of my phone that would show me that it was working (white icon), or that it wasn't (red icon). Now there is no icon at all. Not good to be in a roaming country and connected to wifi and expecting wifi calling to work and for some reason it failed and calls go through cellular generating usage charges . There is no way to enable wifi calling on the connections setting tab as before which would also show status (I found the double swipe from the top does reveal the wifi calling button, but this only enables the option without any indication as to whether it's working or not).

I've also set wifi preferred vs cellular preferred, but I get a message a short while later stating that the phone has switched to cellular preferred. That's not what I want to happen.

This is on a Note 9

$800 SAMSUNG GALAXY S9 PLUS..... RUINED BYUPDATE

AFTER WAITING AN HOUR ON HOLD FOR A BILL I HAVE TO PAY THE DAMN CALL DROPPED.....AFTER ANOTHER UPDATE TODAY, THE ISSUE OF WIFI CALLING AUTOMATICALLY SWITCHING TO CELLULAR PREFERRED ...IS....NOT...FIXED..!!!!!!!!

AFTER THE LATEST UPDATE: SECURITY PATCH UPDATE MARCH, 1ST 2019

AFTER THE UPDATE THERE IS A SCREEN ON MY PHONE THAT SAID

"YOUR PHONE HAS BEEN UPDATED, THANK YOU FOR CHOOSING T-MOBILE"

HELLO T MOBILE.....THAT IS ADMITTING YOU ARE RESPONSIBLE FOR THIS!!!  I'M PISSED AND FEEL RIPPED OFF, FIX THIS WITH A PATCH OR RE-FLASH BACK TO OREO OR I WILL CHANGE CARRIERS (NOT LIKE YOU CARE)

I guess t mobile is ignoring this problem. Horrible. Walked into Verizon store yesterday and they said T for terrible.

Same issue here, Galaxy S9+ with Pie on Tmobile.

Need to bring back Wifi Calling persistent notification and also there is a bug not allowing force wifi calling to wifi preferred always.

Please fix soon!

My issue is Wifi calling is working to much. I'm constantly bombarded with notifications telling me its optimized itself. And change's what i've set it to prefer. I'd really like it if you would keep what I've set it too. And stop changing between cellular network and wifi network and definitely stop notifying me as much. I get 30 notifications in a minute and sometimes none for hours.

My friend is having the same problem. He changed his sim card with mine (tmobile also) and it worked on the S9+. He is going to get new sim tomorrow.  I will update if fixes the problem again.

T-Mobile will lease you a " Tower signal" router that runs off runs off your router.  This generates a T-Mobile signal, not Wifi.  You have to modify 3 portals for this to work.  Check out YouTube on latest version router.  It works.  Router was free.  I have very weak T-Mobile tower signal, but the new router provides a strong tower signal in the house.  Not wifi. 

Reply