Is anyone having WiFi calling issues since Pie update

  • 14 February 2019
  • 95 replies
  • 4566 views


Show first post

95 replies

I can't tell you how to fix the bug, but I can make it so you don't constantly get the notification every 5 seconds. This fix wasn't mine, so I do not take credit. The answer is obvious copy and paste.

I have the same problem- I need to have Wifi Calling on because of the lack of cellular signal at my house, but damn if that notification isn't crazy annoying! I could not find anything either on how to disable it, the only thing that I did figure out was how to "mute" it in a sense. When the notification pops up, I long press on it, which usually gives you a few options for notifications, one of which is to turn the notification off. In this case, you are not allowed and it tells you, as you already surmised. However, a "Details" link pops up and if you tap on that, it takes you to Wi-Fi Calling settings, which is no longer in the Communications section of settings... Anyways, only two settings that are listed, top one being "App Icon Badges" and the lower one is "Wi-Fi Calling" which is enabled and does not allow you to disable, but if you tap on that you can adjust the notifications for Wi-Fi Calling and I played with the first setting which is Notification Style. When you tap on it it expands a menu which has "Sound and pop-up, Sound, Silent and Silent and Minimized". I chose "Silent and Minimized" and have not seen a notification since, unless I go back in and change it back, which I just did now to write this how-to. Hope this helps...

I have always been eager when it comes to updates to the Android OS, but this one for PIE has left me quite unhappy with all of the changes, especially when they design annoying notifications that they don't even allow you to disable... Anyways, I was glad to find a work-around and hopefully it meets your needs!

People,

Please update to April Security Update patch G965USQS4CSC8 which weighs around 526 MB for S9+. That seemed to resolve the WiFi calling issue. It was released 4/19 late night Central Time.

The wifi icon is gone after the update. As long as your connected to wifi and have wifi calling and wifi prefered on, when you make a call you will see the wifi calling icon...next to the time duration near the upper middlle of the screen. It's just different than what we are use to.

  • magenta3045461 wrote:

    My Wi-Fi calling was working fine prior to the pie update. Now it works sporadically. I can text and make calls fine on the network, but Wi-Fi calling is another issue. I've had no issues prior to the update so I must assume that the update is the culprit. Anyone else having similar problems?

    Yes . It happened in our area.
  • I had asked HBO,  Game of Thrones
  • Marked the show to remind me.

How aggravating

I updated to The April Security update patch on the 20th. I'm still seeing the same behavior as before. No indication as to whether WiFi calling is actually working, Just that I have it enabled and I get a text every morning to say that the phone has switched to cellular preferred.

As per a previous note, I now see an indication near the top of the screen on the calling screen when placing a call, or receiving a call as to whether that call is WiFi, or not, but I should not have to wait till a call is in progress to see what connection is being used and the phone should not be flipping back to cellular preferred on its own. What happened to the "WiFi only" option?

If I'm on a cruise ship with unlimited internet minutes, I want the phone to stay on WiFi calling and I want it to show me that WiFi calling is up and running. If WiFi calling fails, or if the phone flips to cellular preferred, then I run the risk of connecting to the ships cell tower to make and receive calls at a rate of somewhere between $5 and $6 a minute.

This really needs to be fixed on Pie, T-mobile.

Are you ready for the fix for your cruise secerno?

Put your phone in airplane mode, then ONLY turn on wifi. This guarantees that the phone only uses wifi calling and not cellular network (as cellular radio is turned off in airplane mode).

I take donations via Paypal.

@paulmcs

Even if you do WiFi preferred, there is no guarantee that it will stay in the wifi. If it gets a better cellular signal, it will switch because the aim always has been to maintain a QoS of the call. The only you can ensure that you are routing your calls via WiFi is via the method that @grant007​ suggested. But I agree with you, a WiFi calling icon would have been good. I am also not happy that Samsung decided to remove that in the PIE build. I have an unlocked S9+ that receives carrier bloatware free software from Samsung directly. That even does not have that icon. Not sure why.

This 9.0 pie update is making it hard the use my phone. The WiFi calling is acting crazy. It constantly switches between Cellular and Wifi preferred. Every time I move it back to the WiFi it will switch back to Cellular. I live in a poor signal inside my dwelling have to have it on my WiFi. The problem ever since it updated. Can't find a fix for it. 

I was still having this issue and I might have found a possible REAL fix, I have used it for hours now with no issues so far. First manually set to Wi-fi preferred in the Wi-fi Calling app's settings. Then, open the Wi-fi Calling app's App info. Scroll to the bottom where you will see Change System Settings under Advanced and change it to Not allowed. I figured, if I manually set it, then remove the app's own permission to change that setting, then it cannot change. Seems to work so far!

I tried it but it started doing it again after about an hour or so. Hopefully, they will put out a patch or something to correct it.

Since the last Android update, I have had zero problems with wifi calling. Once set to Wifi Prefered, I have not had to change it.

You must be one of the lucky few. My Note 9 switches all the time since the 9.0 pie update.

I've never had any luck with T-Mobile WiFi calling.  I always disable it.  I've tried using it on all my phones in the past starting with HTC One S, then Galaxy S4, S5, S7, Note 9 and now S10.

In all cases I can usually hear the other person, but they say I sound awful...like talking on a Magic Jack. 

This has been from home (both Spectrum Charter and then AT&T U-Verse) as well as work (Spectrum Charter) and at my Father's using Fios.

For me, its never worked.

So 2-3 years ago I would have agreed with your statement while using a Galaxy S7. Wifi calling worked but it didnt work every time.

Now though, for the last year, Wifi calling has been stable and voice quality excellent even while overseas working in undeveloped and war torn countries. I honestly have no problems with Wifi calling since the last update where a fix was introduced to force wifi calling to wifi network preferred.

I'm a note 9 user and my phone keeps switching to cellular when the phone is "optimizing" wifi calling.  Cannot get it to stay on wifi for calling.  I have a great mesh network at home that should provide all the bandwidth that wifi needs.  The cellular in my area is terrible.  Was terrible with Sprint, is terrible with TMobile.

My issue was under the Wi-fi Calling tab in the menu screen the newest update changed it back to default. In that setting you have Cellular preferred and Wi-fi preferred. You need to change it to Wi-fi preferred. The reason being if it is on Cellular preferred if the phone sees any type of cell signal even the weakest signal it will try to bring your phone call through the cellular network.

My issue was 90% of my phone calls were going to voicemail and not even ringing. Very frustrating when someone is trying to get a hold of you. It also affects your incoming text messages as well. Hopefully that will fix your problem. The only other thing I have heard but haven't tried is turning your phone on airplane mode and then turn your wi-fi on.

Userlevel 6
Badge +15

@magenta8905439  are the large portion of your calls still going directly to voicemail? If so, what phone are you using and is this only happening when you have Wi-Fi calling set to a certain setting?

Yes definitely most of my calls are going directly to voicemail. I'm using the Galaxy S8. Also an update on putting the phone in airplane mode, it worked a couple of times and then the same issue. So now I have no resolution. Though some one said it might be an app that is causing the issue but the issue didn't happen till after the update. Sure it would happen every once in a while as Wi-fi isn't reliable like the cell service but now it is the majority of the time.....

I have a note 9 and it switches to Cell after I set to wifi. Continual cycle. Even runs my data usage up ever since the pi update. Been thinking of downgrading back to oreo till they come up with a patch.

"If I'm on a cruise ship with unlimited internet minutes, I want the phone to stay on WiFi calling and I want it to show me that WiFi calling is up and running. If WiFi calling fails, or if the phone flips to cellular preferred, then I run the risk of connecting to the ships cell tower to make and receive calls at a rate of somewhere between $5 and $6 a minute."

THIS.

I actually WORK on a cruise ship, and when the wifi calling was on, T-Mobile always showed as my current network. I just did the update (Galaxy A6) yesterday, and with the absence of the indicator in the status bar and "Cellular at Sea" the only network showing as available, I'm paranoid about making a call, even though the wifi icon is present in the dialer. I'm even MORE paranoid to send a text as I've been burned with $6 in charges because i didn't notice that the wifi indicator wasn't present and each text went out on Cellular at Sea at .50 each. I could live without the indicator if T-Mobile at least showed as my current network.

The cruise ship issue is such an easy fix. Put the phone in airplane mode

then turn on wifi. This will force only wifi calls/txts and you won't get

charged a dime.

Userlevel 6
Badge +15

It's possible it could be a 3rd party app, but there's ways to test that. Can you try the phone in Safe mode to see if calls are still routing straight to voicemail? Also, this is a device you got directly from T-Mobile, correct?

I downgraded to 8.1.0 and have no more issues with it switching. Hopefully they release a patch for 9.0 to address this issue.

Did you have to do a factory reset to go back to an earlier build?

On Monday, June 17, 2019, 12:24:04 PM CDT, magenta8526077 <no-reply@t-mobile.com> wrote:

|

T-Mobile Support

|

Is anyone having WiFi calling issues since Pie update

reply from magenta8526077 in Android products - View the full discussion

I downgraded to 8.1.0 and have no more issues with it switching. Hopefully they release a patch for 9.0 to address this issue.

Reply to this message by replying to this email, or go to the message on T-Mobile Support

Start a new discussion in Android products by email or at T-Mobile Support

Following Is anyone having WiFi calling issues since Pie update in these streams: Inbox

This email was sent by T-Mobile Support because you are a registered user.

You may unsubscribe instantly from T-Mobile Support, or adjust email frequency in your email preferences

Reply