Is anyone having WiFi calling issues since Pie update

  • 14 February 2019
  • 95 replies
  • 4693 views

My Wi-Fi calling was working fine prior to the pie update. Now it works sporadically. I can text and make calls fine on the network, but Wi-Fi calling is another issue. I've had no issues prior to the update so I must assume that the update is the culprit. Anyone else having similar problems?


95 replies

No,

I had to use Odin and the 8.1.0 firmware I downloaded. Then after the downgrade had to turn off the auto update in the settings.

I don't have any issues with wifi calling in my home calling area.  However, I was in Canada last weekend and I kept getting popup notifications that said "W-Fi Calling preferences updated to optimize network experience."  Once would have fine, but it kept popping up over and over throughout our visit.  I eventually just turned off wi-fi calling.

Badge

We're all having this issue, and it's not T-Mobile's fault.  If you do your research you will see that this plagues all 4 of the carriers.
This is a Google issue, and Google needs to release a patch to fix this problem.  WiFi calling has a bad habit of switching from Wifi Preferred to Cellular preferred for whatever reason it's programmed to do so.

In Oreo, if you chose Wifi Preferred, it would use that setting.  For whatever reason now, it just does what it wants.  While I understand everyone's frustration on this matter, the fact boils down to this, it's Google than needs to release a fix for this.  Our carriers are not at fault for this

My latest research hasn't turned up anything regarding Google mentioning this to be an issue, or a patch, so my guess is that we should ask our carriers to contact google and let them know this issue is a problem so they can release the patch to fix it.

This particular issue is affecting the folloiwng devices:

Samsung Galaxy S8
Samsung Galaxy S8+

Samsung Note 8

Samsung Galaxy S9
Samsung Galaxy S9+
Samsung Note 9

Clearing your cache won't resolve the issue, nor will doing a factory reset (I've tried both). The issue is Android Pie and needs to be addressed.

So for those of you have read that resetting your device or clearing your cache works, please save yourself the time and headache, and realize this is a software related issue, not a phone issue.

Hope this helps.

How do you know whether or not you are on a call utilizing WiFi?

When placing a call, on the the dial pad screen, as well as showing the connection time, it will also show a little wi-fi icon if the call is going over wi-fi. I would prefer to know prior to dialing that the call is going over wi-fi before placing the call, but that is not the case.

I was at home and placed a call to a help desk. I was on hold for about 30 mins, so needed to leave the house. I get out of wi-fi range and the call drops, so I have to dial back in over cellular and join the queue again. Prior to Pie, I would have seen the little wi-fi calling icon in the top left and been aware that I needed to remain connected to wi-fi, or disable wi-fi calling and place the call over cellular. A little wifi icon on the dial pad screen after I've placed the call just wont cut it here as I have the phone against my ear by the time it shows up.

I downloaded the June update for the phone this morning and no difference to the behavior. 

Ah, I just realized I have cellular preferred checked.  Is that usually the recommended setting?

Not if you are roaming and want to avoid usage charges which is why you might enable Wi-Fi calling in the first place. The issue with PIE is that even if you select Wi-Fi preferred, if the phone deems the cellular connection more stable, it will flip to cellular preferred.

Pre PIE, your choices were cellular preferred, Wi-Fi preferred, or Wi-Fi only. The last option meant that you could never have international roaming if you wandered away from Wi-Fi connectivity (no calls either it must be said!) 

"if the phone deems the cellular connection more stable, it will flip to cellular"

This is something I'm very curious about.  The word "preferred" is tricky since it implies some decision tree to pick one or the other.

I picked up years ago a tmobile cell-spot because my house is in a valley.  That things is the *best* thing about TM (binge-on is pretty cool too...).  But at home I have Google wifi pucks around and the cell spot, so I have great signals for both and I would like to know *how* it picks one connection or the other.

Badge

Just received the July update on my Note 9.  Nothing in the description about dark mode for the camera, but it's there. Also, changed my preferred settings in Wi-Fi calling to wifi and they haven't changed back to cellular in over two days. I think they snuck the fix in there. Anyone else notice this?

I also received the July update and changed a setting, just to be sure.  Haven't had the phone switch in 2 days 😊 . 

Settings--apps--press the 3 dots at the top right--show system apps--wifi calling--Change system setting==Change the option to NOT ALLOWED.

Hope this helps!

Did this resolve the issue for you in the long run?

Badge

Glad that worked for you.  I didn't have to go that far. I went to status bar clicked on the wifi calling text not the icon and it gives you the options of your preferred choice. I used to select wifi preferred and it would keep switching to cellular preferred. It hasn't done it since my last update (July security update) I've also noticed the night mode for the camera, haptic feedback with the swipe function of the navigation bar, and a different animation when I put it on the charger. Did you get the same? 

Userlevel 7
Badge +15

That is one of the many reasons why my girlfriend forced her S9 Plus back to Oreo.  OneUI is awful but the Messages app and some other features are inconsistent since hte Pie updates started rolling out on every firmware, including the U1 and other carrier firmware versions. 

After trying today it appears the bootloader has locked me out of the downgrade option, so I'm stuck with 2 broken phones.

Userlevel 7
Badge +15

That sucks, but that is also a good reason why to not rush into updating.  Samsung does not allow a firmware to rollback to the previous bootloader version.  The first Pie update still had the same bootloader but some newer updates have a newer version. 

Has there been any fixes? I'm having issues since update as well

Galaxy j7star. I just updated software and low and be hold, the wifi calling option in phone app totally disappeared. And the wifi calling icon became shaded blue and can't turn it on or off. I tried everything clearing cache, turn this and on and off.  Nothing works. This is not good. I am going back to other phone company.

It didn't work for me on Galaxy J7star.

I agree. I think it is the software issue. They remove the wifi calling.

Disable wifi saving mode under advanced WiFi settings. This worked for me 

Reply