LG IMS Keeps Stopping FIX


Userlevel 1
Badge

I got this fix 5/24/22 it's similar to many others. They don't work this one does. It's from a LG engineer.

Put the affected LG phone in airplane mode by pulling down the notification shade and tapping on the plane icon.

Putting the phone in airplane mode should stop the IMS error message from popping up.

Open the phone's settings and tap on Apps and Notifications, followed by App Info.

On the App Info page, click on the three-dot menu icon in the top-right corner of the screen and tap on Reset App Preferences, then tap on Show System.

Look on the app list for "com.lge.ims.rcsprovider" and tap on to open the next page. Doing so will pull up the pre-installed IMS provider app's detailed overview.

Once there, tap on the clear data/cache option, then clear storage, then force stop. 

Then restart the phone. If the pop up happens anytime during this. Restart phone and do again.


 


17 replies

Userlevel 7
Badge +14

Thanks. I have a prepaid mnvo that uses Tmobile towers and I use it for a cheap home phone so it really wasn't bothering me much but it seemed to fix the issue.

Userlevel 1
Badge

You're welcome 

Userlevel 7
Badge +14

I read how to do it but the didn't give the steps like you did.

Userlevel 3

I got this fix 5/24/22 it's similar to many others. They don't work this one does. It's from a LG engineer.

Put the affected LG phone in airplane mode by pulling down the notification shade and tapping on the plane icon.

Putting the phone in airplane mode should stop the IMS error message from popping up.

Open the phone's settings and tap on Apps and Notifications, followed by App Info.

On the App Info page, click on the three-dot menu icon in the top-right corner of the screen and tap on Reset App Preferences, then tap on Show System.

Look on the app list for "com.lge.ims.rcsprovider" and tap on to open the next page. Doing so will pull up the pre-installed IMS provider app's detailed overview.

Once there, tap on the clear data/cache option, then clear storage, then force stop. 

Then restart the phone. If the pop up happens anytime during this. Restart phone and do again.


 

This not quite right.

 

You state: “Once there, tap on the clear data/cache option, then clear storage, then force stop.”

 

However, you must clear CACHE, then go back and force STOP

Then go back tap clear DATA, then go back and force STOP. Then exit out of settings.

CACHE and DATA are two different things and DATA is the key.

Turn off airplane mode and test before you allow WIFI to be enabled. If all god, turn on WIFI.If problem resumes, repeat but keep WIFI of or use 2nd solution:

 

THE BEST SOLUTION many have found (and easiest, which was posted by a tech on Monday night) and which allows WIFI to be turned on and RESTARTING the phone  (without the debilitating popup returning) is the following:

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

 

Userlevel 7
Badge +14

This solution worked for me and was easy to perform.

Userlevel 5
Badge +8

 

THE BEST SOLUTION many have found (and easiest, which was posted by a tech on Monday night) and which allows WIFI to be turned on and RESTARTING the phone  (without the debilitating popup returning) is the following:

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

 

 

 

https://tmo.report/2022/05/lg-devices-on-t-mobile-made-unusable-due-to-lg-ims-crashing-bug

 

FAKE NEWS! The problem still existed a full day AFTER this updated article from two days ago. If you rebooted {restarted, not reset} your phone Monday evening  the problem remained and still may remain today (Tuesday).

THE BEST SOLUTION (and easiest, which was posted by a tech on Monday night) and which allows WIFI to be turned on (without the debilitating popup returning) is the following:

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

 

 

FAKE NEWS! The problem still existed a full day AFTER this updated article from two days ago. If you rebooted {restarted, not reset} your phone Monday evening  the problem remained and still may remain today (Tuesday).

THE BEST SOLUTION (and easiest, which was posted by a tech on Monday night) and which allows WIFI to be turned on (without the debilitating popup returning) is the following:

  • Settings > Network & Internet > Mobile Networks > Access Point Names > 3 dots > Restore Default Settings.

 

 

Did anyone actually get the fix by an update push from TMo? Was that actually fake news as @tomwil suggested?

Seems like everyone is talking about performing the fix but noone says the push fixed the phone

My G6 is still plagued with the IMS pop up.

 

This did NOT work. tried several times!

Userlevel 5
Badge +8

 

Did anyone actually get the fix by an update push from TMo? Was that actually fake news as @tomwil suggested?

Seems like everyone is talking about performing the fix but noone says the push fixed the phone

My G6 is still plagued with the IMS pop up.

 

The following post appears to have received an update from T-Mobile, but seems pretty drastic:

 

 

Early on in this fiasco, support suggested I backup the device and do a “Factory Reset”. That didn’t work, so I didn’t restore my data from the backup.

This morning, I did another reset and the problem went away. I restored everything from backup and the system is still good.

Of course, they won’t tell us what caused this mess.

It worked for me as long as I kept my phone in airplane mode, but it reverts back if you turn off airplane mode.  I don’t want my phone continually in airplane mode.

The fix worked for me however since I did that I have no data. I cannot get on the internet unless I'm connected to Wi-Fi. I called customer service on Tuesday they said they would contact LG and get back to me. I've heard nothing.

Worked for me, but I had to find it on line (NO HELP FROM TMOBILE!) I called my “ T-Mobile team EXPERT representative” to get resolution, of course you’re speaking with someone in Asia who just gives lip service saying I was number one priority when they fix it. Asked to speak with an American (to hopefully get a more clear/honest/informed answer, but never received a call back, go figure). So went to a T-Mobile store and was told LG stopped pushing updates to their phones and I would just have to upgrade to a new phone (We have 3 of them that we bought through Tmobile). Their spring-loaded EZ answer since it’s not their money- just buy new phones.... Seems like T-Mobile should own some of this, been a customer for almost 20 years. T-MOBILE AMERICA, ARE YOU LISTENING?

Userlevel 7
Badge +14

The fix worked for me however since I did that I have no data. I cannot get on the internet unless I'm connected to Wi-Fi. I called customer service on Tuesday they said they would contact LG and get back to me. I've heard nothing.

My phone is working fine still after 2 days.

I thought the fix I found online had worked as long as I kept my phone in airplane mode.  But now it is still doing it. I don’t like iPhones but I am seriously considering switching.  

This is the fix for all lg phones if it does not work try it again and make sue to follow directions.

Body Roc wrote:

I got this fix 5/24/22 it's similar to many others. They don't work this one does. It's from a LG engineer.

 

Put the affected LG phone in airplane mode by pulling down the notification shade and tapping on the plane icon.

 

Putting the phone in airplane mode should stop the IMS error message from popping up.

 

Open the phone's settings and tap on Apps and Notifications, followed by App Info.

 

On the App Info page, click on the three-dot menu icon in the top-right corner of the screen and tap on Reset App Preferences, then tap on Show System.

 

Look on the app list for "com.lge.ims.rcsprovider" and tap on to open the next page. Doing so will pull up the pre-installed IMS provider app's detailed overview.

 

Once there, tap on the clear data/cache option, then clear storage, then force stop. 

 

Then restart the phone. If the pop up happens anytime during this. Restart phone and do again.

 

 

Worked for me, but I had to find it on line (NO HELP FROM TMOBILE!) I called my “ T-Mobile team EXPERT representative” to get resolution, of course you’re speaking with someone in Asia who just gives lip service saying I was number one priority when they fix it. Asked to speak with an American (to hopefully get a more clear/honest/informed answer, but never received a call back, go figure). So went to a T-Mobile store and was told LG stopped pushing updates to their phones and I would just have to upgrade to a new phone (We have 3 of them that we bought through Tmobile). Their spring-loaded EZ answer since it’s not their money- just buy new phones.... Seems like T-Mobile should own some of this, been a customer for almost 20 years. T-MOBILE AMERICA, ARE YOU LISTENING?

Call your team of experts and politely ask for a $100. bill credit to help offset the cost of a newer phone. Order the phone from the tmobile site to save the $30.00 “assistance" fee they charge at the store or if an expert from customer support orders it. I too have been a customer for more than 20 years. Tmobile really is the best of the branded carriers.

I just saw this post but I had previously called and told them I wanted $100 off of a new phone. Woman said she'd get back to me and never did so I called again. I insisted and they gave me $100 off but I ended up paying $6.99 for shipping and the $30 activation or whatever the heck it is. I didn't know about ordering online. I got a pixel 6.

I have had no data service since I applied the LG fix last Sunday. Three calls to T-Mobile did not solve the problem so I'm forced to buy a new phone.

Like poster above I've been a customer for 20 years. The agent from the Philippines told me that I have been a customer longer than he's been alive.

Reply