Solved

LG V30 Oreo broke bluetooth audio


After updating to Oreo via the OTA release, bluetooth audio now skips/stutters constantly.  Before the update it never skipped at all.  Anyone else experiencing this yet?  Hardware/Software info:  LG V30 LG-H932 Rev.1.0 from T-mobile.  Android v 8.0.0, 4.4.78 kernel, h93320h software.   The only bluetooth audio device that I use it with (so the only I've tested with so far) is my vehicles Pioneer AVH-X2600BT head unit.

icon

Best answer by tmo_mike_c 13 June 2018, 16:45

View original

135 replies

I see that this problem with bluetooth has been going on for sometime.  I'm only experiencing it for over a month.  I believe I did send a text to the Tech support, but never got a reply.  It IS frustrating!!!!!!!!!!!!!!!  I have to restart my phone all the time.  It will revive/connect the bluetooth after a restart, but it doesn't hold the connection.  It'll get disconnected again.  I've followed everything, including updates.  It was frustrating when I had to pair my watch.  Had to keep restarting, connect, disconnect and restart again. Can LG do something about it?  Or is it T-Mobile who's got the issue. 

Userlevel 1

Yes I tried all the above since this started including the recent "update" and still had skipping. I have moved on to the Note 9 and am very happy.

Userlevel 6
Badge +15

@djjstew did you not get an update that the others are referring to? I suggest checking to see if there's an update and letting us know if the skipping goes away.

Userlevel 1

I was hoping this was true but, at least for me, the skipping continued.  I use BT in my ear and in my car and if I'm not on the phone I like to listen to music, books and podcasts.  So I gave up and traded in my V30 for a Note 9 taking advantage of a pretty good trade in deal.  I blame LG for this not T-Mo since I have seen posts about this on other carriers.  Either LG does not care or it's a hardware problem or both.  I am very happy with my choice with the Note 9, no skipping, great pictures, beautiful screen and well much more.  Good luck everyone!

Confirmed - no skipping after Oct 1 2018 update to H93220o (t-mobile).  Would be nice if there were release notes somewhere. I tried LG's support site and not only are there no release notes, they list H932220k ast the last update -lol. Sad.  BUT, I'm glad my phone is working without issue now so thanks for that!!

Agreed after the update everything has been great. 

Yeeeeeeees!  Thanks for the heads up.  I updated and I haven't had a single skip. I haven't been able to use my Bluetooth for music and what seems for forever. I'm so glad to have this feature back.

For me, the skipping appears to be resolved in the new October update.  I have the TrackR app installed and connected to devices and I have yet to hear it skip since yesterday.

Same thing here. I have Tile app installed, and could get a workaround for BT skipping issue once followed directions posted by magenta1550128. Thanks for the directions! Waiting for permanent fix from LG though...

After reviewing all of the posts and troubleshooting my V30, I can confirm that this is a problem with the BLE / location feature.  For me, it was the Tile app.  Once I denied it location access, the BT stopped cutting out / skipping.  This is a huge problem though, since many people use apps like this, but looking at the logs and times of the drops, this feature is what's causing it.

None of this is fixed. TMobile are responsible to talk with the

manufacturer. They are not. Not going with them after the Galaxy 10 comes

out. Project Fi all the things.

Deleting the TrackR app fixed the issue for me too, but I believe it's an issue with the BTLE (Bluetooth Low Energy) stack.

For one, I have never gotten the Pokémon Go Plus device to connect to this phone.

If I unpair my Fitbit and reconnect it, audio will skip at the start of the re-pair.

If I try to connect to one of my TrackR devices without the app installed, it will skip everytime I try to connect in the Bluetooth menu.

I found the solution to my problem was to delete Trackr app. I would advice anyone with an app that takes total and constant control of bluetooth to delete the app. Once I deleted TrackR app I enjoy using all 7 of my bluetooth audio devices without a problem.

Hey folks,

I recently had this come up too. I had been using a Samsung Gear S3 watch for a while but then stopped wearing it. Today I charged and put it back on and reset the watch and app, and lo and behold, my skipping problem is gone!

The only thing I can assume is that the Samsung Gear app (now called Galaxy Wearable) was trying to reconnect, repair, or something and kept resetting my Bluetooth. Check your devices for this app! If you've used a smart watch this could be your ticket back to sanity. Good luck!

No it is not.

I'm still skip free. I didn't do anything so is this issue fixed?

I actually have been skip free for a week.

However if the screen is on I get skipping. If the screen is black it

doesn't. It makes me think it's not a Bluetooth issue but a RAM management

issue, but devices disappear that have been preciously paired.

Anyway I'm enjoying my skip free period. I've decided to move on from the

phone once another model I like is released.

I experienced the skipping for the very first time on Monday.  I just started searching fixes today and tried everything that was recommended with no success.  Sounds like the suggestion now is to create a ticket with LG - I'll try that.

If it's worth anything - I don't know if I've observed a pattern or a coincidence, but I first had trouble when I was using bluetooth while charging.  When I unpaired all devices, cleared the cache, and restarted my phone, I thought it might have been fixed (only for about 1 or 2 minutes) until I put it on the charger again.  I might try that method again to see if BT is at least usable when I'm not charging the battery.

Ikr

Don Schroeder

***-***-****

***@******.net

Sent from my T-Mobile 4G LTE Device

Funny thing is I haven't had skipping the last two days. I didn't do

anything to the phone but pair it to a rental car. It did skip for the

first day or two but it hasn't in a couple days. This happened when I

bought my Sennheiser BT headphones on Amazon Day. They didn't skip for a

week.

I fully expect the skipping to return. I plan on ditching this phone for

the OnePlus 6T. I have liked the phone but it was the 1st carrier branded

phone I have had since the Samsung GS3. I would have modded the phone by

now but I am tired of having to root and get Rooms for solutions.

When do we get to sue for our money back?

I sold my V-30, and I am using a Samsung Galaxy s9 and no skipping

Userlevel 1

I have been following this for a while and did all the suggested fixes and nothing.  The skipping drives me crazy!  During my workouts went back to wired headphones but for business uses and the car that is not the solution.  I have been seriously thinking of selling this great phone and moving on at this point just waiting for a phone to jump out and say do it!  Thanks for everyone on here trying to fix a problem created by Google/LG (hard to blame T-Mo since the issues in on other carriers).

@ofsinreno Let's not confuse the issue.  On my LG V30 I'm not losing data and we have no proof that is a common issue. However, we do know that BT "skips".  It doesn't lose connection, just the playback "skips".  It's still happening.  Please get LG to fix this.   My $800+ phone should not have crappier audio than my old Samsung Galaxy S3 and my 8 year old unlocked BLU phone.  That's just not acceptable.

Still broke AF

Nope. Still fecked.

Reply