LTE and Wifi Issue after 5.1.1 update

  • 29 September 2015
  • 14 replies

After the recent T-Mobile OTA update on my Samsung Galaxy S6 edge (64GB), I have begun having issues with receiving calls, that I have figured out to be somehow related to LTE and WiFi.


After the update, whenever I would disconnect from Wifi, my phone would only show a 4G symbol. Initially I didn't think much of it, but then I check under Mobile networks, and it was set to WCDMA/GSM. So I changed it to LTE/WCDMA/GSM. As expected, I started getting the 4G-LTE symbol and my internet speed went up as well. But this is where the problem started with my calls. The phone works fine until you connect to a wifi, and that's when the calls stop coming. I would have people calling me, some would get my voicemail, others, there would be no ringing at all. This happened for a few days, and I restarted my phone over and over and the problem would go away temporarily, but when I would connect to LTE and then go on Wifi again, the problem would start all over again.


So the short term solution is, if you don't want to miss any calls switch your phone to WCDMA/GSM, and it will solve the no call issue. However, this is only a temporary solution. I got the S6 edge as an LTE phone and I should not have to worry about having to switch back and forth and restarting my phone.


I have, twice, done a hard reset on my phone, but that has not solved the problem!

I have read on other websites that other people are having similar issues after the update.


If anyone else is having similar issues please post here so we can make T-Mobile aware of this issue, or if you have found a solution, please let me know. I love T-Mobile plans and it's service, I would expect that you guys would get to the bottom of this ASAP and find a fix.


Best answer by tmo_lauren 30 October 2015, 19:23

Hey there!

Thanks everyone for bringing this to our attention, it sounds like we may want to do some direct troubleshooting to take a closer look into this. If you haven't already, please Community-2153 directly so we can take a closer look! 😊


View original

14 replies

Update: Went to the T-Mobile store yesterday, they told me to switch my Wifi calling settings to cellular preferred. To clarify, I never had my Wifi calling on when having this issue, but they said it sometimes may be the issue. So I did it, came home, 30 minutes or so later, getting no calls on my phone, it's either going to VM or nothing at all. Going to go back again today.

I am experiencing the same issue on my Galaxy S6 after the update. Friends are telling me that their calls go straight to voicemail - this is temporarily fixed for only about five minutes or so after I restart my phone. Texts are not coming through properly either – I have to restart my phone and all the missed text messages suddenly flood in at once.

I have been on the phone with T-Mobile technical support regarding this issue over five times already, and they have not been able to resolve the issue. The last agent offered to do an exchange for me, but I am experiencing the exact same issue on the replacement phone!

This is unacceptable – I should not have to keep restarting my phone throughout the day and worry about missed calls or texts. I suggest asking for a credit on your next bill, as the service is pretty much unusable at this point.

@aisley‌ Hi,

Thanks for posting, you are right, it is unacceptable. Mine is still having issues, I haven't had time to call or go back yet. Try the temporary fix that I posted above and see if it helps with the calls, Go to Settings > Mobile Networks > Network mode > WCDMA/GSM. When I do that, my calls are fine, but I just don't get LTE when i'm out. I'll let u know if I find out anything else.

@arkdr‌ Thanks, I will try your temporary fix. Will keep you posted if I figure something else out. At this point, I'm considering asking T-Mobile to send a second replacement and just not updating it.

I'm also having this exact issue and I'm on my 2nd phone with no luck.

I am also having the exact same problem with my Galaxy S6 after the update.  Calls going straight to voicemail and the voicemail not showing up until 20 minutes later.  Talked to Tmobile and they had me change setting to Do Not Use VoLTE on the phone.  Did that and it did NOT fix the problem.  I have talked to Tmobile a bunch of times over the last couple of weeks and they are not aware that this is a problem. 

I am surprised that no one from the T-Mobile community has made an effort to address this issue on here. I would at least expect them to say that they are looking into it, given that so many people are having this problem. Mine is on and off, I have to keep it at the setting above to make sure I get calls, but no fixes yet. Sometimes when I switch it back to LTE it works, but then a couple of days later the same problem. T-Mobile, please address this issue and let us know what to do.

Thank You.

I've noticed I'm having this problem when I'm at home and using the T-Mobile provided WiFi router. I haven't noticed having this issue when I'm on the WiFi at work. Is anyone else also using the T-Mobile WiFi router?

I have the same fix was to turn off Wifi and I can receive and send text messages and people can call me.  I also have WiFi Calling off as well.  If I am wanting to use WiFi I realize that my text messages and phone calls will be effectively disabled.

@matrix23 - I'm not using a T-Mobile router at home. I have yet to try on another router to see if it makes a difference or not. Mine was fixed for like a day by itself, but the next day I started having the problem again, so had to switch my settings back to WCDMA/GSM.

Have any of you tried the temporary fix that I mentioned? Give it a try and let me know, will try to call T-Mobile this weekend to get this issue addressed.

Userlevel 5

Hey there!

Thanks everyone for bringing this to our attention, it sounds like we may want to do some direct troubleshooting to take a closer look into this. If you haven't already, please Community-2153 directly so we can take a closer look! 😊


Why is this thread marked as answered?  I am having the exact same problem and see no info on how this was fixed.  This issue must be related to the Android 5.1.1 update since my husband also has a Samsung S6 except he is keeping his at 5.0.2 and is having no issues.  I want to leave LTE on and still use my phone to receive live calls (not go straight to voicemail).  What is the solution to this problem?

Userlevel 5

You would want to contact us directly for troubleshooting to search for resolution!

Contact Us | T-Mobile Support 

@arkdr‌ is right. The only thing that seems to somewhat fix it is to disconnect the LTE by only enabling CDMA/GSM. However, I have experienced trouble both making and receiving call even in this mode.

@tmo_lauren I have contacted T-Mobile regarding this issue and the T-Mobile support tried to fix it by re-registering me on the network. It never fixed the problem.

I really hope Android 6.0 will fix this or I might change phone service. I like the phone and want to stick with it so maybe some other network can provide better support.